S7700 No Multicast trafic after activating multicast drop-unkown on a VLAN

Created: Jan 22, 2019 15:56:16Latest reply: Jan 24, 2019 10:56:21 317 2 0 0
  Rewarded Hi-coins: 0 (problem resolved)

I'm triing to set up a multicast network with about 35 multicast groups in a single VLAN

All groups apear on interfaces of that VLAN so I activated multicast drop-unkown on a VLAN, after that, no more multicast trafic on hosts.

I can see  l2-multicas forword-table groups and on igmp-snooping port-info.

Multicast source is on int gi5/0/12


Config:


!Software Version V200R010C00SPC600
#
sysname DTC Herdade
#
vlan batch 2 to 9 467 500
#
loopback-detect auto disable
#
set multicast forwarding-table super-mode
#
authentication-profile name default_authen_profile
authentication-profile name dot1x_authen_profile
authentication-profile name mac_authen_profile
authentication-profile name portal_authen_profile
authentication-profile name dot1xmac_authen_profile
authentication-profile name multi_authen_profile
#
assign multicast-resource-mode optimize
igmp-snooping enable
igmp-snooping send-query enable
igmp-snooping send-query source-address 10.0.0.1
#
telnet server enable
#
access-user arp-detect default ip-address 0.0.0.0
#
clock timezone UTC add 00:00:00
#
ecmp local-preference disable
#
arp learning ip-network-cross enable
#
dhcp enable
#
undo portal url-encode enable
#
set flow-change-ratio input-broadcast-detect disable
#
diffserv domain default
#
radius-server template default
radius-server shared-key cipher %^%#bX)B+Cm<cRZ#(rTECB/*6ANdQL9A)FcG7"3on0xO%^%#
#
free-rule-template name default_free_rule
#
portal-access-profile name portal_access_profile
#
drop-profile default
#                                        
vlan 500
multicast drop-unknown
igmp-snooping enable
igmp-snooping querier enable
#
aaa
authentication-scheme default
authentication-scheme radius
 authentication-mode radius
authorization-scheme default
accounting-scheme default
domain default
 authentication-scheme default
domain default_admin
 authentication-scheme default
local-user admin password irreversible-cipher %^%#hP~!"3Pm4-$#s35gvjw$(=nC1hFNIQ{b{*8S'`QMw^Pr>^~85+ZdOUN:"/GP%^%#
local-user admin privilege level 15
local-user admin ftp-directory cfcard:/
local-user admin service-type telnet terminal ssh ftp http
#
interface Vlanif2
description "VLAN 2 / Rede HDG
ip address 172.20.10.253 255.255.255.0
#                                        
interface Vlanif3
description "VLAN 3 / Tel. Clientes"
ip address 172.20.11.253 255.255.255.0
#
interface Vlanif4
description "VLAN 4 / Tel. Servicos"
ip address 172.20.12.253 255.255.255.0
#
interface Vlanif6
ip address 172.20.18.253 255.255.255.0
dhcp select interface
dhcp server ip-range 172.20.18.10 172.20.18.250
dhcp server gateway-list 172.20.18.253
#
interface Vlanif7
description "VLAN 7 / Gestao
ip address 172.20.19.253 255.255.255.0
#
interface Vlanif500
ip address 10.0.0.1 255.255.255.0
#
interface Ethernet0/0/0
#
interface GigabitEthernet2/1/0            
#
interface GigabitEthernet2/1/1
#
interface GigabitEthernet2/1/2
#
interface GigabitEthernet2/1/3
#
interface GigabitEthernet2/1/4
#
interface GigabitEthernet2/1/5
#
interface GigabitEthernet2/1/6
#
interface GigabitEthernet2/1/7
#
interface GigabitEthernet5/0/0
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/1
description "Rede Gestao"
port link-type access
port default vlan 7                      
#
interface GigabitEthernet5/0/2
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/3
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/4
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/5
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/6
description "Rede Gestao"
port link-type access                    
port default vlan 7
#
interface GigabitEthernet5/0/7
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/8
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/9
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/10
description "Rede Gestao"
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/11
description "Rede Gestao"                
port link-type access
port default vlan 7
#
interface GigabitEthernet5/0/12
description "Rede IPTV"
port link-type access
port default vlan 500
#
interface GigabitEthernet5/0/13
description "Rede IPTV"
port link-type access
port default vlan 500
#
interface GigabitEthernet5/0/14
description "Rede IPTV"
port link-type access
port default vlan 500
#
interface GigabitEthernet5/0/15
description "Rede IPTV"
port link-type access
port default vlan 500
#                                        
interface GigabitEthernet5/0/16
description "Rede IPTV"
port link-type access
port default vlan 500
#
interface GigabitEthernet5/0/17
description "Rede IPTV"
port link-type access
port default vlan 500

  • x
  • convention:

Featured Answers
chenhui
Admin Created Jan 23, 2019 01:19:26 Helpful(0) Helpful(0)

@ACorreia hi,
please check the multicast foward information, are there (s,g) items with unreserved multicast destination address. cause when configuring multicast drop-unknown, those traffic with reserved multicast destination address will not be forwarded either.
  • x
  • convention:

All Answers
chenhui
chenhui Admin Created Jan 23, 2019 01:19:26 Helpful(0) Helpful(0)

@ACorreia hi,
please check the multicast foward information, are there (s,g) items with unreserved multicast destination address. cause when configuring multicast drop-unknown, those traffic with reserved multicast destination address will not be forwarded either.
  • x
  • convention:

ACorreia
ACorreia Created Jan 24, 2019 10:56:21 Helpful(0) Helpful(0)

Hi cWX611640, thanks for the help,
The (s,g) appears as (*,g), I didn't configure the ssm mapping. Yesterday I've done some testes and I discovered that it works with any group from 224.0.1.1 to 224.127.255.255. The same is true to all other groups from 224 to 239.
If I use, for example, 239.127.1.1 it works, but if I use 239.255.1.1, beside the MAC address is the same (01-00-5e-7f-01-01), it doesn't work.
I'm not sure, but it seams to bee related with multicast-hash-mode.
Next week I'll do some testes with that.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login