Got it

s5720-28x-si-ac SNMP port diagnostic

Created: May 14, 2017 11:07:04Latest reply: Sep 16, 2018 11:08:49 1535 2 0 0
  Rewarded HiCoins: 0 (problem resolved)
This post was last edited by Nexzis at 2017-05-14 12:43. Hello, i had switch s5720-28x-si-ac and i have a problem.i need to make port diagnostic (enabled/disabled) with SNMP protocol in our SCADA system, but i with all setting on my SCADA i dont recieve any signal from switch. I used different OID and all types of signal in SCADA to check it.Mb i got some wrong setting on switch? Can u tell me what kind of setting i should make to recieve any signals with OID? Or mb i used wrong OIDs
  • x
  • convention:

Featured Answers

Recommended answer

Martian_superman
Created Sep 16, 2018 11:08:49 Helpful(0) Helpful(0)

from my point for view, this is just SNMP configuration issue, you can follow the SNMP agent configuration example in the product documentation:

below is an example of configuring SNMP V3 between switch and NMS tool:

#
sysname Switch
#
vlan batch 100
#
acl number 2001
rule 5 permit source 10.1.1.2 0
rule 6 deny source 10.1.1.1 0
#
interface Vlanif100
ip address 10.1.2.1 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type hybrid
port hybrid pvid vlan 100
port hybrid untagged vlan 100
#
snmp-agent
snmp-agent local-engineid 800007DB0300259E0370C3
snmp-agent sys-info contact call Operator at 010-12345678
snmp-agent sys-info version v3
snmp-agent group v3 admin privacy write-view isoview acl 2001
snmp-agent target-host trap address udp-domain 10.1.1.2 params securityname nms2-admin v3 privacy
snmp-agent mib-view included isoview iso
snmp-agent usm-user v3 nms2-admin
snmp-agent usm-user v3 nms2-admin group admin
snmp-agent usm-user v3 nms2-admin authentication-mode sha cipher %$%$cDjJA|yOjEak%@M]MO~Rh';<%$%$
snmp-agent usm-user v3 nms2-admin privacy-mode aes128 cipher %$%$Adem8-N9(H/*WOE2,IIQh'Nw%$%$
#
return
View more
  • x
  • convention:

All Answers
New_commer
New_commer Created May 16, 2017 01:09:59 Helpful(0) Helpful(0)

have you configured SNMP in the switch
View more
  • x
  • convention:

Martian_superman
Martian_superman Created Sep 16, 2018 11:08:49 Helpful(0) Helpful(0)

from my point for view, this is just SNMP configuration issue, you can follow the SNMP agent configuration example in the product documentation:

below is an example of configuring SNMP V3 between switch and NMS tool:

#
sysname Switch
#
vlan batch 100
#
acl number 2001
rule 5 permit source 10.1.1.2 0
rule 6 deny source 10.1.1.1 0
#
interface Vlanif100
ip address 10.1.2.1 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type hybrid
port hybrid pvid vlan 100
port hybrid untagged vlan 100
#
snmp-agent
snmp-agent local-engineid 800007DB0300259E0370C3
snmp-agent sys-info contact call Operator at 010-12345678
snmp-agent sys-info version v3
snmp-agent group v3 admin privacy write-view isoview acl 2001
snmp-agent target-host trap address udp-domain 10.1.1.2 params securityname nms2-admin v3 privacy
snmp-agent mib-view included isoview iso
snmp-agent usm-user v3 nms2-admin
snmp-agent usm-user v3 nms2-admin group admin
snmp-agent usm-user v3 nms2-admin authentication-mode sha cipher %$%$cDjJA|yOjEak%@M]MO~Rh';<%$%$
snmp-agent usm-user v3 nms2-admin privacy-mode aes128 cipher %$%$Adem8-N9(H/*WOE2,IIQh'Nw%$%$
#
return
View more
  • x
  • convention:

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."

My Followers

Login and enjoy all the member benefits

Login

Huawei Enterprise Support Community
Huawei Enterprise Support Community
Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.