S5700 VLAN configuration

Latest reply: Aug 12, 2019 14:32:08 5346 8 0 0

Hi, 

We have a S5700 LI switch and I would like to program on each port except the port to the other switches (which is a trunk port) a voice and data VLAN. 

VLAN's on the current switches are:

VLAN 1 = DATA

VLAN2 =  VOICE

When I add a VLAN 2 to say port 0/0/1 VLAN 1 is ruled out and can't seem to add it. 

What we are adding on the ports are an IP Phone (on VLAN 2) and attached to the phone is a pc/laptop on VLAN 1

What do I need to do to get both VLAN's operational so the phone auto goes to the Phone System on VLAN 2 and the computer finds its way on VLAN 1? 

Best regards,

Edwin

  • x
  • convention:

p00187531
Created Sep 5, 2014 02:03:25 Helpful(0) Helpful(0)

Hi, this can be  refered to the voice-vlan configuration from the product manual guide

1)conifg the voice-vlan OUI in system view(ip phone's mac address)

voice-vlan mac-address XX-XX-XXmask ffff-ff00-0000  avaya  

(2)config the port which cnnect to the IP PHONE

interface GigabitEthernet0/0/1

description (USER CONNECTION )

voice-vlan 2 enable include-untagged   /*
add the voice-vlan  tag 2 to the voice data*/
voice-vlan remark-mode mac-address

port hybrid pvid vlan 1

port hybrid untagged vlan 1 2  

trust 8021p

  • x
  • convention:

who_knows
Created Sep 5, 2014 02:05:36 Helpful(0) Helpful(0)

IP phone and pc/laptop connect to different ports, and different ports add different vlans.

  • x
  • convention:

edwin_boellaard
Created Sep 5, 2014 06:12:20 Helpful(0) Helpful(0)

Quote 3 #

IP phone and pc/laptop connect to different ports, and different ports add different vlans.

l00192083 Post On 2014-09-05 02:05


This I don't understand. Our IP Phones have an ethernet port on the back where the workstation is connected to. This works on our HP switches and the port distinct the traffic for voice and data via the vlans. 

  • x
  • convention:

who_knows
Created Sep 5, 2014 07:47:46 Helpful(0) Helpful(0)

So you connect these devices like this:

Switch----IP phone----pc/laptop

right?

How do you configure the port of switch which connect to IP phone?

  • x
  • convention:

edwin_boellaard
Created Sep 5, 2014 07:55:02 Helpful(0) Helpful(0)

Hi 

That is correct. 

Now for the port config, that is my question :) 

This is what I see in the current HP switches (see attached)

This is installed by my predecessor. I already start to doubt if it would be wise to keep VLAN 1 for the general data and VLAN 2 for voice. 



This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

c00903737
Created Oct 30, 2014 14:34:29 Helpful(0) Helpful(0)

I think the below configuration should work for you

lldp enable

#

interface g0/0/1
voice-vlan 40 enable                                   (enable voice VLAN40, LLDP informs phone to use VLAN 40)
voice-vlan mode manual                              (all access ports are manual ports)
undo voice-vlan security enable                     (aka normal mode, allows both voice and data traffic in voice vlan) 
voice-vlan legacy enable                               (allows compatibility with Cisco/CDP phones)
port hybrid pvid vlan 30
port hybrid tagged vlan 40                             (switch expects voice traffic to arrive in vlan 40 and tags packets outoubnd)
port hybrid untagged vlan 30                          (vlan 30 packets for PC are untagged outbound from port)
stp bpdu-filter enable
stp edged-port enable
trust 8021p

  • x
  • convention:

GTC
Created Jun 23, 2015 19:08:56 Helpful(0) Helpful(0)

On the phone do we need to mention the voice VLAN ID ?


  • x
  • convention:

VGL639G
Created Aug 12, 2019 14:32:08 Helpful(0) Helpful(0)

Hello

I am trying to configure voice vlan on the S5720-28X-PWR-LI-AC which is getting a link from Cisco switch but i can't seem to get it right. My scenario looks more like this, Cisco6500Core---->Cisco2960-------->HuaweiS5720

All the scopes are configured on the 6500 & all the access switches are pulling the vlans from the core, all access switches can ping all the vlans(dat+voice).

Now on the S5720 i have configured Voice Vlan30 & Data Vlan2 as follows

#
interface Vlanif30
dhcp select global
#
#
vlan batch 2 to 3 8 to 9 30 100 240 247 to 254
#
stp mode stp
#
dhcp enable
Lldp enable
#

interface GigabitEthernet0/0/24
description Cisco-IP-Phone
port link-type hybrid
voice-vlan 30 enable
voice-vlan legacy enable
port hybrid pvid vlan 2
port hybrid tagged vlan 30
port hybrid untagged vlan 2
trust 8021p
#

And the link port to Cisco2960 configs below:

#
interface XGigabitEthernet0/0/1
description link to cisco2960-sw1: Trunk
port link-type trunk
port trunk allow-pass vlan 2 to 4094
lldp compliance cdp receive
trust 8021p
#

The pc can get a dhcp ip address successfully but the Cisco IP phone is not getting any ip address, error: PHONE NOT REGISTERED

[Huawei-cctv1]display voice-vlan status
Voice VLAN Configurations:
-----------------------------------------------------------
Voice VLAN ID : 30
Voice VLAN status : Enable
Voice VLAN 8021p remark : 6
Voice VLAN dscp remark : 46
-----------------------------------------------------------
Port Information:
-------------------------------------------------------------------------------
Port Add-Mode Security-Mode Legacy PribyVLAN Untag
-------------------------------------------------------------------------------
GigabitEthernet0/0/24 Manual Normal Enable Disable Disable
[Huawei-cctv1]

On the cisco side i have enable LLDP & i can ping the Huawei & the link configs below
!
interface GigabitEthernet0/2
switchport mode trunk
!

What am i missing here?
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login