Router connecting to ISP modem

Created: Sep 6, 2017 16:21:12Latest reply: Sep 8, 2017 13:43:33 1712 6 0 0
  Rewarded Hi-coins: 5 (problem resolved)
Hi I want to ask for help for my pc to connect to the internet.

this is the set up:

Modem > Router > Switch > PC

NAT is on the modem, this is an ISP modem that has a 172.16.105.0/24 network,
what should I configure on the router for me to have 2 network with 10.10.10.0/24 and 10.10.20.0/24, but only the 10.10.20.0/24 network can access the internet.

Thank you
  • x
  • convention:

Featured Answers
Created Sep 6, 2017 16:21:13 Helpful(0) Helpful(0)

on your router you can configure this:
#
acl number 2000
rule 5 permit source 10.10.10.0 0.0.0.255
#
interface GigabitEthernet0/0/0
ip address 172.16.105.100 255.255.255.0
traffic-filter outbound acl 2000
#
vlan batch 10 20
#
dhcp enable
#
ip pool vlan10
network 10.10.10.0 mask 24
dns 8.8.8.8
gateway 10.10.10.1
#
ip pool vlan20
network 10.10.20.0 mask 24
gateway 10.10.20.1
#
interface vlan 10
ip address 10.10.20.1 24
#
interface vlan 20
ip address 10.10.20.1 24
#
ip pool vlan10
network 10.10.10.0 mask 24
#
ip route-static 0.0.0.0 0.0.0.0 172.16.105.1
#
interface ethernet 0/0/0
port link-type access
port defaaut vlan 10
#
interface ethernet 0/0/1
port link-type access
port defaaut vlan 20

or interface ethernet 0/0/0
port link-type trunk
port trunk all vlan 10 20
#
quit
#
save
  • x
  • convention:

All Answers
blacktiger Created Sep 6, 2017 16:21:13 Helpful(0) Helpful(0)

on your router you can configure this:
#
acl number 2000
rule 5 permit source 10.10.10.0 0.0.0.255
#
interface GigabitEthernet0/0/0
ip address 172.16.105.100 255.255.255.0
traffic-filter outbound acl 2000
#
vlan batch 10 20
#
dhcp enable
#
ip pool vlan10
network 10.10.10.0 mask 24
dns 8.8.8.8
gateway 10.10.10.1
#
ip pool vlan20
network 10.10.20.0 mask 24
gateway 10.10.20.1
#
interface vlan 10
ip address 10.10.20.1 24
#
interface vlan 20
ip address 10.10.20.1 24
#
ip pool vlan10
network 10.10.10.0 mask 24
#
ip route-static 0.0.0.0 0.0.0.0 172.16.105.1
#
interface ethernet 0/0/0
port link-type access
port defaaut vlan 10
#
interface ethernet 0/0/1
port link-type access
port defaaut vlan 20

or interface ethernet 0/0/0
port link-type trunk
port trunk all vlan 10 20
#
quit
#
save
  • x
  • convention:

WoodWood Created Sep 6, 2017 18:17:51 Helpful(0) Helpful(0)

please help@kmyd @撒么
  • x
  • convention:

lucian2003 Created Sep 7, 2017 01:29:14 Helpful(0) Helpful(0)

Hello this configuration is only ip whith acces internet the other IP LAN whithout acces internet work ok in switch

Configuration on router Huawei take http://support.huawei.com/enterprise/docinforeader.action?contentId=DOC0100585934&idPath=7919710%7C21432787%7C7923148%7C9858988%7C6078836
INTERNET/NAT

#
sysname Router //Set the device name.
#
acl number 2000 //Configure the IP address segment on which IP addresses can be translated using NAT as 10.10.20.0/24
rule 5 permit source 10.10.20.0 0.0.0.255
#
interface Ethernet0/0/1
undo portswhich
ip address 10.10.20.1 255.255.255.0 //Configure an IP address for the intranet gateway.
#
interface GigabitEthernet0/0/1
ip address 172.16.105.1 255.255.255.0
nat outbound 2000 //Configure Easy IP on outbound interface GE0/0/1.
#
ip route-static 0.0.0.0 0.0.0.0 172.16.105.1 //Configure a default route between the outbound interface to the remote interface and ensure that the route is reachable.
#
  • x
  • convention:

orlan_ortiz MVE Created Sep 8, 2017 13:41:53 Helpful(0) Helpful(0)

does it mean I need to do double natting,because on the ISP modem there is already a NAT, will it affect my network once a single nat has been down?
  • x
  • convention:

Success%20can%20be%20achieved%20through%20hardwork%20and%20perseverance
orlan_ortiz MVE Created Sep 8, 2017 13:43:01 Helpful(0) Helpful(0)

Posted by lucian2003 at 2017-09-07 01:29 Hello this configuration is only ip whith acces internet the other IP LAN whithout acces internet wo ...
Hi lucian2003 thank you :)
  • x
  • convention:

Success%20can%20be%20achieved%20through%20hardwork%20and%20perseverance
orlan_ortiz MVE Created Sep 8, 2017 13:43:33 Helpful(0) Helpful(0)

Posted by yaba.mobhe at 2017-09-06 16:21 on your router you can configure this:#acl number 2000rule 5 permit source 10.10.10.0 0.0.0.255#inte ...
Hi yaba.mobhe thank you :)
  • x
  • convention:

Success%20can%20be%20achieved%20through%20hardwork%20and%20perseverance

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top