QinQ between Huawei and Extreme Networks

Created: Aug 20, 2019 21:56:24Latest reply: Aug 23, 2019 20:15:52 290 9 1 0
  Rewarded Hi-coins: 0 (problem resolved)

Hello Dears,


I'm running S5720-56C-EI-DC with V200R010C00SPC600, and we have a 10g port as trunk port to other switch (in this case Extreme X460), nonetheless on the huawei configuration there is one qinq vlan id 4000, with ethertype default 0x8100, so, and in the other side one Extreme as ethertype set up as 0x88A8.

So, in order to get compatibility between them i set up extreme switch as ethertype 0x8100, and then I noticed that all vlans including vlans tagged over that port stopped working,

However, I thought that it could be some thing on Extreme configuration, returned the default to 0x88A8, and then started changing the ethertype on Huawei to 0x88A8, and it didn't take any effects.


interface GigabitEthernet0/0/11

description CLIENTE_A

qinq protocol 88a8

port link-type hybrid

qinq vlan-translation enable

undo port hybrid vlan 1

port hybrid tagged vlan 175

port hybrid untagged vlan 4000

port vlan-stacking vlan 700 stack-vlan 4000

port vlan-stacking vlan 1000 to 1300 stack-vlan 4000

port vlan-stacking vlan 3550 stack-vlan 4000


interface Eth-Trunk0

 description TRUNK-SW_EXTREME-20GB

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 175 3011 3218 4000 4076

 mode lacp



I tried the same scenario over eNSP and there it worked properly just setting up "qinq protocol 88A8" into the interface Eth-trunk0 , or simply changing the ethertype default on Extreme to 0x8100, but I don't understand why in a real situation the S5720 is not working like eNSP.

Can some help me with that pls?


I've been getting a headache with that.


Cheers.



  • x
  • convention:

Featured Answers
chenhui
Admin Created Aug 21, 2019 03:20:37 Helpful(0) Helpful(0)

@welisson_br hello,
For V200R010 and later versions, command qinq protocol can be configured on the Eth-Trunk but not Eth-Trunk member interfaces. Please configure this command on the eth-trunk interface rather the memmer interface.
  • x
  • convention:

All Answers
chenhui
chenhui Admin Created Aug 21, 2019 03:20:37 Helpful(0) Helpful(0)

@welisson_br hello,
For V200R010 and later versions, command qinq protocol can be configured on the Eth-Trunk but not Eth-Trunk member interfaces. Please configure this command on the eth-trunk interface rather the memmer interface.
  • x
  • convention:

welisson_br
welisson_br Created Aug 21, 2019 14:30:31 Helpful(0) Helpful(0)

Posted by chenhui at 2019-08-20 16:20@welisson_br hello,For V200R010 and later versions, command qinq protocol can be configured on the E ...

@chenhui hello,

I did that configurations and even have done it, the comunications went down.

We can't have any comunications with the other switch through the vlans tags(l2 or L3) and the qinq didn't work as well.

Cheers
  • x
  • convention:

user_2844477
user_2844477 Created Aug 21, 2019 20:03:02 Helpful(0) Helpful(0)

Hi.
Please post all related cofigurations from Extreme side.

I've done this before, just changed VMAN ethertype to 0x8100 on Extreme side. No changes on Huawei.
  • x
  • convention:

welisson_br
welisson_br Created Aug 22, 2019 02:20:00 Helpful(0) Helpful(0)

Posted by user_2844477 at 2019-08-21 09:03Hi.Please post all related cofigurations from Extreme side. I've done this before, just changed VMAN ...

Hi,

Here it is from Extreme Side.
P.S:  the port 29 is 10g as a trunk and forward other vlans including layer 3 vlan, where it is connected with S5720 as I posted above.

show configuration detail | grep vman
configure vman ethertype 0x88a8 or move on to 0x8100  like Huawei, the behavior is the same.
create vman "OLTS"
configure vman OLTS tag 4000
enable flooding vman OLTS
enable learning vman OLTS
configure vman "OLTS" qosprofile none
disable vman cep egress filtering ports 1
disable vman cep egress filtering ports 2
disable vman cep egress filtering ports 3
disable vman cep egress filtering ports 4
disable vman cep egress filtering ports 5
disable vman cep egress filtering ports 6
disable vman cep egress filtering ports 7
disable vman cep egress filtering ports 8
disable vman cep egress filtering ports 9
disable vman cep egress filtering ports 10
disable vman cep egress filtering ports 11
disable vman cep egress filtering ports 12
disable vman cep egress filtering ports 13
disable vman cep egress filtering ports 14
disable vman cep egress filtering ports 15
disable vman cep egress filtering ports 16
disable vman cep egress filtering ports 17
disable vman cep egress filtering ports 18
disable vman cep egress filtering ports 19
disable vman cep egress filtering ports 20
disable vman cep egress filtering ports 21
disable vman cep egress filtering ports 22
disable vman cep egress filtering ports 23
disable vman cep egress filtering ports 24
disable vman cep egress filtering ports 25
disable vman cep egress filtering ports 26
disable vman cep egress filtering ports 27
disable vman cep egress filtering ports 28
disable vman cep egress filtering ports 29
disable vman cep egress filtering ports 30
disable vman cep egress filtering ports 31
disable vman cep egress filtering ports 32
disable vman cep egress filtering ports 33
disable vman cep egress filtering ports 34
configure vman OLTS add ports 29 tagged
configure vman OLTS add ports 1,3-9,11-15,17-18,21,23,25,28 untagged
  • x
  • convention:

chenhui
chenhui Admin Created Aug 22, 2019 08:24:10 Helpful(0) Helpful(0)

Posted by welisson_br at 2019-08-21 14:30 Posted by chenhui at 2019-08-21 14:30@welisson_br hello,For V200R010 and later versions, command qinq ...
hi,
did you connect the Extreme X460 to S5720 through interface eth-trunk 0?
if yes, you should adjust your configuration as below:

interface GigabitEthernet0/0/11

description CLIENTE_A

qinq protocol 88a8        // delete this command if client A doesn't support 0x88a8

port link-type hybrid

qinq vlan-translation enable

undo port hybrid vlan 1

port hybrid tagged vlan 175

port hybrid untagged vlan 4000

port vlan-stacking vlan 700 stack-vlan 4000

port vlan-stacking vlan 1000 to 1300 stack-vlan 4000

port vlan-stacking vlan 3550 stack-vlan 4000


interface Eth-Trunk0

 description TRUNK-SW_EXTREME-20GB

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 175 3011 3218 4000 4076

 mode lacp

 qinq protocol 88a8     // add this command, so that the frame type of the packets sent to Extreme X460 is 0x88a8

  • x
  • convention:

welisson_br
welisson_br Created Aug 22, 2019 12:54:25 Helpful(0) Helpful(0)

Posted by chenhui at 2019-08-21 21:24hi,did you connect the Extreme X460 to S5720 through interface eth-trunk 0?if yes, you should adju ...

Hi,

I did that, but the result was the same.

Everything that I do over them, all comunications between either switchs goes down.

It is so curious, cause as I said before using eNSP + GNS3 everything worked well, but in real life is not having the expected behavior.

BTW, doing that over  eth-thrunk port, would it be changing the vlan ethertype as well or just qinq?

Cheers
  • x
  • convention:

user_2844477
user_2844477 Created Aug 22, 2019 19:25:23 Helpful(0) Helpful(0)

Have you checked MTU sizes?

Is jumbo frame enabled on Extreme device?
  • x
  • convention:

chenhui
chenhui Admin Created Aug 23, 2019 01:54:21 Helpful(0) Helpful(0)

Posted by welisson_br at 2019-08-22 12:54 Posted by chenhui at 2019-08-22 12:54hi,did you connect the Extreme X460 to S5720 through interface e ...
hi,
the qinq protocol only modify the outter vlan tag.
please check the picture below:

after the qinq protocol configured as 88a8.
qinq_protocol

before the qinq protocol configured.
no_qinq_protocol

as we can see, the inner vlan tag keeps same no matter if the qinq protocol is configured.
So, you are kindly advised to check if the X460 could process the normal 802.1q VLAN tag.

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

welisson_br
welisson_br Created Aug 23, 2019 20:15:52 Helpful(0) Helpful(0)

It is quite weird, and so annoying, but we have destroyed and rebuild the aggregation and with a touch of magic everything started working well.

Thx guys
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login