Got it

Overview about HCIE LAB Link Aggregation/ETH-TRUNK Highlighted

Latest reply: Dec 29, 2021 08:16:58 3319 25 15 0 2

Hi everybody,


A brief description about Link Aggregation(ETH-Trunk) that happened in my LAB;


There was just one link Aggregation enlace, with only two interfaces.


ETH


Before that I describe the script of this configuration,  I'll describe a little bit about LinkAggregation:


Originally, to increase the bandwidth, users use high-speed devices to replace old devices. This solution, however, is costly and inflexible.


As we know for Huawei the Ethernet link aggregation, which is called Eth-Trunk, bundles multiple physical links to form a logical link to increase link bandwidth.


These bundled links back up each other, increasing reliability.


Link aggregation helps increase bandwidth by bundling a group of physical interfaces into a single logical interface, without having to upgrade hardware


Link aggregation has the following advantages:


Increased bandwidth:


  • The bandwidth of the link aggregation interface is the sum of the bandwidth of member interfaces.


Higher reliability:


  • When an active link fails, traffic on this active link is switched to another active link, improving the reliability of the link aggregation interface.


Load balancing:


  • In a link aggregation group (LAG), traffic is load-balanced among active links of member interfaces.


Types of Link Aggregation:


Link aggregation can work IN MANUAL OR STATIC LACP mode depending on whether LACP is used


Manual mode:


  • You must manually create an Eth-Trunk and add member interfaces to the Eth-Trunk.

  • In this mode, LACP is not required.

  • The manual mode applies to the scenario where a high link bandwidth between two directly connected devices is required but the remote device does not support the LACP protocol

  • However, in this mode, there is a little problem: Eth-Trunk in manual mode can increase the bandwidth. However, the manual mode can only detect member link disconnections, but cannot detect other faults such as link-layer faults and incorrect link connections


LACP Mode:


  • LACP, as specified in IEEE 802.3ad, implements dynamic link aggregation and de-aggregation, allowing both ends to exchange Link Aggregation Control Protocol Data Units (LACPDUs)

  • After member interfaces are added to an Eth-Trunk in LACP mode, each end sends LACPDUs to inform its remote end of its system priority, MAC address, member interface priorities, interface numbers, and keys. The remote end then compares this information with that saved on itself and selects which interfaces to be aggregated. The two ends perform LACP negotiation to select active interfaces and links.

  • The Link Aggregation Control Protocol (LACP) can improve the fault tolerance of the Eth-Trunk, provide backup, and ensure the high reliability of member links.

  • LACP uses a standard negotiation mechanism for a switching device so that the switching device can create and start the aggregated link based on its configuration.

  • After the aggregated link is created, LACP maintains the link status. If an aggregated link's status changes, LACP adjusts or removes the link.

  • In LACP mode, active member interfaces selected by both devices must be consistent;

  • Interface LACP priorities are set to prioritize interfaces of an Eth-Trunk

  • In LACP mode, LACP is used to negotiate parameters to determine active links in a LAG. This mode is also called the M: N mode, where M refers to the number of active links and N refers to the number of the backup link

  • When LACP preemption is enabled, interfaces with higher priorities in a LAG function as active interfaces

  • In LACP mode, a link switchover in a LAG is triggered if a device at one end detects one of the following events:

  • An active link goes Down

  • Ethernet OAM detects a link fault.

  • LACP detects a link fault.

  • An active interface becomes unavailable.

  • When LACP preemption is enabled, a backup interface's priority is changed to be higher than that of the currently active interface.


Here are some cases that we can use Link Aggregation:


  • Switches are connected across a transmission device using link aggregation

  • Networking where switches are connected to transmission devices using link aggregation

  • A Switch Connects to a Server Using Link Aggregation

  • A Switch Connects to a Stack Using Link Aggregation


Script:


SWITCH 01:


interface Eth-Trunk1

port link-type trunk

undo port trunk allow-pass vlan 1

port trunk allow-pass vlan 2 to 4094

load-balance src-dst-mac

#

interface GigabitEthernet0/0/1

eth-trunk 1

#

interface GigabitEthernet0/0/21

eth-trunk 1


SWITCH 02:


interface Eth-Trunk1

port link-type trunk

undo port trunk allow-pass vlan 1

port trunk allow-pass vlan 2 to 4094

load-balance src-dst-mac

#

interface GigabitEthernet0/0/1

eth-trunk 1

#

interface GigabitEthernet0/0/2

eth-trunk 1


Thanks.

The post is synchronized to: HCIE groupClass HCIE

  • x
  • convention:

andersoncf1
MVE Author Created Jul 14, 2021 17:43:22

Thanks for sharing know with us.
View more
  • x
  • convention:

daniellima
daniellima Created Jul 14, 2021 17:44:16 (1) (0)
Thanks my friend  
Irshadhussain
Created Jul 14, 2021 17:48:38

NIce
View more
  • x
  • convention:

Irshadhussain
Created Jul 14, 2021 17:48:44

Overview about HCIE LAB Link Aggregation/ETH-TRUNK-4033503-1
View more
  • x
  • convention:

little_fish
Admin Created Jul 15, 2021 00:48:40

good
View more
  • x
  • convention:

hemin88
Author Created Jul 16, 2021 09:02:08

Great information and knowledge, thanks for sharing
View more
  • x
  • convention:

LucianoNhantumbo
Created Jul 16, 2021 14:09:34

good job, congratulation
View more
  • x
  • convention:

LucianoNhantumbo
Created Jul 16, 2021 14:09:45

good job, congratulation

View more
  • x
  • convention:

Saqib123
Saqib123 Created Jul 28, 2021 16:49:41 (0) (0)
 
lalinhgCA
Created Jul 19, 2021 08:54:41

It is the old lab H12-262 HCIE-Routing & Switching (Lab) ???? I expect the new H12-266 HCIE-Routing & Switching(New Lab) will be very different from that one?? pls help share ideas
View more
  • x
  • convention:

Saqib123
Saqib123 Created Jul 28, 2021 16:49:35 (0) (0)
 
lalinhgCA
Created Jul 19, 2021 08:55:00

It is the old lab H12-262 HCIE-Routing & Switching (Lab) ???? I expect the new H12-266 HCIE-Routing & Switching(New Lab) will be very different from that one?? pls help share ideas

View more
  • x
  • convention:

123
Back to list

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.