Got it

MPLS TE - Fundamentals

Created: Mar 19, 2020 17:33:45Latest reply: Apr 1, 2020 10:01:32 175 6 0 1
  HiCoins as reward: 2 (problem unresolved)

Hi,


I would like help to understand the concept of a TE tunnels in Huawei and the several possibilities to deploy them.


There are many options to different scenarios. Hedex has great examples, but it's a hard task to choose one option and apply changes in a network already running because of complexity of this matter.


This article has some instructions, but it's still not clear to me:

https://forum.huawei.com/enterprise/en/deploying-mpls-te/thread/506061-861


Which options in MPLS family are mandatory to create a simple TE tunnel and guide traffic on it?


We're running only LDP in our AS (basic OSPF and MPLS in the core). Is it possible to create TE tunnel (and a backup TE tunnel indeed) and guide customer traffic over them?


This image can help understand the aim:


TE Lab



The goal is to guide traffic from PC1 to PC2 via R1 > R3 > R2 > R4 (1Gbps Path), to keep a backup tunnel over R1 > R3 > R4 (or R1 > R2 > R4) and the last option to use the IGP path (R1 > R4).


Is there any free Advanced Course (step by step) about this topic?


Thanks!

  • x
  • convention:

Featured Answers

Recommended answer

chenhui
Admin Created Mar 20, 2020 07:45:53 Helpful(0) Helpful(0)

Hi @ptomasi,
In this scenario, you can configure three MPLS TE tunnel with explicit forward path. And assign the MPLS TE tunnel path IGP metric lower than the IGP path. Just as the picture below shows.

path metric


On R1, the forwarding path will be selected in order: MPLS TE tunnel 1  >  MPLS TE tunnel 2 > MPLS TE tunnel 3 > IGP

You can refer to the example https://support.huawei.com/hedex/hdx.do?docid=EDOC1000163385&id=dc_cfg_mpls-te_0175&lang=en


What should be pointed out, the MPLS TE tunnel is unidirectional, which means the backward traffic wouldn't be transferred in the MPLS TE tunnel unless you assign the corresponding tunnel on R4.

View more
  • x
  • convention:

All Answers
sohaib.ansar
sohaib.ansar MVE Created Mar 19, 2020 18:00:56 Helpful(0) Helpful(0)

Hi User,

MPLS TE Fundamentals



View more
  • x
  • convention:

sohaib.ansar
sohaib.ansar MVE Created Mar 19, 2020 18:02:14 Helpful(0) Helpful(0)

Hi User,

MPLS TE

On traditional IP networks, routers select the shortest path as the route regardless of other factors such as bandwidth. Traffic on a path is not switched to other paths even if the path is congested. As a result, the shortest path first rule can cause severe problems on networks.

Traffic engineering (TE) monitors network traffic and the load of network components and then adjusts parameters such as traffic management, routing, and resource restraint parameters in real time. These adjustments help prevent network congestion caused by unbalanced traffic distribution.

TE can be implemented on a large-scale backbone network using a simple, scalable solution. MPLS, an overlay model, allows a virtual topology to be established over a physical topology and maps traffic to the virtual topology. MPLS can be integrated with TE to implement MPLS TE.

As shown in Figure 2-12, two paths are set up between LSR_1 and LSR_7: LSR_1 -> LSR_2 -> LSR_3 -> LSR_6 -> LSR_7 and LSR_1 -> LSR_2 -> LSR_4 -> LSR_5 -> LSR_6 -> LSR_7. Bandwidth of the first path is 30 Mbit/s, and bandwidth of the second path is 80 Mbit/s. TE allocates traffic based on bandwidth, preventing link congestion. For example, 30 Mbit/s and 50 Mbit/s services are running between LSR_1 and LSR_7. TE distributes the 30 Mbit/s traffic to the 30 Mbit/s path and the 50 Mbit/s traffic to the 80 Mbit/s path.

Figure 2-12  MPLS TE
imgDownload?uuid=536e364645db4037ae5ca3c
MPLS TE can reserve resources by setting up LSPs along a specified path to prevent network congestion and balance network traffic. MPLS TE has the following advantages:
  • MPLS TE can reserve resources to ensure the quality of services during the establishment of LSPs.

  • The behavior of an LSP can be easily controlled based on the attributes of the LSP such as priority and bandwidth.

  • LSP establishment consumes few resources and does not affect other network services.

  • Backup path and fast reroute (FRR) protect network communication upon a failure of a link or a node.

These advantages make MPLS TE the optimal TE solution. MPLS TE allows service providers (SPs) to fully leverage existing network resources to provide diverse services, optimize network resources, and efficiently manage the network.


View more
  • x
  • convention:

chenhui
chenhui Admin Created Mar 20, 2020 07:45:53 Helpful(0) Helpful(0)

Hi @ptomasi,
In this scenario, you can configure three MPLS TE tunnel with explicit forward path. And assign the MPLS TE tunnel path IGP metric lower than the IGP path. Just as the picture below shows.

path metric


On R1, the forwarding path will be selected in order: MPLS TE tunnel 1  >  MPLS TE tunnel 2 > MPLS TE tunnel 3 > IGP

You can refer to the example https://support.huawei.com/hedex/hdx.do?docid=EDOC1000163385&id=dc_cfg_mpls-te_0175&lang=en


What should be pointed out, the MPLS TE tunnel is unidirectional, which means the backward traffic wouldn't be transferred in the MPLS TE tunnel unless you assign the corresponding tunnel on R4.

View more
  • x
  • convention:

chenhui
chenhui Admin Created Mar 20, 2020 07:53:21 Helpful(0) Helpful(0)

Also, you can refer to the eNSP project as below:

By the way, I didn't configure the backward MPLS TE tunnel in this project.

ensp topo

R1:

#
mpls lsr-id 1.1.1.1
mpls
mpls te
mpls rsvp-te
mpls te cspf
#
explicit-path 1st
next hop 10.1.13.3
next hop 10.1.23.2
next hop 10.1.24.4
next hop 4.4.4.4
#
explicit-path 2nd
next hop 10.1.13.3
next hop 10.1.34.4
next hop 4.4.4.4
#
explicit-path 3rd
next hop 10.1.12.2
next hop 10.1.24.4
next hop 4.4.4.4
#
interface GigabitEthernet0/0/0
ip address 10.1.13.1 255.255.255.0
ospf cost 100
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/1
ip address 10.1.12.1 255.255.255.0
ospf cost 100
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/2
ip address 10.1.14.1 255.255.255.0
ospf cost 100
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
interface LoopBack1
ip address 100.1.1.1 255.255.255.0
#
interface Tunnel0/0/1
ip address unnumbered interface LoopBack0
tunnel-protocol mpls te
destination 4.4.4.4
mpls te tunnel-id 1
mpls te path explicit-path 1st
mpls te igp shortcut ospf
mpls te igp metric absolute 1
mpls te commit
#
interface Tunnel0/0/2
ip address unnumbered interface LoopBack0
tunnel-protocol mpls te
destination 4.4.4.4
mpls te tunnel-id 2
mpls te path explicit-path 2nd
mpls te igp shortcut ospf
mpls te igp metric absolute 2
mpls te commit
#
interface Tunnel0/0/3
ip address unnumbered interface LoopBack0
tunnel-protocol mpls te
destination 4.4.4.4
mpls te tunnel-id 3
mpls te path explicit-path 3rd
mpls te igp shortcut ospf
mpls te igp metric absolute 3
mpls te commit
#
ospf 1
opaque-capability enable
enable traffic-adjustment
area 0.0.0.0
 network 10.1.12.0 0.0.0.255
 network 10.1.13.0 0.0.0.255
 network 10.1.14.0 0.0.0.255
 network 1.1.1.1 0.0.0.0
 network 100.1.1.0 0.0.0.255
 mpls-te enable
#


R2:

#
mpls lsr-id 2.2.2.2
mpls
mpls te
mpls rsvp-te
mpls te cspf
#
interface GigabitEthernet0/0/0
ip address 10.1.24.2 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/1
ip address 10.1.12.2 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/2
ip address 10.1.23.2 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
ospf 1
opaque-capability enable
area 0.0.0.0
 network 10.1.12.0 0.0.0.255
 network 10.1.23.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 network 2.2.2.2 0.0.0.0
 mpls-te enable
#


R3:

#
mpls lsr-id 3.3.3.3
mpls
mpls te
mpls rsvp-te
mpls te cspf
#
interface GigabitEthernet0/0/0
ip address 10.1.13.3 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/1
ip address 10.1.34.3 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/2
ip address 10.1.23.3 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
#
ospf 1
opaque-capability enable
area 0.0.0.0
 network 3.3.3.3 0.0.0.0
 network 10.1.13.0 0.0.0.255
 network 10.1.23.0 0.0.0.255
 network 10.1.34.0 0.0.0.255
 mpls-te enable
#


R4:

#
mpls lsr-id 4.4.4.4
mpls
mpls te
mpls rsvp-te
mpls te cspf
#
interface GigabitEthernet0/0/0
ip address 10.1.24.4 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/1
ip address 10.1.34.4 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface GigabitEthernet0/0/2
ip address 10.1.14.4 255.255.255.0
mpls
mpls te
mpls rsvp-te
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
#
interface LoopBack1
ip address 100.1.4.1 255.255.255.0
#
ospf 1
opaque-capability enable
area 0.0.0.0
 network 4.4.4.4 0.0.0.0
 network 10.1.24.0 0.0.0.255
 network 10.1.34.0 0.0.0.255
 network 10.1.14.0 0.0.0.255
 network 100.1.4.0 0.0.0.255
 mpls-te enable
#


View more
  • x
  • convention:

ptomasi
ptomasi Created Mar 20, 2020 14:26:19 Helpful(0) Helpful(0)

Great instructions, thank you!


Can you help me to clarify some restless questions in my mind? i_f42.gif


According to examples, are these mandatory options in any TE scenario?


mpls te
 mpls rsvp-te
 mpls te cspf
 
interface GigabitEthernet0/0/N
 mpls te
 mpls rsvp-te
 
ospf 1
 opaque-capability enable
 area 0.0.0.0
  mpls-te enable



If we are already running LDP, can we run RSVP too in the label distribution task without problems? Is there a chance to generate conflict between them?


- - -


Some questions about the lab you shared:


Virtual interfaces (TE Tunnels) are configured to have lower cost than physical links? This way will OSPF use TE tunnel as best path from R1 to R4?

If yes, is this calculation valid only on R1? Or will R2 and R3 use R1 to get to R4 (because of lower cost of TE Tunnel) even they are directly connected to R4?


Will all traffic from R1 to R4 be guided in TE Tunnel?

If we want to guide only some Customer to Customer or Transit (Upstream ISP) to Customer, is it possible?


In the lab, ip address 100.1.1.1 (loopback 1) is going to use TE Tunnel to get to 100.1.4.1 (loopback 1)?


"What should be pointed out, the MPLS TE tunnel is unidirectional, which means the backward traffic wouldn't be transferred in the MPLS TE tunnel unless you assign the corresponding tunnel on R4."

Great, in that case we could create another TE Tunnel from R4 to R1 to choose a reverse path or keep backwards traffic being routed via IGP, correct?


Thanks again and sorry about too many noob questions.

View more
  • x
  • convention:

chenhui
chenhui Admin Created Apr 1, 2020 10:01:32 Helpful(0) Helpful(0)

Posted by ptomasi at 2020-03-20 14:26 Great instructions, thank you!Can you help me to clarify some restless questions in my mind? Accordi ...
Hi,
I'm not sure about your first question, but I think there might be some problems when enable both LDP and RSVP on the same interface.

Virtual interfaces (TE Tunnels) are configured to have lower cost than physical links? This way will OSPF use TE tunnel as best path from R1 to R4?
Yes, the lower cost allows the OSPF choosing the TE tunnel. This calculation only works on R1, the TE tunnel forwards the traffic through MPLS label, rather than the FIB on R2 and R3. Traffic is imported into the TE on R1 and will forward using the TE tunnel, no more route-path calculation is required on R2 and R3.

Will all traffic from R1 to R4 be guided in TE Tunnel?
It depends on the specific configuration.


In the lab, ip address 100.1.1.1 (loopback 1) is going to use TE Tunnel to get to 100.1.4.1 (loopback 1)?
Yes. Cause the TE tunnel owns a lower cost than the physical link.


Great, in that case we could create another TE Tunnel from R4 to R1 to choose a reverse path or keep backwards traffic being routed via IGP, correct?
Yes, I think so.


View more
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

My Followers

Login and enjoy all the member benefits

Login

Huawei Enterprise Support Community
Huawei Enterprise Support Community