Mapping multiple VLANs to EoMPLS tunnel between S6720

Latest reply: Aug 19, 2019 12:03:04 482 1 0 0
I would like to map multiple VLANs on a subinterface to EoMPLS tunnel on a S6720EI switch. I setup the topology below involving two S6720EI and a CISCO device working as CPE. I cannot ping between devices in VLAN 10 and also between devices on VLAN 20.


Software version is V200R010c00SPC600

Mapping multiple VLANs to EoMPLS tunnel between S6720-2690571-1

BA configuration:

#

mpls ldp remote-peer SE

 remote-ip x.0.0.9

#

vlan 10

 name TEST1

vlan 20

 name TEST2

#

interface LoopBack0

 description ### Routing loopback ###

 ipv6 enable

 ip address x.0.0.1 255.255.255.255

 ipv6 address x::1/128

 ospfv3 100 area 0.0.0.0

 ospf cost 1

 ospf enable 100 area 0.0.0.0

#

interface Vlanif10

 description ### TEST ###

 ip address 10.35.29.1 255.255.255.0

 statistic enable both

#

interface Vlanif20

 description ### TEST ###

 ip address 10.35.28.1 255.255.255.0

 statistic enable both

#

interface XGigabitEthernet0/0/27

 undo portswitch

 description ### SL ###

 mtu 9216

 mpls l2vc x.0.0.9 123456 tagged

#

interface XGigabitEthernet0/0/28

 description ### SL ###

 port link-type trunk

 port trunk allow-pass vlan 10 to 20

#

SE Configuration:

#

mpls ldp remote-peer ba-rs-mil11

 remote-ip x.0.0.1

#

interface LoopBack0

 description ### Routing loopback ###

 ipv6 enable

 ip address x.0.0.9 255.255.255.255

 ipv6 address x::9/128

 ospfv3 100 area 0.0.0.0

 ospf cost 1

 ospf enable 100 area 0.0.0.0

#

#

interface XGigabitEthernet0/0/21

 description ### SM ###

 port link-type trunk

 port trunk allow-pass vlan 2

#

interface XGigabitEthernet0/0/21.3700

 description ### TEST ###

 mtu 9216

 dot1q termination vid 10 to 20

 mpls l2vc x.0.0.1 123456

#

CPE Configuration:

vlan 10

 name test

!

vlan 20

name test2

!

Interface Vlan10

description ### TEST ###

ip address 10.35.29.2 255.255.255.0

!

Interface Vlan20

description ### TEST ###ip address 10.35.28.2 255.255.255.0

!

Interface GigabitEthernet0/1

description ### Link to SE ##

switchport trunk encapsulation dot1q

switchport trunk allowed 2,10,20

switchport mode trunk

switchport non-negociate

load-interval 30


There is a chip limitation on this equipment that makes the egress switch (BA) not being able to have both physical interfaces (end and start of the mpls l2vc tunnel of the trunk for the mapped VLANs 10 and 20).

For example interface below is a main interface.

#

interface XGigabitEthernet0/0/45

 undo portswitch

 description ### Smer ba-rs-tp01, [NNI_L3] ###

 mtu 1998

 ip address 87.244.238.193 255.255.255.252

 pim sm

 pim bfd enable

 ospf cost 50000

 ospf mtu-enable

 ospf network-type p2p

 ospf timer hello 1

 ospf timer dead 30

 ospf enable 100 area 0.0.0.0

 mpls

 mpls mtu 9216

 mpls te

 mpls rsvp-te

 mpls ldp

 jumboframe enable 12288

#


To overcome this limitation, customer needs to configure the end of the mpls l2vc tunnel as a VLAN interface instead of a physical interface.

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

You have to terminate the vlans just the way you did on the SE

interface XGigabitEthernet0/0/21.3700
dot1q termination vid 10 to 20
mpls l2vc x.0.0.1 123456

When you do this, it'll work and you lose the feature to "open" a vlanif
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top