Got it

L2TPv3

Created: Dec 13, 2017 19:10:26Latest reply: Mar 22, 2018 14:07:02 3652 4 0 0 0
  Rewarded HiCoins: 0 (problem resolved)
i need to configure L2TPv3 between huawei router and cisco ,Can anyone help on this ?
  • x
  • convention:

Featured Answers
Busy_with_lazy_mind
Created Dec 14, 2017 01:26:35

Can works with Cisco using static mode.
for example

Huawei devide:
l2tpv3 enable
#
license active accept agreement
license function datae
#
interface GigabitEthernet0/0/0
undo portswitch
link-bridge Tunnel0/0/1 vc-id 1234 tagged
#
interface GigabitEthernet0/0/1
undo portswitch
ip address 10.10.2.1 255.255.255.0
#
interface Tunnel0/0/1
tunnel-protocol svpn
encapsulation l2tpv3
l2tpv3 local session-id 1
l2tpv3 remote session-id 4
tunnel-source 3.3.3.3
tunnel-destination 10.10.2.2
#

Cisco device:

pseudowire-class HW-device
encapsulation l2tpv3
protocol none
ip local interface Loopback0
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
!
interface GigabitEthernet0/1
ip address 10.10.2.2 255.255.255.0
duplex auto
speed auto
no keepalive
!
interface FastEthernet0/0/0
no ip address
duplex auto
speed auto
xconnect 10.10.2.1 1234 encapsulation l2tpv3 manual pw-class HW-device
l2tp id 4 1

View more
  • x
  • convention:

All Answers
Busy_with_lazy_mind
Busy_with_lazy_mind Created Dec 14, 2017 01:26:35

Can works with Cisco using static mode.
for example

Huawei devide:
l2tpv3 enable
#
license active accept agreement
license function datae
#
interface GigabitEthernet0/0/0
undo portswitch
link-bridge Tunnel0/0/1 vc-id 1234 tagged
#
interface GigabitEthernet0/0/1
undo portswitch
ip address 10.10.2.1 255.255.255.0
#
interface Tunnel0/0/1
tunnel-protocol svpn
encapsulation l2tpv3
l2tpv3 local session-id 1
l2tpv3 remote session-id 4
tunnel-source 3.3.3.3
tunnel-destination 10.10.2.2
#

Cisco device:

pseudowire-class HW-device
encapsulation l2tpv3
protocol none
ip local interface Loopback0
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
!
interface GigabitEthernet0/1
ip address 10.10.2.2 255.255.255.0
duplex auto
speed auto
no keepalive
!
interface FastEthernet0/0/0
no ip address
duplex auto
speed auto
xconnect 10.10.2.1 1234 encapsulation l2tpv3 manual pw-class HW-device
l2tp id 4 1

View more
  • x
  • convention:

Waeel
Waeel Created Dec 14, 2017 08:32:59

i will try it and feedback , Please also confirm if the source tunnel is correct should not be 10.10.2.1 instead
of 3.3.3.3 ?

interface Tunnel0/0/1
tunnel-protocol svpn
encapsulation l2tpv3
l2tpv3 local session-id 1
l2tpv3 remote session-id 4
tunnel-source 3.3.3.3
tunnel-destination 10.10.2.2
View more
  • x
  • convention:

Waeel
Waeel Created Dec 16, 2017 10:51:26

Dear,
thanks for your help , xconnect is up . but one more thing i hope you can help me . why the interface binding to tunnel in huawei router goes to protocol down when i am binding it to tunnel
View more
  • x
  • convention:

StarOfWest
StarOfWest Created Mar 22, 2018 14:07:02

Hi,

it's normal to go down, since communication at protocol level is performed through tunnel interface. Please check the tunnel interface protocol status.
View more
  • x
  • convention:

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.
Information Protection Guide
Thanks for using Huawei Enterprise Support Community! We will help you learn how we collect, use, store and share your personal information and the rights you have in accordance with Privacy Policy and User Agreement.