Interoperation and Replacement Guide for Huawei LNP and Cisco DTP

94 0 0 0

Overview of LNP and DTP

Huawei LNP

The Link-type Negotiation Protocol (LNP) dynamically negotiates whether an Ethernet interface is the access or trunk interface. Huawei switches support LNP starting from V200R005.

Table 2-101  LNP negotiation

Local Link Type

Remote Link Type or Negotiation Status

Locally Negotiated Link Type

Final Status of the Remote Interface

Negotiation-desirable/Negotiation-auto

Access (LNP negotiation enabled)

Access

Access

Hybrid (LNP negotiation enabled)

Trunk

Hybrid

Dot1q-tunnel (LNP negotiation enabled)

Access

Dot1q-tunnel

Trunk (LNP negotiation enabled)

Trunk

Trunk

LNP negotiation not supported or disabled

Access

Uncertain

Negotiation-desirable

Negotiation-desirable

Trunk

Trunk

Negotiation-desirable

Negotiation-auto

Trunk

Trunk

Negotiation-auto

Negotiation-auto

Access

Access

imgDownload?uuid=34c9df5829a54adba3eaa66 NOTE:

  • The VCMP domain name affects LNP negotiation. A trunk interface is negotiated only when domain names at both ends of a link are consistent or the domain name of at least one end is empty; otherwise, an access interface is negotiated.
  • The Ethernet interface that is negotiated as an access interface joins VLAN 1 by default. The Ethernet interface that is negotiated as a trunk interface allows all VLANs by default.
Cisco DTP

The Dynamic Trunking Protocol (DTP) dynamically negotiates whether an Ethernet interface is the access or trunk interface.

Table 2-102  DTP negotiation

Configured Link Type of an Interface

Negotiated Link Type of an Interface

Switchport mode access

The interface is configured to work in access mode forcibly.

Switchport mode dynamic auto

If the remote interface works in trunk or desirable mode, the local interface works in trunk mode through negotiation.

Switchport mode dynamic desirable

If the remote interface works in trunk, desirable, or auto mode, the local interface works in trunk mode through negotiation.

Switchport mode trunk

The interface is configured to work in trunk mode forcibly.

Switchport nonegotiate

This command is used to enable the interface not to send DTP packets, and can be used on only the interface in trunk or access mode.

To establish a trunk link, you must manually configure interfaces at both ends to work in trunk mode.

imgDownload?uuid=34c9df5829a54adba3eaa66 NOTE:

  • Devices at both ends must have the same VTP domain name to ensure successful DTP negotiation.
  • DTP supports the Inter-Switch Link (ISL) and IEEE 802.1Q. ISL is a Cisco proprietary encapsulation protocol, and IEEE 802.1Q is a standard protocol.

Comparison Between LNP and DTP

Table 2-103  Function support

Function

Huawei Switches

Cisco Switches

Enabling or disabling global auto-negotiation of the link type of an interface

Supported

Global auto-negotiation of the link type of an interface is enabled by default.

For devices such as access devices that do not require dynamic negotiation, LNP can be disabled globally. After LNP is disabled, the device stops sending LNP packets. The network burden is therefore reduced.

Not supported

Enabling or disabling auto-negotiation of the link type of an interface

Supported

Auto-negotiation of the link type of an interface is enabled by default.

Supported

See the Cisco documentation.

Dynamically negotiating the link type

Supported

Supported

Delivering VLAN information about an interface based on the negotiation result after the link type is negotiated dynamically

Supported

Supported

Displaying negotiation information about the link type of an interface

Supported

Supported

Automatic recovery of the dynamically negotiated link state after the active/standby switchover

Supported

Supported

Table 2-104  Differences in command formats

Function

Command on Huawei Switches

Command on Cisco Switches

Configure the link dynamic negotiation mode as auto.

port link-type negotiation-autoswitchport mode dynamic auto

Configure the link dynamic negotiation mode as desirable.

port link-type negotiation-desirableswitchport mode dynamic desirable

Remove an interface from a VLAN in negotiation mode. For example, remove an interface from VLAN 10.

There is no command used to remove an interface from VLAN 10. You can specify the VLANs that interfaces can be added to.

port trunk allow-pass only-vlan 1 to 9 11 to 4094
switchport trunk allowed vlan remove 10

Disable auto-negotiation of an interface.

port negotiation disableswitchport nonegotiate

Disable global LNP.

lnp disable

Not supported

Modify the packet encapsulation mode.

Huawei supports only encapsulation based on the standard protocol, without any configuration.

switchport trunk encapsulation dot1q

Interoperation and Replacement Solution for LNP and DTP

DTP and LNP are both proprietary protocols, so they cannot interwork. The two protocols can replace each other. Select either of the following solutions depending on the actual scenario:

  • Network-wide replacement: All Cisco DTP switches are replaced by Huawei switches that support LNP.
  • Single replacement: One Cisco switch is replaced by a Huawei S series switch. The remote switch is still a Cisco switch. In this situation, you need to configure the interface of the remote Cisco switch to work in non-negotiation mode.

Interoperation and Replacement Solution 1: Replacement Solution on the Entire Network

Topic contents:

Overview

Network-wide replacement indicates that all Cisco DTP switches are replaced by Huawei switches that support LNP. The following describes the configuration of Huawei LNP.

Configuration Notes
  • This example applies to Huawei switches of V200R005 and later versions.
  • On Huawei switches, LNP is used globally and on interfaces by default. The interface that is negotiated as an access interface joins VLAN 1 by default, and the interface that is negotiated as a trunk interface joins all VLANs by default. Generally, you only need to change the VLAN configuration on an interface based on the networking.

Networking Requirements

In Figure 2-69, terminal users are connected to the network through switches. To implement Layer 2 connectivity, configure the link type on each interface and add interfaces to VLANs. If the network scale is large, the configuration is very complex. To simplify configurations, switches are connected through the trunk link, and switches and user terminals are connected through access links and added to VLANs.

Figure 2-69  Networking for configuring LNP to implement auto-negotiation of the link type of an Ethernet interface 
imgDownload?uuid=2e078d3aa0c14285853eb5a

Configuration Roadmap
  1. Enable LNP in the system view and interface view to implement auto-negotiation of the link type of an interface. Because PCs do not support LNP, so switch interfaces connected to terminals are used as access interfaces and interfaces between switches are used as trunk interfaces through negotiation.
  2. Add interfaces to VLANs to implement Layer 2 connectivity.

Procedure

  1. Enable global LNP.

    By default, global LNP is enabled. If LNP is disabled, run the undo lnp disable command in the system view to enable it.

  2. Create VLANs.

    Huawei switches support two VLAN creation modes:

    • Manually create VLANs on switches.
    • Create VLANs on Switch3 only and configure VCMP to synchronize VLANs on Switch3 to other switches. If VCMP is used to create VLANs, configure Switch3 as the VCMP server and Switch1 and Switch2 as VCMP clients. For details, see "VCMP Configuration."

    The following describes how to manually create VLANs.

    # Create VLAN 10 and VLAN 20 on Switch1, Switch2, and Switch3.

    <HUAWEI> system-view [HUAWEI] sysname Switch1 [Switch1] vlan batch 10 20
    <HUAWEI> system-view [HUAWEI] sysname Switch2 [Switch2] vlan batch 10 20
    <HUAWEI> system-view [HUAWEI] sysname Switch3 [Switch3] vlan batch 10 20

  3. Enable LNP on interfaces, and add switch interfaces connected to PCs to VLANs as access interfaces and interfaces between switches to VLANs as trunk interfaces.

    By default, LNP on an interface is enabled. If LNP is disabled, run the undo port negotiation disable command in the interface view to enable it.

    # Configure Switch1.

    [Switch1] interface GigabitEthernet 0/0/1 [Switch1-GigabitEthernet0/0/1] port default vlan 10  //The interface connected to a PC is an access interface. Run this command to configure the VLAN that the interface joins. [Switch1-GigabitEthernet0/0/1] quit [Switch1] interface GigabitEthernet 0/0/2 [Switch1-GigabitEthernet0/0/2] port trunk allow-pass only-vlan 10 20  //The interface connected to a switch is negotiated as a trunk interface. Run this command to configure the VLANs that the interface joins. This command configures the interface to allow packets from VLAN 10 and VLAN 20. [Switch1-GigabitEthernet0/0/2] quit [Switch1] interface GigabitEthernet 0/0/3 [Switch1-GigabitEthernet0/0/3] port default vlan 20 [Switch1-GigabitEthernet0/0/3] quit

    # Configure Switch2.

    [Switch2] interface GigabitEthernet 0/0/1 [Switch2-GigabitEthernet0/0/1] port default vlan 10 [Switch2-GigabitEthernet0/0/1] quit [Switch2] interface GigabitEthernet 0/0/2 [Switch2-GigabitEthernet0/0/2] port trunk allow-pass only-vlan 10 20 [Switch2-GigabitEthernet0/0/2] quit [Switch2] interface GigabitEthernet 0/0/3 [Switch2-GigabitEthernet0/0/3] port default vlan 20 [Switch2-GigabitEthernet0/0/3] quit

    # Configure Switch3.

    [Switch3] interface GigabitEthernet 0/0/1 [Switch3-GigabitEthernet0/0/1] port trunk allow-pass only-vlan 10 20 [Switch3-GigabitEthernet0/0/1] quit [Switch3] interface GigabitEthernet 0/0/2 [Switch3-GigabitEthernet0/0/2] port trunk allow-pass only-vlan 10 20 [Switch3-GigabitEthernet0/0/2] quit

  4. Verify the configuration.

    After the preceding configuration is complete, run the display lnp interface interface-type interface-number command to check auto-negotiation on the specified Layer 2 interface.

    [Switch1] display lnp interface gigabitethernet0/0/2 LNP information for GigabitEthernet0/0/2:   Port link type: trunk   Negotiation mode: desirable   Hello timer expiration(s): 7   Negotiation timer expiration(s): 0   Trunk timer expiration(s): 278   FSM state: trunk   Packets statistics   56 packets received     0 packets dropped       bad version: 0, bad TLV(s): 0, bad port link type: 0,       bad negotiation state: 0, other: 0   58 packets output     0 packets dropped       other: 0

    Run the display lnp summary command to check auto-negotiation information on all interfaces of the Layer 2 device.

    [Switch1] display lnp summary Global LNP : Negotiation enable ------------------------------------------------------------------------------- C: Configured; N: Negotiated; *: Negotiation disable; Port         link-type(C)   link-type(N)   InDropped   OutDropped  FSM          ------------------------------------------------------------------------------- GE0/0/1      desirable      access         0           0           access GE0/0/2      desirable      trunk          0           0           trunk GE0/0/3      desirable      access         0           0           access

Configuration Files
  • Switch1 configuration file

    # sysname Switch1 # vlan batch 10 20 # interface GigabitEthernet0/0/1  port default vlan 10 # interface GigabitEthernet0/0/2  port trunk allow-pass only-vlan 10 20 # interface GigabitEthernet0/0/3  port default vlan 20 # return
  • Switch2 configuration file

    # sysname Switch2 # vlan batch 10 20 # interface GigabitEthernet0/0/1  port default vlan 10 # interface GigabitEthernet0/0/2  port trunk allow-pass only-vlan 10 20 # interface GigabitEthernet0/0/3  port default vlan 20 # return
  • Switch3 configuration file

    # sysname Switch3 # vlan batch 10 20 # interface GigabitEthernet0/0/1  port trunk allow-pass only-vlan 10 20 # interface GigabitEthernet0/0/2  port trunk allow-pass only-vlan 10 20 # return

Interoperation and Replacement Solution 2: Replacement Solution of a Single Device

Topic contents:

Overview

When replacing a single device, you need to configure the connected interface of the Cisco device as non-negotiation.

Configuration Notes
  • This example applies to all versions of S series switches.
  • During interworking and replacement of Cisco switches and Huawei switches, the encapsulation mode must be IEEE 802.1Q.

Networking Requirements

In Figure 2-70, three Cisco devices use DTP to dynamically negotiate link types of interfaces. One device is replaced by a Huawei S series switch, and the three switches need to implement Layer 2 connectivity.

Figure 2-70  Interworking of Huawei switches and Cisco switches 
imgDownload?uuid=110cd75f9c214b948619097

Configuration Roadmap
  1. Manually configure link types of interfaces. DTP on Cisco switches and LNP on Huawei switches are both proprietary protocols, and cannot interwork. When Huawei switches are connected to Cisco switches, the link type of an interface cannot be negotiated dynamically.
  2. Manually configure link types of interfaces on two switches as trunk and specify the packet encapsulation mode on Cisco switches as IEEE 802.1Q.

Procedure

  1. Manually change the link type of Fa0/2 on the Cisco switch to trunk. The configuration of two Cisco switches is the same.

    CiscoA# configure terminal CiscoA(config)# interface fastEthernet 0/2 CiscoA(config-if)# switchport trunk encapsulation dot1q CiscoA(config-if)# switchport mode trunk  //An interface on a Cisco switch joins all VLANs by default, and does not need to be configured manually.

  2. Configure the link type of the interface on the Huawei S series switch as trunk.

    <Huawei> system-view [Huawei] interface GigabitEthernet0/0/2 [Huawei-GigabitEthernet0/0/2] port link-type trunk [Huawei-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 to 4094  //When the link type of an interface of a Huawei S series switch is configured as trunk, the interface joins VLAN 1 by default. You need to manually add the interface to VLANs 2 to 4094. 

  3. Verify the configuration.

    • Run the show interfaces fastEthernet 0/2 switchport command to check whether the link type field on the Cisco switch is Administrative Mode: trunk.
    • Run the display interface gigabitethernet 0/0/2 command to check whether the link type field on the Cisco switch is Link-type: trunk(configured).

See more please click 

https://support.huawei.com/enterprise/en/doc/EDOC1000069520/9aadccc0/comprehensive-configuration-examples


  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login