I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS

Created: Sep 22, 2018 13:53:51Latest reply: Sep 27, 2018 03:55:49 853 12 0 0
  Rewarded Hi-coins: 0 (problem resolved)
I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS
  • x
  • convention:

Featured Answers
Sergio93
Created Sep 22, 2018 17:03:03 Helpful(0) Helpful(0)

Hello,


OSPF is supported so definetely is a configuration problem. Please try to load these examples when you first open eNSP and check if these are behaving correctly : 
I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS-2758421-1

Have here an example also if you want to practice and check where is your mistake, you can also directly copy and paste the configuration scripts in the devices if topology is identical : 
    
  Networking diagram for configuring basic OSPF functions 
fig_dc_cfg_ospf_105902.png

Networking Requirements

As shown in figure, three switches on a network need to communicate with each other, and the entire network needs to be extended based on SwitchA and SwitchB as the service devices.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure VLANs for interfaces, VLANIF interfaces for the VLANs, and IP addresses for each VLANIF interface to implement communication within network segments.

  2. Configure basic OSPF functions on each switch. Configure SwitchA as the ABR to partition the OSPF network into two areas (Area0 and Area1) so that the entire OSPF network can be extended using the area where SwitchA and SwitchB are located as the backbone area.

Procedure

  1. Configure VLANs for interfaces.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit

  2. Configure an IP address for each VLANIF interface.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.1.1 24
    [SwitchA-Vlanif20] quit

  3. Configure basic OSPF functions.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] return

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] return

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] return

  4. Verify the configuration.

    # Check information about OSPF neighbors on SwitchA.

    <SwitchA> display ospf peer
    
              OSPF Process 1 with Router ID 10.1.1.1
                      Neighbors
    
     Area 0.0.0.0 interface 192.168.0.1(Vlanif10)'s neighbors
    Router ID: 10.2.2.2      Address: 192.168.0.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.0.2  BDR: 192.168.0.1   MTU: 0
       Dead timer due in 36  sec
       Retrans timer interval: 5
       Neighbor is up for 00:15:04
       Authentication Sequence: [ 0 ]
    
                      Neighbors
    
     Area 0.0.0.1 interface 192.168.1.1(Vlanif20)'s neighbors
    Router ID: 10.3.3.3       Address: 192.168.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.1.2  BDR: 192.168.1.1   MTU: 0
       Dead timer due in 39  sec
       Retrans timer interval: 5
       Neighbor is up for 00:07:32
       Authentication Sequence: [ 0 ]

    # Check the OSPF routing information on SwitchC.

    <SwitchC> display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination      Cost  Type         NextHop         AdvRouter       Area
     192.168.1.0/24    1    Transit      192.168.1.2     10.3.3.3        0.0.0.1
     192.168.0.0/24    2    Inter-area   192.168.1.1     10.1.1.1        0.0.0.1
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

    The preceding command output shows that SwitchC has an inter-area route to the network segment 192.168.0.0/24.

    # Check the routing table on SwitchB, and perform the ping operation on SwitchB to test the connectivity between SwitchB and SwitchC.

    <SwitchB> display ospf routing
    
              OSPF Process 1 with Router ID 10.2.2.2
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop      AdvRouter       Area
     192.168.0.0/24     1     Transit    192.168.0.2  10.2.2.2        0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.0.1  10.1.1.1        0.0.0.0
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

    The preceding command output shows that SwitchB has an inter-area route to the network segment 192.168.1.0/24.

    # Perform the ping operation on SwitchB to test the connectivity between SwitchB and SwitchC.

    <SwitchB> ping 192.168.1.2
      PING 192.168.1.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.1.2: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 192.168.1.2: bytes=56 Sequence=2 ttl=253 time=16 ms
        Reply from 192.168.1.2: bytes=56 Sequence=3 ttl=253 time=62 ms
        Reply from 192.168.1.2: bytes=56 Sequence=4 ttl=253 time=94 ms
        Reply from 192.168.1.2: bytes=56 Sequence=5 ttl=253 time=63 ms
    
      --- 192.168.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/59/94 ms

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.0.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

BEST%20ANSWER!%20If%20you%20think%20I%20earn%20it!%3Cbr%2F%3E%3Cbr%2F%3EIf%20this%20post%20was%20useful%20to%20you%2C%20please%20click%20the%20%3Cimg%20id%3D%22aimg_eYhFO%22%20onclick%3D%22zoom(this%2C%20this.src%2C%200%2C%200%2C%200)%22%20class%3D%22zoom%22%20src%3D%22https%3A%2F%2Fforum.huawei.com%2Fenterprise%2Fen%2Fstatic%2Fimage%2Fcommon%2Fsupport01.png%22%20onmouseover%3D%22img_onmouseoverfunc(this)%22%20onload%3D%22thumbImg(this)%22%20border%3D%220%22%20alt%3D%22%22%20%2F%3E%20%3Cfont%20color%3D%22DarkOrange%22%3EHelpful%3C%2Ffont%3E%20button%20and%20flag%20my%20post%20as%20a%20%26quot%3BBEST%20ANSWER%26quot%3B%20so%20others%20can%20benefit.%20Thank%20you%20%3Cimg%20id%3D%22aimg_H808i%22%20onclick%3D%22zoom(this%2C
All Answers
Sergio93
Sergio93 Created Sep 22, 2018 17:03:03 Helpful(0) Helpful(0)

Hello,


OSPF is supported so definetely is a configuration problem. Please try to load these examples when you first open eNSP and check if these are behaving correctly : 
I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS-2758421-1

Have here an example also if you want to practice and check where is your mistake, you can also directly copy and paste the configuration scripts in the devices if topology is identical : 
    
  Networking diagram for configuring basic OSPF functions 
fig_dc_cfg_ospf_105902.png

Networking Requirements

As shown in figure, three switches on a network need to communicate with each other, and the entire network needs to be extended based on SwitchA and SwitchB as the service devices.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure VLANs for interfaces, VLANIF interfaces for the VLANs, and IP addresses for each VLANIF interface to implement communication within network segments.

  2. Configure basic OSPF functions on each switch. Configure SwitchA as the ABR to partition the OSPF network into two areas (Area0 and Area1) so that the entire OSPF network can be extended using the area where SwitchA and SwitchB are located as the backbone area.

Procedure

  1. Configure VLANs for interfaces.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit

  2. Configure an IP address for each VLANIF interface.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.1.1 24
    [SwitchA-Vlanif20] quit

  3. Configure basic OSPF functions.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] return

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] return

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] return

  4. Verify the configuration.

    # Check information about OSPF neighbors on SwitchA.

    <SwitchA> display ospf peer
    
              OSPF Process 1 with Router ID 10.1.1.1
                      Neighbors
    
     Area 0.0.0.0 interface 192.168.0.1(Vlanif10)'s neighbors
    Router ID: 10.2.2.2      Address: 192.168.0.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.0.2  BDR: 192.168.0.1   MTU: 0
       Dead timer due in 36  sec
       Retrans timer interval: 5
       Neighbor is up for 00:15:04
       Authentication Sequence: [ 0 ]
    
                      Neighbors
    
     Area 0.0.0.1 interface 192.168.1.1(Vlanif20)'s neighbors
    Router ID: 10.3.3.3       Address: 192.168.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.1.2  BDR: 192.168.1.1   MTU: 0
       Dead timer due in 39  sec
       Retrans timer interval: 5
       Neighbor is up for 00:07:32
       Authentication Sequence: [ 0 ]

    # Check the OSPF routing information on SwitchC.

    <SwitchC> display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination      Cost  Type         NextHop         AdvRouter       Area
     192.168.1.0/24    1    Transit      192.168.1.2     10.3.3.3        0.0.0.1
     192.168.0.0/24    2    Inter-area   192.168.1.1     10.1.1.1        0.0.0.1
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

    The preceding command output shows that SwitchC has an inter-area route to the network segment 192.168.0.0/24.

    # Check the routing table on SwitchB, and perform the ping operation on SwitchB to test the connectivity between SwitchB and SwitchC.

    <SwitchB> display ospf routing
    
              OSPF Process 1 with Router ID 10.2.2.2
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop      AdvRouter       Area
     192.168.0.0/24     1     Transit    192.168.0.2  10.2.2.2        0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.0.1  10.1.1.1        0.0.0.0
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

    The preceding command output shows that SwitchB has an inter-area route to the network segment 192.168.1.0/24.

    # Perform the ping operation on SwitchB to test the connectivity between SwitchB and SwitchC.

    <SwitchB> ping 192.168.1.2
      PING 192.168.1.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.1.2: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 192.168.1.2: bytes=56 Sequence=2 ttl=253 time=16 ms
        Reply from 192.168.1.2: bytes=56 Sequence=3 ttl=253 time=62 ms
        Reply from 192.168.1.2: bytes=56 Sequence=4 ttl=253 time=94 ms
        Reply from 192.168.1.2: bytes=56 Sequence=5 ttl=253 time=63 ms
    
      --- 192.168.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/59/94 ms

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.0.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

BEST%20ANSWER!%20If%20you%20think%20I%20earn%20it!%3Cbr%2F%3E%3Cbr%2F%3EIf%20this%20post%20was%20useful%20to%20you%2C%20please%20click%20the%20%3Cimg%20id%3D%22aimg_eYhFO%22%20onclick%3D%22zoom(this%2C%20this.src%2C%200%2C%200%2C%200)%22%20class%3D%22zoom%22%20src%3D%22https%3A%2F%2Fforum.huawei.com%2Fenterprise%2Fen%2Fstatic%2Fimage%2Fcommon%2Fsupport01.png%22%20onmouseover%3D%22img_onmouseoverfunc(this)%22%20onload%3D%22thumbImg(this)%22%20border%3D%220%22%20alt%3D%22%22%20%2F%3E%20%3Cfont%20color%3D%22DarkOrange%22%3EHelpful%3C%2Ffont%3E%20button%20and%20flag%20my%20post%20as%20a%20%26quot%3BBEST%20ANSWER%26quot%3B%20so%20others%20can%20benefit.%20Thank%20you%20%3Cimg%20id%3D%22aimg_H808i%22%20onclick%3D%22zoom(this%2C
Protocol
Protocol Created Sep 23, 2018 06:25:48 Helpful(0) Helpful(0)

Posted by Sergio93 at 2018-09-22 17:03 Hello,OSPF is supported so definetely is a configuration problem. Please try to load these examples ...
Thank you sir for very well explain ...but in ENSP have example of OSPF on Router not of Switch...my
question is that .can OSPF packet passes through Trunk when not allowed on trunk..i-e if SwitchA learn route from SwitchC from Vlan20 and we allowed only Vlan10 on GE0/0/1 Then how route advertise
to SwitchB..
  • x
  • convention:

Mysterious.color
Mysterious.color MVE Created Sep 23, 2018 10:21:17 Helpful(0) Helpful(0)

can you share the configuration ?
  • x
  • convention:

Core%20Engineer%2C%20Technical%20Department.%20High%20experience%20in%20Networking
Sergio93
Sergio93 Created Sep 23, 2018 10:51:32 Helpful(0) Helpful(0)

Posted by Protocol at 2018-09-23 01:25 Thank you sir for very well explain ...but in ENSP have example of OSPF on Router not of Switch... ...
Hello,
Please simulate this example and add one more network to switch C. And then you can run the 'display ospf routing' command on switch B to check if the switchc received the adveretised network. 
You can create a loopback interface and advertise it using network command.
  • x
  • convention:

BEST%20ANSWER!%20If%20you%20think%20I%20earn%20it!%3Cbr%2F%3E%3Cbr%2F%3EIf%20this%20post%20was%20useful%20to%20you%2C%20please%20click%20the%20%3Cimg%20id%3D%22aimg_eYhFO%22%20onclick%3D%22zoom(this%2C%20this.src%2C%200%2C%200%2C%200)%22%20class%3D%22zoom%22%20src%3D%22https%3A%2F%2Fforum.huawei.com%2Fenterprise%2Fen%2Fstatic%2Fimage%2Fcommon%2Fsupport01.png%22%20onmouseover%3D%22img_onmouseoverfunc(this)%22%20onload%3D%22thumbImg(this)%22%20border%3D%220%22%20alt%3D%22%22%20%2F%3E%20%3Cfont%20color%3D%22DarkOrange%22%3EHelpful%3C%2Ffont%3E%20button%20and%20flag%20my%20post%20as%20a%20%26quot%3BBEST%20ANSWER%26quot%3B%20so%20others%20can%20benefit.%20Thank%20you%20%3Cimg%20id%3D%22aimg_H808i%22%20onclick%3D%22zoom(this%2C
Protocol
Protocol Created Sep 23, 2018 17:13:15 Helpful(0) Helpful(0)

Posted by Sergio93 at 2018-09-23 10:51 Hello,Please simulate this example and add one more network to switch C. And then you can run the ...
Hello ..if we not allowed any vlan on trunk then ospf traffic passess on that link??
  • x
  • convention:

Protocol
Protocol Created Sep 23, 2018 17:20:08 Helpful(0) Helpful(0)

SIR this my topolgy....two area i want to share routes through ospf from switch 3 to Router R ...but not learn route from switch 2 and sw3

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

Sergio93
Sergio93 Created Sep 23, 2018 20:34:38 Helpful(0) Helpful(0)

Posted by Protocol at 2018-09-23 12:13 Hello ..if we not allowed any vlan on trunk then ospf traffic passess on that link??
Hello,

Yes, the packets will pass, basically SW A is doing inter-vlan routing using VLANIF interfaces. 
It's exactly like in this example, there are 2 access links with different VLAN but they can communicate based on inter-vlan connection : 

Using VLANIF interfaces to implement inter-VLAN communication through the same switch 
fig_dc_cfg_vlan_101201.png

When Host_1 sends a packet to Host_2, the packet is transmitted as follows (assuming that no forwarding entry exists on the switch):

  1. Host_1 determines that the destination IP address is on a different network segment from its own IP address, and therefore sends an ARP Request packet to request the gateway MAC address. The ARP Request packet carries the destination IP address of 10.1.1.1 (gateway's IP address) and all-F destination MAC address.
  2. When the ARP Request packet reaches IF_1 on the Switch, the Switch tags the packet with VLAN 2 (PVID of IF_1). The Switch then adds the mapping between the source MAC address, VLAN ID, and interface (1-1-1, 2, IF_1) in its MAC address table.
  3. The Switch detects that the packet is an ARP Request packet and the destination IP address is the IP address of VLANIF 2. The Switch then encapsulates VLANIF 2's MAC address of 3-3-3 into the ARP Reply packet and removes the tag with VLAN 2 from the packet before sending it from IF_1. In addition, the Switch adds the binding of the IP address and MAC address of Host_1 in its ARP table.
  4. After receiving the ARP Reply packet from the Switch, Host_1 adds the binding of the IP address and MAC address of VLANIF 2 on the Switchin its ARP table and sends a packet to the Switch. The packet carries the destination MAC address of 3-3-3 and destination IP address of 10.2.2.2 (Host_2's IP address).
  5. After the packet reaches IF_1 on the Switch, the Switch tags the packet with VLAN 2.
  6. The Switch updates its MAC address table based on the source MAC address, VLAN ID, and inbound interface of the packet, and compares the destination MAC address of the packet with the MAC address of VLANIF 2. If they are the same, the Switch determines that the packet should be forwarded at Layer 3 and searches for a Layer 3 forwarding entry based on the destination IP address. If no entry is found, the Switch sends the packet to the CPU. The CPU then searches for a routing entry to forward the packet.
  7. The CPU looks up the routing table based on the destination IP address of the packet and detects that the destination IP address matches a directly connected network segment (network segment of VLANIF 3). The CPU continues to look up its ARP table but finds no matching ARP entry. Therefore, the Switch broadcasts an ARP Request packet with the destination address of 10.2.2.2 to all interfaces in VLAN 3. Before sending the ARP Request packet from IF_2, the Switch removes the tag with VLAN 2 from the packet.
  8. After receiving the ARP Request packet, Host_2 detects that the IP address is its own IP address and sends an ARP Reply packet with its own. Additionally, Host_2 adds the mapping between the MAC address and IP address of VLANIF 3 to its ARP table.
  9. After IF_2 on the Switch receives the ARP Reply packet, IF_2 tags the packet with VLAN 3 to the packet and adds the binding of the MAC address and IP address of Host_2 in its ARP table. Before forwarding the packet from Host_1 to Host_2, the Switch removes the tag with VLAN 3 from the packet. The Switch also adds the binding of Host_2's IP address, MAC address, VLAN ID, and outbound interface in its Layer 3 forwarding table.

The packet sent from Host_1 then reaches Host_2. The packet transmission process from Host_2 to Host_1 is similar. Subsequent packets between Host_1 and Host_2 are first sent to the gateway (Switch), and the Switch forwards the packets at Layer 3 based on its Layer 3 forwarding table.


  • x
  • convention:

BEST%20ANSWER!%20If%20you%20think%20I%20earn%20it!%3Cbr%2F%3E%3Cbr%2F%3EIf%20this%20post%20was%20useful%20to%20you%2C%20please%20click%20the%20%3Cimg%20id%3D%22aimg_eYhFO%22%20onclick%3D%22zoom(this%2C%20this.src%2C%200%2C%200%2C%200)%22%20class%3D%22zoom%22%20src%3D%22https%3A%2F%2Fforum.huawei.com%2Fenterprise%2Fen%2Fstatic%2Fimage%2Fcommon%2Fsupport01.png%22%20onmouseover%3D%22img_onmouseoverfunc(this)%22%20onload%3D%22thumbImg(this)%22%20border%3D%220%22%20alt%3D%22%22%20%2F%3E%20%3Cfont%20color%3D%22DarkOrange%22%3EHelpful%3C%2Ffont%3E%20button%20and%20flag%20my%20post%20as%20a%20%26quot%3BBEST%20ANSWER%26quot%3B%20so%20others%20can%20benefit.%20Thank%20you%20%3Cimg%20id%3D%22aimg_H808i%22%20onclick%3D%22zoom(this%2C
Sergio93
Sergio93 Created Sep 23, 2018 20:35:49 Helpful(0) Helpful(0)

Posted by Protocol at 2018-09-23 12:20 SIR this my topolgy....two area i want to share routes through ospf from switch 3 to Router R ...but ...
Hi,
Could you provide us the configuration from each device ? Did you specify which networks to advisertise through network command on each device ?
  • x
  • convention:

BEST%20ANSWER!%20If%20you%20think%20I%20earn%20it!%3Cbr%2F%3E%3Cbr%2F%3EIf%20this%20post%20was%20useful%20to%20you%2C%20please%20click%20the%20%3Cimg%20id%3D%22aimg_eYhFO%22%20onclick%3D%22zoom(this%2C%20this.src%2C%200%2C%200%2C%200)%22%20class%3D%22zoom%22%20src%3D%22https%3A%2F%2Fforum.huawei.com%2Fenterprise%2Fen%2Fstatic%2Fimage%2Fcommon%2Fsupport01.png%22%20onmouseover%3D%22img_onmouseoverfunc(this)%22%20onload%3D%22thumbImg(this)%22%20border%3D%220%22%20alt%3D%22%22%20%2F%3E%20%3Cfont%20color%3D%22DarkOrange%22%3EHelpful%3C%2Ffont%3E%20button%20and%20flag%20my%20post%20as%20a%20%26quot%3BBEST%20ANSWER%26quot%3B%20so%20others%20can%20benefit.%20Thank%20you%20%3Cimg%20id%3D%22aimg_H808i%22%20onclick%3D%22zoom(this%2C
Protocol
Protocol Created Sep 24, 2018 06:15:24 Helpful(0) Helpful(0)

This router and switch configuration... Router not
Learn routes from sw3I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS-2759347-1I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS-2759347-2I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS-2759347-3I have one problem in Switch configuration ..when i run OSPF on switch in ENSP then route not share to other switch....any one here for help..THANKS-2759347-4
  • x
  • convention:

12
Back to list

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login