Huawei S5700 and ESXI

Created: Sep 18, 2017 18:46:59Latest reply: Sep 18, 2017 19:08:01 2278 1 0 0
  Rewarded Hi-coins: 0 (problem resolved)

Hi all,

 

I'm planing to change my Cisco 2960G to some of Huawei S5700 series. I have one esxi single host conected to the cisco right now and i want to know how can pass this config in huawei.

My cisco config is the following:

 

!
interface Port-channel1
 description ENLACES ESX TRUNK
 switchport trunk allowed vlan 10,20,30,40,50,60,70
 switchport mode trunk
!
interface GigabitEthernet0/1
 description ENLACE ESX T1
 switchport trunk allowed vlan 10,20,30,40,50,60,70
 switchport mode trunk
 speed 1000
 duplex full
 channel-group 1 mode on
!
interface GigabitEthernet0/2
 description ENLACE ESX T2
 switchport trunk allowed vlan 10,20,30,40,50,60,70
 switchport mode trunk
 speed 1000
 duplex full
 channel-group 1 mode on
!
interface GigabitEthernet0/3
 description ENLACE ESX T3
 switchport trunk allowed vlan 10,20,30,40,50,60,70
 switchport mode trunk
 speed 1000
 duplex full
 channel-group 1 mode on
!
interface GigabitEthernet0/4
 description ENLACE ESX T4
 switchport trunk allowed vlan 10,20,30,40,50,60,70
 switchport mode trunk
 speed 1000
 duplex full
 channel-group 1 mode on

 

On ESX side i have 1 virtual switch with all nic in active mode and load balancing routed based on ip hash

 

I need to know if this is compatible with s5720 series and how to do it

 

Thanks

  • x
  • convention:

Featured Answers
Jon_TX
Created Sep 18, 2017 19:08:01 Helpful(0) Helpful(0)

Good day!

Cisco's term for link aggregation is port-channel.

Huawei uses 'eth-trunk'.

Create an 'eth-trunk' interface (just like on Cisco's 'port-channel' interface), then add physical interfaces to the eth-trunk.  

You only have to configure the VLAN's on the eth-trunk, not on the physical interfaces.

The default load balance mode is 'source and destination IP'.

Here is an example:

vlan batch 10 20
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 10 20
load-balance { dst-ip | dst-mac | src-ip | src-mac | src-dst-ip | src-dst-mac } // you can pick one
#
interface GigabitEthernet0/0/1
eth-trunk 1
#
interface GigabitEthernet0/0/2
eth-trunk 1
#
interface GigabitEthernet0/0/3
eth-trunk 1

Rating

Number of participants 1E-coins +20 Experience +1 Collapse Reasons
user_2845837 user_2845837 + 1 Awesome!
user_2845837 user_2845837 + 20 Awesome!

View All scores

  • x
  • convention:

All Answers
Jon_TX
Jon_TX Created Sep 18, 2017 19:08:01 Helpful(0) Helpful(0)

Good day!

Cisco's term for link aggregation is port-channel.

Huawei uses 'eth-trunk'.

Create an 'eth-trunk' interface (just like on Cisco's 'port-channel' interface), then add physical interfaces to the eth-trunk.  

You only have to configure the VLAN's on the eth-trunk, not on the physical interfaces.

The default load balance mode is 'source and destination IP'.

Here is an example:

vlan batch 10 20
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 10 20
load-balance { dst-ip | dst-mac | src-ip | src-mac | src-dst-ip | src-dst-mac } // you can pick one
#
interface GigabitEthernet0/0/1
eth-trunk 1
#
interface GigabitEthernet0/0/2
eth-trunk 1
#
interface GigabitEthernet0/0/3
eth-trunk 1

Rating

Number of participants 1E-coins +20 Experience +1 Collapse Reasons
user_2845837 user_2845837 + 1 Awesome!
user_2845837 user_2845837 + 20 Awesome!

View All scores

  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login