Huawei MA5800-X15 MPLA Active/Standby failure after config load

Created: Apr 11, 2019 12:28:02Latest reply: May 10, 2019 09:23:50 552 14 0 0
  Rewarded Hi-coins: 0 (problem resolved)

I have 2 Huawei MA5800-X15 OLTs with 2 H902MPLA boards each, one on my desk and one working in production.

Initially, both boards of the OLT on my desk were running fine. One of the boards had ACT led ON and the RUN/ALM led was blinking 

green (0.5s) on both of the boards, as it should be when things are running correctly.


I've exported the config from the production OLT via tftp running:


   backup configuration tftp 192.168.1.11 backup.cfg


After that I've loaded and applied this configuration into the OLT on my desk using:


    load configuration tftp 192.168.1.11 backup.cfg all

    active configuration system


After that, OLT on my desk has rebooted successfully and loaded new configuration. Next I run save command.

Then I decided to reboot the active board (board1) with:


     reboot active


During the reboot of board1 the ACT led on board2 has switched ON (green) and the RUN/ALM led on board1 started blinking red 

every 0.25 sec, which is normal during reboot. Unfortunately the board2's RUN/ALM led never became green again and ACT led 

has never blinked again. I left everything for a couple of days and nothing changed. Complete OLT reboot did not help.


I know that none of the boards are faulty because when I reboot the board2 then board1 comes online and board2 stays with 

RUN/ALM blinking led in red.

Seems like they are working separately and cannot get synchronized. When one board reboots, the other loads up and  becomes 

active, but the recently rebooted board just hangs in the middle of the loading process.


I've connected two console cables, one to each board, and I can see that the board with the red light just stops at the same point 

every time.

The active board on OLT has an alarm which says:


The communication between the board and the control board fails


Here is the console output from both boards:


https://imgur.com/a/8x3atmL


The board with RUN/ALM red light always stops after


Starting system application init......successfully!


After this line it should start loading config, but it does not until the active board goes for reboot!


I've tried to do a factory reset on both boards (separately) with:


    erase flash data

    reboot system


But it did not work out. Both boards have a default configuration now, but keep doing the same thing again and again. Looks like the 

boards can't sync the configuration between them. Or both want to become Active and only one loads up.


I´ve also upgraded both boards to V100R018C10SPH102. I´ve also erased nand fs by running nandfsformat from the BIOS on both 

boards and then loaded the packetfile. Same situation. There is an option eraseall but i´m not sure that I have the files to restore it.


I tried to google about this situation, but i did not find a single word about it. Seems like some unique situation.

Did anyone have similar problems with Huawei OLT?


  • x
  • convention:

All Answers
chmutoff Created Apr 25, 2019 09:54:13 Helpful(0) Helpful(0)

Posted by xiaker2012 at 2019-04-25 06:32 Dear customer, about your problem, it is probably caused by the following reasons,When the configura ...
Thank you for the reply. Is there any way of restoring both boards to factory defaults? I've tried erasing the nandfs from the bios and then loading a packetfile (containing bios and firmware) on both boards but i had no success. If I erase flash data and then save the config and data, will it make a new data file? How could I make the second board to syncronize with it? Should I load it somehow manually?

Meanwhile I sent the OLT to the distributor that sold it to me, i'm waiting for their response. But I got another OLT with exactly the same problem in production, so I need to fix that as well.
  • x
  • convention:

xiaker2012 Created Apr 26, 2019 06:28:35
Dear customer, if you want to initialize these two boards (if you can't start it locally), you only need to load the version from bios (the version is recommended to be downloaded from Huawei's official website support-e), the version package should contain basic Data configuration file (matches this version). When upgrading, you are advised to insert only one board to upgrade. After completing one board, insert another board to upgrade. After the two boards are upgraded (this ensures that the  
xiaker2012 Reply xiaker2012  Created Apr 26, 2019 06:35:13
After the two boards are upgraded (this ensures that the two boards are the same version). At the same time, let the two boards run at the same time, so that they can be used normally.  
xiaker2012 Created Apr 26, 2019 07:15:48
If you want to load from bios, you need to get the motherboard package .bin file, such as: scul_VerB_basebios_112.bin, the main control board expands bios: scul_extbios_115.bin, matching database configuration file: .dat file. First load the basic bios, after erasing the extended bios, reboot into the load extension bios. last load the data file.  
chmutoff Created May 10, 2019 09:23:50 Helpful(0) Helpful(0)

I sen't the OLT to the people that sold it to me and they have fixed it. The bad thing is that they told me strange things an I'm still having no clue about how the achieved to sync it. They just said that the load sharing mode was disable. When I asked for clarification, they said that they were referring to a disabled 'system switch-over', but that functionability only changes the currently active boar. Then they said that I did not loaded the firmware in the right way, but they did not clearly specified how they reloaded it.
  • x
  • convention:

12
Back to list

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top