Huawei Health app not working in the Pixel 3a

Latest reply: Jan 28, 2020 19:46:05 4616 10 0 0

Hello,

I'm having some troubles to pair my Huawei Watch GT2 with my Pixel 3a running the last firmware (Android 10).

After installing the Huawei Health and Huawei Mobile Sevices app, I keep getting the popup "Huawei Mobile Services app stopped working". I've tried to: reboot the phone several times, clear the caches of both apps, grant them all the permissions (calls logs, GPS, storage, etc.), disable any battery optimization that might kill the apps in the background. I've also tried to install the previous version, but nothing worked.

What else could I try?

Thank you!


  • x
  • convention:

wissal
MVE Created Dec 8, 2019 08:18:41 Helpful(2) Helpful(2)

Hello, dear user!

Please kindly note that on this Forum we are responsible for Enterprise products and your device belongs to the Huawei Consumer group.

For assistance needed regarding mobile broadband, mobile phones or home devices, we advise you to check the Huawei support website for Consumer, which also contains direct hotline phone numbers where you can contact our colleagues from the Consumer Business Group.

They are able to help you solve your issues: https://consumer.huawei.com/en/support/hotline/.

Thanks for your understanding!
  • x
  • convention:

I%20would%20like%20to%20share%20with%20you%20my%20experience%2C%20I'm%20telecommunications%20engineer%2C%20currently%20senior%20project%20manager%20at%20an%20operator%2C%20partner%20of%20Huawei%2C%20in%20the%20radio%20access%20network%20department%2C%20for%2020%20years%20I%20managed%20several%20types%20of%20projects%2C%20for%20the%20different%20nodes%20of%20the%20network.%3Cbr%2F%3EAt%20the%20same%20time%2C%20I%20give%20courses%20in%20universities%20as%20a%20temporary%2C%20to%20bring%20the%20operational%20side%20of%20telecommunication%20technologies%20to%20students%2C%20for%20network%20supervision%20systems%2C%20mobile%20radio%20networks%20and%20access%20networks%20etc.
JNL
Created Dec 8, 2019 12:49:11 Helpful(0) Helpful(0)

Huawei Health app not working in the Pixel 3a-3136854-1
  • x
  • convention:

You%20can%20do%20only%20what%20you%20think%20you%20can%20do%2C%20you%20can%20have%20only%20what%20you%20think%20you%20can%20have%2C%20and%20you%20can%20be%20only%20what%20you%20think%20you%20can%20be.%20We%20cannot%20express%20anything%20that%20we%20do%20not%20first%20have%20in%20the%20mind
user_3663872
Created Dec 11, 2019 19:16:08 Helpful(0) Helpful(0)

Hi friend

I have the same issue but on Mi 9. Did you fix your issue ? If yes, could you please help me.
  • x
  • convention:

user_3668264
Created Dec 15, 2019 15:03:57 Helpful(0) Helpful(0)

I have the same problem here. Huawei watch GT2 and Google Pixel 2 xl phone. "Huawei Mobile Services app stopped working."
  • x
  • convention:

user_3718452
user_3718452 Created Feb 6, 2020 22:20:39
Hello, i fix the problem with my Google pixel 3, you only need to download the Huawei service with anothe site. Foro example, i download the Huawei service from Aptoide and now are running!! Good luck Pd: sorry for my English, i'm from Spain (◠‿◕)  
Coliseu
Created Dec 16, 2019 17:09:05 Helpful(0) Helpful(0)

I have the same problem here. Huawei Mobile Services app stopped working
  • x
  • convention:

user_3701352
Created Jan 14, 2020 19:12:37 Helpful(0) Helpful(0)

Same problem with a pixel 3a, did you solve It?
  • x
  • convention:

user_3703610
Created Jan 16, 2020 15:20:51 Helpful(0) Helpful(0)

I have the same problem with my pixel XL , please recomend us some solution
  • x
  • convention:

user_3708706
Created Jan 22, 2020 11:12:03 Helpful(0) Helpful(0)

I have the same issue on my new Oppo Reno 3 5G phone. Finally I can fix the problem by create the account under your Phone setting manual, then select "Users and Accounts" and then choose add account button. You have to select Huawei Mobile Services and follow the instruction. Good luck!
  • x
  • convention:

Suchy
Created Jan 28, 2020 19:46:05 Helpful(0) Helpful(0)

This is help
https://forums.oneplus.com/threads/connection-to-huawei-mobile-services.1149607/
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login