Got it

How can Cisco 2911 configure PPPOE to Internet?

Latest reply: Dec 29, 2018 12:17:49 2442 3 6 0 0

This post refers to the process of how Cisco 2911 can configure PPPOE to Internet. Please see below the commands:


interface FastEthernet0/1  //public interface


pppoe enable 


pppoe-client dial-pool-number 1 


no cdp enable //



R3(config)#vpdn enable

R3(config)#vpdn-group 1

R3(config-vpdn)#request-dialin                           

R3(config-vpdn-req-in)#protocol pppoe



interface Dialer1  //create a dialer interface


mtu 1492 


ip address negotiated 


encapsulation ppp 


dialer pool 1 


dialer-group 1 


ppp authentication pap chap callin 


ppp chap hostname ad66548494


ppp chap password 0 123456 


ppp pap sent-username ad66548494 password 0 123456 




R3(config)#interface fastethernet 1/0

R3(config-if)#ip nat inside

R3(config-if)#exit

R3(config)#interface dialer 1      

R3(config-if)#ip nat outside

R3(config-if)#exit

R3(config)#access-list 1 permit any

R3(config)#ip nat inside source list 1 interface dialer 1 overload 

R3(config)#ip route 0.0.0.0 0.0.0.0 dialer 1                 configure the default route




R3(config)#ip dhcp pool local_net

R3(dhcp-config)#network 192.168.1.0 /24

R3(dhcp-config)#default-router 192.168.1.1

R3(dhcp-config)#import all                          //  导入从上级DHCP获得的IP配置

R3(dhcp-config)#exit

R3(config)#interface fastethernet 1/0

R3(config-if)#ip address 192.168.1.1 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit


  • x
  • convention:

SupperRobin
Created Dec 29, 2018 03:36:36

In the current network, cisco is more KS, so this article takes cisco KS as an example. In order to monopolize the A2A market, Cisco vendors do not support unicast docking with other vendors' GMs. Later, under pressure, they started the RFC draft version, stating that they can be connected to other vendors in versions later than 15.1, but found in the test. In the subsequent IOS version, the private field is added to the A2A structure.
View more
  • x
  • convention:

Finn92
Created Dec 29, 2018 03:45:08

why share cisco configuration ..... no idea ..
View more
  • x
  • convention:

littlestone
Created Dec 29, 2018 12:17:49

PPPoE (English: Point-to-Point Protocol Over Ethernet), a point-to-point protocol on ethernet, is a network tunnel protocol encapsulated in the framework of ethernet. Because PPP protocol is integrated in the protocol, authentication, encryption and compression can not be provided by traditional Ethernet are realized.
View more
  • x
  • convention:

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.