Guide for Replacement and Interoperation Between Huawei Switches and Cisco Switches

112 0 0 0

Networking Requirements

A campus network has two branches. Branch B encounters problems such as network congestion, insufficient bandwidth, and outdated devices. To address these problems, the customer wants to replace devices at the aggregation and access layers of branch B by Huawei devices, with the network plan remaining unchanged.

Figure 2-104 shows the networking before the replacement, on which Cisco switches are deployed. A port channel is established between core switches and between aggregation switches of each branch to provide link redundancy. HSRP is configured on core switches to implement virtual gateway backup. In the networking, Rapid PVST+ is configured on switches to prevent loops.

Figure 2-104  Networking before the replacement 
imgDownload?uuid=49286e3012334fb3a0b31a1

Figure 2-105 shows the networking after the replacement.

Key requirements of the aggregation layer are as follows:
  • Use two S12704 switches that set up a CSS to replace Cisco switches CiscoC and CiscoD at the aggregation layer.
  • Use the CSS to replace Cisco HSRP. The switchover time upon a CSS single point of failure is shorter than HSRP-based active/standby switchover.
  • Interoperate with Cisco switches CiscoA and CiscoB through LACP, CDP, OSPF, and Rapid PVST+.
  • Retain the original configurations of Cisco switches such as ACL policies, OSPF, and interface configurations.
Key requirements of the access layer are as follows:
  • Use two S5730HI switches that set up a stack to replace Cisco access switches CiscoE and CiscoF to improve reliability.
  • Retain the original configurations of Cisco switches, such as ACL policies, access terminal negotiation mode, port security, and storm control.
Figure 2-105  Networking after the replacement 
imgDownload?uuid=d866a0b2ba384876b767824

Check Before the Replacement

Before the replacement, run the commands listed in Table 2-123 to check the status of Cisco switches. This facilitates service comparison after the replacement.

Table 2-123  Commands for checking status of Cisco switches before the replacement
ItemCommand
Checking the clock status

show clock

Checking the interface status

show interface brief

Checking the MAC address table

show mac address-table

Checking the neighbor status

show cdp neighbors

Checking the ARP table

show ip arp

Checking the routing table

show ip route

Checking the STP status

show spanning-tree summary

show spanning-tree detail

Checking the existing configurations

show version

show running-config

Configuration Roadmap

  1. Perform service configurations for the S12704 CSS, CiscoA, CiscoB, CiscoC, CiscoD, and S5730HI stack.

  2. Connect the S12704 CSS to CiscoA and CiscoB through physical cables.
  3. Connect the S12704 CSS to CiscoC and CiscoD through physical cables.
  4. Connect the S5730HI stack to the network to replace Cisco access switches CiscoE and CiscoF.
  5. Disable the switch virtual interfaces (SVIs) on CiscoC and CiscoD and enable VLANIF interfaces for the S12704 CSS. SVIs on Cisco switches are equivalent to VLANIF interfaces on Huawei switches.
  6. Remove the cables between S12704 CSS and CiscoC and CiscoD and the cables between CiscoC and CiscoD and between CiscoA and CiscoB.
  7. Check whether services of the terminals connected to the S5730HI stack are normal.

Data Plan

Table 2-124  Data plan for link aggregation
DeviceLink Aggregation InterfacePhysical InterfaceFunction

CiscoA

Port-channel 3

Te2/2

Te4/3

Interconnection with the S12704 CSS

CiscoB

Port-channel 3

Te2/2

Te4/3

Interconnection with the S12704 CSS

CiscoC

Port-channel 256

Gi3/1

Gi3/2

Gi8/1

Gi8/2

Interconnection with the S12704 CSS

CiscoD

Port-channel 256

Gi3/1

Gi3/2

Gi8/1

Gi8/2

Interconnection with the S12704 CSS

S12704 CSS

Eth-Trunk 2

XGE1/1/0/44

XGE1/1/0/45

XGE1/2/0/44

XGE1/2/0/45

Interconnection with CiscoC

Eth-Trunk 3

XGE2/1/0/44

XGE2/1/0/45

XGE2/2/0/44

XGE2/2/0/45

Interconnection with CiscoD

Eth-Trunk 4

XGE1/2/0/46

XGE2/2/0/46

Interconnection with CiscoA

Eth-Trunk 5

XGE1/1/0/46

XGE2/1/0/46

Interconnection with CiscoB
Table 2-125  IP address plan
DeviceItemFunction

CiscoA

  • Port-channel 3: 168.106.194.161 255.255.255.252

  • Loopback0: 168.106.194.254 255.255.255.255

  • Port-channel 3 is used to interconnect with the S12704 CSS.

  • The IP address of Loopback0 is used as the router ID.

CiscoB

  • Port-channel 3: 168.106.193.161 255.255.255.252

  • Loopback0: 168.106.194.253 255.255.255.255

  • Port-channel 3 is used to interconnect with the S12704 CSS.

  • The IP address of Loopback0 is used as the router ID.

CiscoC

Loopback0: 168.106.7.254 255.255.255.255

The IP address of Loopback0 is used as the router ID.

CiscoD

Loopback0: 168.106.7.253 255.255.255.255

The IP address of Loopback0 is used as the router ID.

S12704 CSS

Eth-Trunk 4: 168.106.193.162 255.255.255.252

Eth-Trunk 4 is used to interconnect with CiscoA.

Eth-Trunk 5: 168.106.194.162 255.255.255.252

Eth-Trunk 5 is used to interconnect with CiscoB.

LoopBack0: 168.106.7.252 255.255.255.255

The IP address of Loopback0 is used as the router ID.

Procedure

  1. Deploy the two S12704 switches in a CSS and two S5730HI switches in a stack and perform the following configurations:

    • Configure link aggregation in LACP mode and OSPF between S12704 switches and Cisco core switches, and set the network type of OSPF interfaces to P2P.

      # Configure Eth-Trunk 4 and Eth-Trunk 5 in LACP mode for the S12704 CSS and add interfaces to the Eth-Trunks.

      <HUAWEI> system-view[HUAWEI] syaname CSS[CSS] interface eth-trunk 4[CSS-Eth-Trunk4] mode lacp[CSS-Eth-Trunk4] quit[CSS] interface eth-trunk 5[CSS-Eth-Trunk5] mode lacp[CSS-Eth-Trunk5] quit[CSS] interface XGigabitEthernet 1/2/0/46[CSS-XGigabitEthernet1/2/0/46] eth-trunk 4[CSS-XGigabitEthernet1/2/0/46] lldp compliance cdp txrx      //Enable the interface to exchange information with CDP-capable devices.[CSS-XGigabitEthernet1/2/0/46] quit[CSS] interface XGigabitEthernet 2/2/0/46[CSS-XGigabitEthernet2/2/0/46] eth-trunk 4[CSS-XGigabitEthernet2/2/0/46] lldp compliance cdp txrx[CSS-XGigabitEthernet2/2/0/46] quit[CSS] interface XGigabitEthernet 1/1/0/46[CSS-XGigabitEthernet1/1/0/46] eth-trunk 5 [CSS-XGigabitEthernet1/1/0/46] lldp compliance cdp txrx[CSS-XGigabitEthernet1/1/0/46] quit[CSS] interface XGigabitEthernet 2/1/0/46  [CSS-XGigabitEthernet2/1/0/46] eth-trunk 5[CSS-XGigabitEthernet2/1/0/46] lldp compliance cdp txrx[CSS-XGigabitEthernet2/1/0/46] quit

      # Configure OSPF for the S12704 CSS.

      [CSS] interface LoopBack0[CSS-LoopBack0] ip address 168.106.7.252 255.255.255.255[CSS-LoopBack0] quit[CSS] interface eth-trunk 4[CSS-Eth-Trunk4] undo portswitch[CSS-Eth-Trunk4] ip address 168.106.193.162 255.255.255.252[CSS-Eth-Trunk4] ospf authentication-mode md5 1 cipher Huawei@123   //The password must be the same as that on the peer end.[CSS-Eth-Trunk4] ospf network-type p2p[CSS-Eth-Trunk4] quit[CSS] interface eth-trunk 5[CSS-Eth-Trunk5] undo portswitch[CSS-Eth-Trunk5] ip address 168.106.194.162 255.255.255.252[CSS-Eth-Trunk5] ospf authentication-mode md5 1 cipher Admin@123   //The password must be the same as that on the peer end.[CSS-Eth-Trunk5] ospf network-type p2p[CSS-Eth-Trunk5] quit[CSS] ospf 100 router-id 168.106.7.252[CSS-ospf-100] silent-interface all[CSS-ospf-100] undo silent-interface Eth-Trunk4[CSS-ospf-100] undo silent-interface Eth-Trunk5   //Except for Eth-Trunk 4 and Eth-Trunk 5, disable the other interfaces from sending and receiving OSPF packets.[CSS-ospf-100] area 0.0.0.0[CSS-ospf-100-area-0.0.0.0] authentication-mode md5   [CSS-ospf-100-area-0.0.0.0] network 168.106.193.160 0.0.0.3[CSS-ospf-100-area-0.0.0.0] network 168.106.194.160 0.0.0.3[CSS-ospf-100-area-0.0.0.0] quit[CSS-ospf-100] quit

      # Configure the ICMP attribute for the S12704 CSS.

      [CSS] interface eth-trunk 4[CSS-Eth-Trunk4] undo icmp host-unreachable send      //Disable the switch from sending ICMP Host Unreachable packets. This prevents the peer device from processing a large number of ICMP packets.[CSS-Eth-Trunk4] undo icmp redirect send     //Disable the switch from sending ICMP redirect packets.[CSS-Eth-Trunk4] quit[CSS] interface eth-trunk 5[CSS-Eth-Trunk5] undo icmp host-unreachable send[CSS-Eth-Trunk5] undo icmp redirect send[CSS-Eth-Trunk5] quit
      # The related CiscoA and CiscoB configuration files are as follows:
      • CiscoA configuration file:
        !
        interface Loopback0
         ip address 168.106.194.254 255.255.255.255
        !
        port-channel per-module load-balance
        !
        interface Port-channel3        
         ip address 168.106.194.161 255.255.255.252
         no ip redirects
         no ip unreachables
         no ip proxy-arp
         ip ospf authentication message-digest      
         ip ospf message-digest-key 1 md5 7 1108180B1206
         ip ospf network point-to-point
         ip ospf cost 1000
        !
        interface TenGigabitEthernet2/2
         no ip address
         channel-group 3 mode active
        !
        interface TenGigabitEthernet4/3
         no ip address
         channel-group 3 mode active
        !
        router ospf 100
         router-id 168.106.194.254
         area 0 authentication message-digest
         network 168.106.193.160 0.0.0.3 area 0
      • CiscoB configuration file:
        !
        interface Loopback0
         ip address 168.106.194.253 255.255.255.255
        !
        port-channel per-module load-balance
        !
        interface Port-channel3
         ip address 168.106.193.161 255.255.255.252
         no ip redirects
         no ip unreachables
         no ip proxy-arp
         ip ospf authentication message-digest
         ip ospf message-digest-key 1 md5 7 104F08170003
         ip ospf network point-to-point
         ip ospf cost 1000
        !
        interface TenGigabitEthernet2/2
         no ip address
         channel-group 3 mode active
        !
        interface TenGigabitEthernet4/3
         no ip address
         channel-group 3 mode active
        !
        router ospf 100
         router-id 168.106.194.253
         area 0 authentication message-digest
         network 168.106.193.160 0.0.0.3 area 0
    • Connect the S12704 CSS and Cisco aggregation switches CiscoC and CiscoD through Eth-Trunks in LACP mode. Cisco aggregation switches use Rapid PVST+ to prevent loops. Therefore, VBST needs to be enabled for the S12704 CSS to interoperate with Rapid PVST+.

      # Configure Eth-Trunk 2 and Eth-Trunk 3 in LACP mode for the S12704 CSS, and add interfaces to the Eth-Trunks.

      [CSS] interface eth-trunk 2[CSS-Eth-Trunk2] mode lacp[CSS-Eth-Trunk2] quit[CSS] interface eth-trunk 3[CSS-Eth-Trunk3] mode lacp[CSS-Eth-Trunk3] quit[CSS] interface XGigabitEthernet 1/1/0/44[CSS-XGigabitEthernet1/1/0/44] eth-trunk 2[CSS-XGigabitEthernet1/1/0/44] lldp compliance cdp txrx[CSS-XGigabitEthernet1/1/0/44] quit[CSS] interface XGigabitEthernet 1/1/0/45[CSS-XGigabitEthernet1/1/0/45] eth-trunk 2[CSS-XGigabitEthernet1/1/0/45] lldp compliance cdp txrx[CSS-XGigabitEthernet1/1/0/45] quit[CSS] interface XGigabitEthernet 1/2/0/44[CSS-XGigabitEthernet1/2/0/44] eth-trunk 2[CSS-XGigabitEthernet1/2/0/44] lldp compliance cdp txrx[CSS-XGigabitEthernet1/2/0/44] quit[CSS] interface XGigabitEthernet 1/2/0/45[CSS-XGigabitEthernet1/2/0/45] eth-trunk 2 [CSS-XGigabitEthernet1/2/0/45] lldp compliance cdp txrx[CSS-XGigabitEthernet1/2/0/45] quit[CSS] interface XGigabitEthernet 2/1/0/44[CSS-XGigabitEthernet2/1/0/44] eth-trunk 3 [CSS-XGigabitEthernet2/1/0/44] lldp compliance cdp txrx[CSS-XGigabitEthernet2/1/0/44] quit[CSS] interface XGigabitEthernet 2/1/0/45[CSS-XGigabitEthernet2/1/0/45] eth-trunk 3 [CSS-XGigabitEthernet2/1/0/45] lldp compliance cdp txrx[CSS-XGigabitEthernet2/1/0/45] quit[CSS] interface XGigabitEthernet 2/2/0/44[CSS-XGigabitEthernet2/2/0/44] eth-trunk 3 [CSS-XGigabitEthernet2/2/0/44] lldp compliance cdp txrx[CSS-XGigabitEthernet2/2/0/44] quit[CSS] interface XGigabitEthernet 2/2/0/45[CSS-XGigabitEthernet2/2/0/45] eth-trunk 3 [CSS-XGigabitEthernet2/2/0/45] lldp compliance cdp txrx[CSS-XGigabitEthernet2/2/0/45] quit

      # Configure VBST for the S12704 CSS.

      [CSS] stp mode vbst[CSS] vlan batch 2 4 33 73[CSS] stp vlan 2 4 33 73 priority 12288[CSS] interface eth-trunk 2[CSS-Eth-Trunk2] port link-type trunk[CSS-Eth-Trunk2] undo port trunk allow-pass vlan 1[CSS-Eth-Trunk2] port trunk allow-pass vlan 2 4 33 73[CSS-Eth-Trunk2] stp no-agreement-check           //Configure the common fast transition mechanism on the interface.[CSS-Eth-Trunk2] quit[CSS] interface eth-trunk 3[CSS-Eth-Trunk3] port link-type trunk[CSS-Eth-Trunk3] undo port trunk allow-pass vlan 1[CSS-Eth-Trunk3] port trunk allow-pass vlan 2 4 33 73[CSS-Eth-Trunk3] stp no-agreement-check           [CSS-Eth-Trunk3] quit
      # The related CiscoC and CiscoD configuration files are as follows:
      • CiscoC configuration file:
        !
        spanning-tree mode rapid-pvst
        spanning-tree loopguard default
        no spanning-tree optimize bpdu transmission
        spanning-tree extend system-id
        spanning-tree backbonefast
        spanning-tree vlan 1,33,73 priority 8192
        spanning-tree vlan 2,4 priority 4096
        port-channel per-module load-balance
        !
        interface GigabitEthernet3/1
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
        !
        interface GigabitEthernet3/2
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
        !
        interface GigabitEthernet8/1
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
        !
        interface GigabitEthernet8/2
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
      • CiscoD configuration file:
        !
        spanning-tree mode rapid-pvst
        spanning-tree loopguard default
        no spanning-tree optimize bpdu transmission
        spanning-tree extend system-id
        spanning-tree backbonefast
        spanning-tree vlan 1,33,73 priority 4096
        spanning-tree vlan 2,4 priority 8192
        port-channel per-module load-balance
        !
        interface GigabitEthernet3/1
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
        !
        interface GigabitEthernet3/2
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
        !
        interface GigabitEthernet8/1
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
        !
        interface GigabitEthernet8/2
         switchport
         switchport trunk allowed vlan 2,4,33,73
         switchport mode trunk
         switchport nonegotiate
         channel-group 256 mode active
    • Create VLANIF2 for the S12704 CSS and create VLAN2 on Cisco aggregation switches CiscoC and CiscoD to advertise routes of CiscoC and CiscoD to the S12704 CSS.

      # Perform the following configurations for the S12704 CSS:

      [CSS] interface Vlanif2[CSS-Vlanif2] ip address 168.106.7.7 255.255.255.128[CSS-Vlanif2] undo icmp host-unreachable send[CSS-Vlanif2] undo icmp redirect send[CSS-Vlanif2] ospf authentication-mode md5 1 cipher Huawei@345[CSS-Vlanif2] ospf dr-priority 95[CSS-Vlanif2] quit[CSS] ospf 100 router-id 168.106.7.252[CSS-ospf-100] undo silent-interface Vlanif2[CSS-ospf-100] area 0.0.0.3[CSS-ospf-100-area-0.0.0.3] authentication-mode md5   [CSS-ospf-100-area-0.0.0.3] network 168.106.7.0 0.0.0.127[CSS-ospf-100-area-0.0.0.3] quit[CSS-ospf-100] quit
      # The related CiscoC and CiscoD configuration files are as follows:
      • CiscoC configuration file:
        !
        interface Loopback0
         ip address 168.106.7.254 255.255.255.255
        !
        interface Vlan2
         ip address 168.106.7.2 255.255.255.128
         no ip redirects
         no ip unreachables
         no ip proxy-arp
         ip ospf authentication message-digest
         ip ospf message-digest-key 1 md5 7 094D4F071C11
         ip ospf priority 105
        !
        router ospf 100
         router-id 168.106.7.254
         area 3 authentication message-digest
         passive-interface default
         no passive-interface Vlan2
         network 168.106.7.0 0.0.0.127 area 3
      • CiscoD configuration file:
        !
        interface Loopback0
         ip address 168.106.7.253 255.255.255.255
        !
        interface Vlan2
         ip address 168.106.7.3 255.255.255.128
         no ip redirects
         no ip unreachables
         no ip proxy-arp
         ip ospf authentication message-digest
         ip ospf message-digest-key 1 md5 7 094D4F071C11
         ip ospf priority 100
        !
        router ospf 100
         router-id 168.106.7.253
         area 3 authentication message-digest
         passive-interface default
         no passive-interface Vlan2
         network 168.106.7.0 0.0.0.127 area 3

  2. Use physical cables to connect the S12704 CSS and Cisco core switches CiscoA and CiscoB through the Eth-Trunks in LACP mode, as shown in Figure 2-106.

    Figure 2-106  Migration process 1 
    imgDownload?uuid=3ed93f9ab6b54f4d9b03e41

    # After cables are connected, run the display ospf peer brief command to check whether OSPF is running properly. The following information indicates that OSPF is running properly:

    <CSS> display ospf peer brief
             OSPF Process 1 with Router ID 168.106.7.252
                       Peer Statistic Information
     ----------------------------------------------------------------------------
     Area Id          Interface                        Neighbor id      State    
     0.0.0.0          Eth-Trunk4                       168.106.194.254  Full        
     0.0.0.0          Eth-Trunk5                       168.106.194.253  Full        
     ----------------------------------------------------------------------------   
     Total Peer(s):     2

    # Ping CiscoA and CiscoB to check the connectivity between the S12704 CSS and CiscoA and CiscoB. CiscoA is used as an example. The following information indicates that CiscoA is pinged successfully.

    <CSS> ping 168.106.194.161
      PING 168.106.194.161: 56  data bytes, press CTRL_C to break
        Reply from 168.106.194.161: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 168.106.194.161: bytes=56 Sequence=2 ttl=253 time=16 ms
        Reply from 168.106.194.161: bytes=56 Sequence=3 ttl=253 time=62 ms
        Reply from 168.106.194.161: bytes=56 Sequence=4 ttl=253 time=94 ms
        Reply from 168.106.194.161: bytes=56 Sequence=5 ttl=253 time=63 ms
    
      --- 168.106.194.161 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/59/94 ms

  3. Use physical cables to connect the S12704 CSS and Cisco aggregation switches CiscoC and CiscoD through the Eth-Trunks in LACP mode, as shown in Figure 2-107.

    Figure 2-107  Migration process 2 
    imgDownload?uuid=f3d31868fca543e5901e852

    # After cables are connected, run the display stp brief command to check the VBST status. The status of Eth-Trunk 2 and Eth-Trunk 3 is normal in different VLANs.

    <CSS> display stp brief
     VLAN-ID   Port                        Role  STP State     Protection
           2   Eth-Trunk2                  ALTE  DISCARDING    NONE
           2   Eth-Trunk3                  ROOT  FORWARDING    NONE
           4   Eth-Trunk2                  ALTE  DISCARDING    NONE
           4   Eth-Trunk3                  ROOT  FORWARDING    NONE  
          33   Eth-Trunk2                  ROOT  FORWARDING    NONE
          33   Eth-Trunk3                  ALTE  DISCARDING    NONE
          73   Eth-Trunk2                  ROOT  FORWARDING    NONE
          73   Eth-Trunk3                  ALTE  DISCARDING    NONE

    # Run the display ospf peer brief command to check whether routes of CiscoC and CiscoD have been advertised to the S12704 CSS. The following information indicates that OSPF is running properly:

    <CSS> display ospf peer brief
             OSPF Process 1 with Router ID 168.106.7.252
                       Peer Statistic Information
     ----------------------------------------------------------------------------
     Area Id          Interface                        Neighbor id      State    
     0.0.0.0          Eth-Trunk4                       168.106.194.254  Full        
     0.0.0.0          Eth-Trunk5                       168.106.194.253  Full        
     0.0.0.3          Vlanif2                          168.106.7.254    Full        
     0.0.0.3          Vlanif2                          168.106.7.253    Full
     ----------------------------------------------------------------------------   
     Total Peer(s):     4
    # Ping CiscoC and CiscoD to check the connectivity between the S12704 CSS and CiscoC and CiscoD. CiscoC is used as an example. The following information indicates that CiscoC is pinged successfully.
    <CSS> ping 168.106.7.254
      PING 168.106.7.254: 56  data bytes, press CTRL_C to break
        Reply from 168.106.7.254: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 168.106.7.254: bytes=56 Sequence=2 ttl=253 time=16 ms
        Reply from 168.106.7.254: bytes=56 Sequence=3 ttl=253 time=62 ms
        Reply from 168.106.7.254: bytes=56 Sequence=4 ttl=253 time=94 ms
        Reply from 168.106.7.254: bytes=56 Sequence=5 ttl=253 time=63 ms
    
      --- 168.106.7.254 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/59/94 ms

  4. Configure the S5730HI switches in a stack. Disconnect a physical link between CiscoC and CiscoE, and connect one end of the physical link to the uplink interface of the S5730HI stack and the other end to the S12704 CSS. Migrate cables connecting to downlink interfaces of CiscoE to the corresponding downlink interfaces of the S5730HI. Migrate the other physical link between CiscoC and CiscoE in a similar manner. Migrate the other access switches using the same method. After the operations are completed, run the commands listed in Table 2-126 for the S5730HI stack to verify that services are running properly. The STP status does not need to be checked.
  5. Run the shutdown command to disable the SVIs on Cisco aggregation switches CiscoC and CiscoD where the interface vlan command has been run. The VLANIF interfaces of the S12704 CSS are in Down state (excluding VLANIF2 corresponding to VLAN2). Then run the undo shutdowncommand on a VLANIF interface to enable the VLANIF interface for the S12704 CSS. Migrate the gateway from CiscoC and CiscoD to the S12704 CSS. After the operations are completed, run the commands listed in Table 2-126 for the S12704 CSS to verify that services are running properly.
  6. Remove the cables between S12704 CSS and CiscoC and CiscoD and the cables between CiscoC and CiscoD and between CiscoA and CiscoB. Delete configurations such as the Eth-Trunk, OSPF, and VBST that are related to CiscoC and CiscoD from the S12704 CSS. After the operations are completed, run the commands listed in Table 2-126 for the S12704 CSS to verify that services are running properly.
  7. Check whether services connected to the S5730HI stack are normal, for example, whether PCs can access the Internet properly and whether APs can provide wireless access.

Check After the Replacement

After the replacement, run the commands listed in Table 2-126 to check the status and entries of Huawei switches and compare them with those on Cisco switches before the replacement. Ensure that routing table entries, ARP table entries, MAC address table entries, and neighbors remain unchanged after the replacement. This can only preliminarily determine whether the network devices are normal. To check whether the migration is successful, check the service status.

Table 2-126  Commands for checking the status of Huawei switches after the replacement
ItemCommand
Checking the clock status

display clock

Checking the interface status

display interface brief

Checking the MAC address table

display mac-address

Checking the neighbor status

display lldp neighbor

Checking the ARP table

display arp

Checking the routing table

display ip routing-table

Checking the STP status

display stp brief

display stp global

Checking the existing configurations

display current-configuration

display saved-configuration

Checking logs and alarms

display logbuffer

display alarm active

display alarm history


See more please click 

https://support.huawei.com/enterprise/en/doc/EDOC1000069520/9aadccc0/comprehensive-configuration-examples


  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login