Example for Connecting a Stack to an NLB Cluster (Using Physical Link Loopback)

Latest reply: May 2, 2018 05:38:18 2768 3 0 0

Example for Connecting a Stack to an NLB Cluster (Using Physical Link Loopback)

Overview

NLB is developed by Microsoft for a cluster set up by multiple Windows servers. When a switch is connected to an NLB cluster, the switch needs to send packets destined for the cluster IP address to every NLB server in the cluster. An NLB server can work in unicast, multicast, or IGMP multicast mode.

Currently, a switch can be connected to the NLB server working in only unicast or multicast mode. If the switch supports multi-interface ARP, this function is recommended to implement the connection between the switch and NLB cluster. When the switch or version does not support multi-interface ARP and there are insufficient device resources, you can use physical link loopback to connect the switch to the NLB cluster.

Configuration Notes

l   When the NLB cluster works in unicast mode, static ARP entries do not need to be configured on the switch; when the cluster works in multicast mode, static ARP entries need to be configured on the switch.

l   A VRRP virtual gateway cannot be configured on a switch in a stack for clients.

l   Table 1 lists the applicable products and versions.

Table 1 Applicable product models and versions

Product

Product Model

Software Version

S2700

S2710SI

V100R006C05

S2700EI

V100R006C05

S2720EI

V200R006C10, V200R009C00, V200R010C00, V200R011C10

S2750EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S3700

S3700SI

V100R006C05

S3700EI

V100R006C05

S5700

S5700LI

V200R001C00, V200R002C00, V200R003(C00&C02&C10), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5700S-LI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5700SI

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02&C03)

S5700HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-C-LI

V200R001C00

S5710-X-LI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5710EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710HI

V200R005C03

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5720HI

V200R009C00, V200R010C00, V200R011C00, V200R011C10

S6700

S6700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6720LI and S6720S-LI

V200R011C00, V200R011C10

S6720SI and S6720S-SI

V200R011C00, V200R011C10

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10

 

20170531100535670001.jpg

For details about software mappings, see Version Mapping Search for Huawei Campus Switches.

Networking Requirements

As shown in Figure 1, Switch_1 and Switch_2 form a stack and are directly connected to two NLB servers respectively through GE0/0/1 and GE1/0/1. The NLB cluster works in multicast mode, the cluster IP address is 10.128.246.252/24, and the cluster MAC address is 03bf-0a80-f6fc. There are reachable routes between the Switch and Client.

The customer requires that the stack be able to send the Client's packets destined for the NLB cluster IP address to all NLB servers.

Figure 1 Connecting a stack to an NLB cluster in multicast mode

20170531100536911002.png

 

Data plan

Before the configuration, you need the following data.

Item

Data

Description

IP address

VLANIF200: 10.128.246.250/24

-

Configuration Roadmap

The configuration roadmap is as follows:

1.         Add GE0/0/1 and GE1/0/1 that are directly connected to NLB servers to VLAN 100.

2.         Add GE0/0/4 and GE1/0/4 to Eth-Trunk 4, and GE0/0/5 and GE1/0/5 to Eth-Trunk 5.

3.         Disable STP, RSTP, VBST, or MSTP on Eth-Trunk 4 and Eth-Trunk 5, and add Eth-Trunk 4 and Eth-Trunk 5 to VLAN 100 and VLAN 200 respectively in access mode.

4.         Configure an IP address for VLANIF 200 that functions as the NLB cluster's gateway.

5.         Configure a static ARP entry. In the static ARP entry, the IP address is the cluster IP address, the MAC address is the cluster multicast MAC address, and the outbound interface is the interface where the VLAN to which the NLB cluster's gateway belongs is configured.

6.         Connect GE0/0/4 and GE0/0/5 as well as GE1/0/4 and GE1/0/5.

Procedure

                               Step 1     Add interfaces directly connected to NLB servers to VLAN 100.

# Add GE0/0/1 to VLAN 100.

<HUAWEI> system-view
[HUAWEI] sysname Stack
[Stack] vlan batch 100 200
[Stack] interface gigabitethernet 0/0/1
[Stack-GigabitEthernet0/0/1] port link-type access  
[Stack-GigabitEthernet0/0/1] port default vlan 100
[Stack-GigabitEthernet0/0/1] quit

# Add GE1/0/1 to VLAN 100.

[Stack] interface gigabitethernet 1/0/1
[Stack-GigabitEthernet1/0/1] port link-type access  
[Stack-GigabitEthernet1/0/1] port default vlan 100
[Stack-GigabitEthernet1/0/1] quit

                               Step 2     Add interfaces to Eth-Trunks.

# Add GE0/0/4 and GE1/0/4 to Eth-Trunk 4.

[Stack] interface eth-trunk 4
[Stack-Eth-Trunk4] quit
[Stack] interface gigabitethernet 0/0/4
[Stack-GigabitEthernet0/0/4] eth-trunk 4
[Stack-GigabitEthernet0/0/4] quit
[Stack] interface gigabitethernet 1/0/4
[Stack-GigabitEthernet1/0/4] eth-trunk 4
[Stack-GigabitEthernet1/0/4] quit

# Add GE0/0/5 and GE1/0/5 to Eth-Trunk 5.

[Stack] interface eth-trunk 5
[Stack-Eth-Trunk5] quit
[Stack] interface gigabitethernet 0/0/5
[Stack-GigabitEthernet0/0/5] eth-trunk 5
[Stack-GigabitEthernet0/0/5] quit
[Stack] interface gigabitethernet 1/0/5
[Stack-GigabitEthernet1/0/5] eth-trunk 5
[Stack-GigabitEthernet1/0/5] quit

                               Step 3     Configure Eth-Trunk 4 and Eth-Trunk 5.

# Disable STP, RSTP, VBST, or MSTP on Eth-Trunk 4 and Eth-Trunk 5.

[Stack] interface eth-trunk 4
[Stack-Eth-Trunk4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP
[Stack-Eth-Trunk4] quit
[Stack] interface eth-trunk 5
[Stack-Eth-Trunk5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP
[Stack-Eth-Trunk5] quit

# Add Eth-Trunk 4 and Eth-Trunk 5 to VLAN 100 and VLAN 200 respectively in access mode.

[Stack] interface eth-trunk 4
[Stack-Eth-Trunk4] port link-type access
[Stack-Eth-Trunk4] port default vlan 100
[Stack-Eth-Trunk4] quit
[Stack] interface eth-trunk 5
[Stack-Eth-Trunk5] port link-type access
[Stack-Eth-Trunk5] port default vlan 200
[Stack-Eth-Trunk5] quit

                               Step 4     Configure an IP address for the NLB cluster's gateway.

[Stack] interface vlanif 200
[Stack-Vlanif200] ip address 10.128.246.250 24
[Stack-Vlanif200] quit

                               Step 5     Configure a static ARP entry. In the static ARP entry, the IP address is the cluster IP address 10.128.246.252, the MAC address is the cluster multicast MAC address 03bf-0a80-f6fc, and the outbound interface is Eth-Trunk 5 in VLAN 200.

[Stack] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface eth-trunk 5   //Configure a static ARP entry

                               Step 6     Connect GE0/0/4 and GE0/0/5 on Switch_1, and GE1/0/4 and GE1/0/5 on Switch_2.

After the previous configurations, connect physical links.

                               Step 7     Verify the configuration.

Verify that Server_1 and Server_2 can receive packets destined for the NLB cluster IP address.

----End

Configuration Files

Stack configuration file

#
sysname Stack
#
vlan batch 100 200
#                                                                               
interface Vlanif200                                                             
 ip address 10.128.246.250 255.255.255.0                                        
#
interface Eth-Trunk4                                                            
 port link-type access                                                          
 port default vlan 100                                                          
 stp disable                                                                    
#                                                                                
interface Eth-Trunk5                                                             
 port link-type access                                                          
 port default vlan 200                                                          
 stp disable                                                                     
#                                                                                
interface GigabitEthernet0/0/1                                                 
 port link-type access                                                           
 port default vlan 100                                               

interface GigabitEthernet0/0/4
 eth-trunk 4

interface GigabitEthernet0/0/5
 eth-trunk 5

interface GigabitEthernet1/0/1                                                  
 port link-type access                                                          
 port default vlan 100                                                
#                                                                                
interface GigabitEthernet1/0/4                                                 
 eth-trunk 4                                                                    
#                                                                                
interface GigabitEthernet1/0/5                                                 
 eth-trunk 5                                                                    
#
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface Eth-Trunk5 
#
return

本帖最后由 交换机在江湖 于 2017-05-31 02:06 编辑
  • x
  • convention:

user_2790689
Created Mar 23, 2017 07:58:08 Helpful(0) Helpful(0)

good
  • x
  • convention:

Aminakhan2
Created Jun 30, 2017 12:18:02 Helpful(0) Helpful(0)

Example for Connecting a Stack to an NLB Cluster (Using Physical Link Loopback) and the compelte coding and other procedure of this example have this article. I try to understand it but unfortunately i could not get success in it. However, I try to read some reviews of http://www.rushessaya.com/custom_essay.html but i thought this is official Huawei website to get solution related to its products.
  • x
  • convention:

wissal
MVE Created May 2, 2018 05:38:18 Helpful(0) Helpful(0)


useful document, thanks
  • x
  • convention:

Telecommunications%20engineer%2C%20currently%20senior%20project%20manager%20at%20an%20operator%2C%20partner%20of%20Huawei%2C%20in%20the%20radio%20access%20network%20department%2C%20for%2020%20years%20I%20managed%20several%20types%20of%20projects%2C%20for%20the%20different%20nodes%20of%20the%20network.

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login