Example for Connecting a Single Device to an NLB Cluster (Using Physical Link Loopback)

Latest reply: Mar 23, 2017 07:57:43 2217 1 0 0

 

Overview

NLB is developed by Microsoft for a cluster set up by multiple Windows servers. When a switch is connected to an NLB cluster, the switch needs to send packets destined for the cluster IP address to every NLB server in the cluster. An NLB server can work in unicast, multicast, or IGMP multicast mode.

Currently, a switch can be connected to the NLB server working in only unicast or multicast mode. If the switch supports multi-interface ARP, this function is recommended to implement the connection between the switch and NLB cluster. When the switch or version does not support multi-interface ARP and there are insufficient device resources, you can use physical link loopback to connect the switch to the NLB cluster.

Configuration Notes

l   When the NLB cluster works in unicast mode, static ARP entries do not need to be configured on the switch; when the cluster works in multicast mode, static ARP entries need to be configured on the switch.

l   This example applies to all versions of all S series switches.

Networking Requirements

As shown in Figure 1-1, the Switch connects to three NLB servers through GE0/0/1, GE0/0/2, and GE0/0/3. The NLB cluster works in unicast mode, the cluster IP address is 10.128.246.252/24, and the cluster MAC address is 02bf-0a80-f6fc. There are reachable routes between the Switch and Client.

The customer requires that the Switch be able to send the Client's packets destined for the NLB cluster IP address to all NLB servers.

Figure 1-1 Connecting a single device to an NLB cluster in unicast mode

20170323143845125004.png

 

Configuration Roadmap

The configuration roadmap is as follows:

1.         Add GE0/0/1 through GE0/0/3 that are directly connected to NLB servers to VLAN 100.

2.         Disable STP, RSTP, VBST, or MSTP on GE0/0/4 and GE0/0/5, and add the interfaces to VLAN 100 and VLAN 200 respectively in access mode.

3.         Configure an IP address for VLANIF 200 that functions as the NLB cluster's gateway.

4.         Connect GE0/0/4 and GE0/0/5.

Procedure

                               Step 1     Add GE0/0/1 through GE0/0/3 that are directly connected to NLB servers to VLAN 100.

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 100 200
[Switch] interface gigabitethernet 0/0/1
[Switch-GigabitEthernet0/0/1] port link-type access
[Switch-GigabitEthernet0/0/1] quit
[Switch] interface gigabitethernet 0/0/2
[Switch-GigabitEthernet0/0/2] port link-type access
[Switch-GigabitEthernet0/0/2] quit
[Switch] interface gigabitethernet 0/0/3
[Switch-GigabitEthernet0/0/3] port link-type access
[Switch-GigabitEthernet0/0/3] quit
[Switch] vlan 100
[Switch-vlan100] port gigabitethernet 0/0/1 to 0/0/3
[Switch-vlan100] quit

                               Step 2     Configure GE0/0/4 and GE0/0/5.

# Disable STP, RSTP, VBST, or MSTP on GE0/0/4 and GE0/0/5.

[Switch] interface gigabitethernet 0/0/4
[Switch-GigabitEthernet0/0/4] undo stp enable  
[Switch-GigabitEthernet0/0/4] quit
[Switch] interface gigabitethernet 0/0/5
[Switch-GigabitEthernet0/0/5] undo stp enable  
[Switch-GigabitEthernet0/0/5] quit

# Add GE0/0/4 and GE0/0/5 to VLAN 100 and VLAN 200 respectively in access mode.

[Switch] interface gigabitethernet 0/0/4
[Switch-GigabitEthernet0/0/4] port link-type access
[Switch-GigabitEthernet0/0/4] port default vlan 100
[Switch-GigabitEthernet0/0/4] quit
[Switch] interface gigabitethernet 0/0/5
[Switch-GigabitEthernet0/0/5] port link-type access
[Switch-GigabitEthernet0/0/5] port default vlan 200
[Switch-GigabitEthernet0/0/5] quit

                               Step 3     Configure an IP address for the NLB cluster's gateway.

[Switch] interface vlanif 200
[Switch-Vlanif200] ip address 10.128.246.250 24
[Switch-Vlanif200] quit

                               Step 4     Connect GE0/0/4 and GE0/0/5.

After the previous configurations, connect physical links.

                               Step 5     Verify the configuration.

Verify that Server_1 through Server_3 can receive packets destined for the NLB cluster.

----End

Configuration Files

Configuration file of the Switch

#
sysname Switch
#
vlan batch 100 200
#                                                                               
interface Vlanif200                                                              
 ip address 10.128.246.250 255.255.255.0                                        
#                                                                               
interface GigabitEthernet0/0/1              
 port link-type access                                                           
 port default vlan 100                                                

interface GigabitEthernet0/0/2              
 port link-type access                                                          
 port default vlan 100                                                  
#                                                                               
interface GigabitEthernet0/0/3              
 port link-type access                                                           
 port default vlan 100                                                  
#                                                                               
interface GigabitEthernet0/0/4              
 port link-type access                                                           
 port default vlan 100                                                          
 stp disable                                                                    

interface GigabitEthernet0/0/5               
 port link-type access                                                          
 port default vlan 200                                                          
 stp disable                                                                    

return

  • x
  • convention:

user_2790689
Created Mar 23, 2017 07:57:43 Helpful(0) Helpful(0)

good
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login