Example for Configuring RIP

Latest reply: Jan 15, 2017 00:17:41 1173 1 0 0

Applicability

This example applies to all versions and AR routers.

Networking Requirements

RIP needs to be configured to ensure that two hosts can communicate with each other. Figure 7-5 shows the IP addresses and masks of hosts and routers' interfaces.

Figure 7-5  Networking diagram of configuring RIP
1d776c8aaa1a437099eafe70809b60a5

Procedure

  1. Configure RouterA.

    #
    interface GigabitEthernet1/0/0 
     ip address 192.168.1.1 255.255.255.0 
    #  
    interface GigabitEthernet2/0/0 
     ip address 10.1.1.1 255.255.255.0 
    #
    rip 1
     version 2 //Set the RIP version.
     network 192.168.1.0 //Enable RIP on the specified network segment.
     network 10.0.0.0  
    #  
    return 

  2. Configure RouterB.

    #
    interface GigabitEthernet1/0/0 
     ip address 172.16.1.1 255.255.255.0 
    #  
    interface GigabitEthernet2/0/0 
     ip address 10.1.1.2 255.255.255.0 
    #
    rip 1
     version 2
     network 172.16.0.0
     network 10.0.0.0
    #  
    return 

  3. Configure hosts.

    Set the default gateway of hosts in VLAN 10 to 192.168.1.1 and the default gateway of hosts in VLAN 20 to 172.16.1.1.

  4. Configure switches.

    Configure switches to allow hosts to communicate with their respective gateways.

  5. Verify the configuration.

    • Run the display rip process-id route command to view the RIP routing table. The RIP routing table shows that the routes advertised by RIPv2 contain accurate subnet masks.
    • Run the ping command to verify the router connectivity.

Configuration Notes

  • Configure IPv4 addresses for routers' interfaces correctly.

  • Configure IP addresses on the same network segment for interfaces connecting two routers together.

  • Configure default gateways for hosts.

  • Enable RIP on a natural network segment.


  • x
  • convention:

Created Jan 15, 2017 00:17:41 Helpful(0) Helpful(0)

thank you
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top