Example for Configuring BFD for IPv4 Static Routes

Latest reply: Jan 14, 2017 16:17:08 1682 2 0 0

Specifications

This example applies to all AR models of all versions.

Networking Requirements

On a company's internal network shown in Figure 7-4, there are two forwarding paths from Router_1 and Router_2 and with next hops Router_2 and Router_3 respectively. Router_1 and Router_2 are far from each other, and the L2 Switch acts as the relay agent between Router_1 and Router_2. In this example, Router_2 does not support bidirectional forwarding detection (BFD). BFD for IPv4 static routes needs to be configured on Router_1 to ensure that Router_1 can fast detect the failure (for example the Down state) of the link between Router_2 and the L2 Switch and switch traffic to the link of Router_3.

Figure 7-4  Networking diagram of configuring BFD for IPv4 static routes
ba904bd5f60a4f56b80e26df4962ef97
Device Interface IP Address
Router_1 GE2/0/1 10.10.10.101/24
GE2/0/2 10.10.20.101/24
GE2/0/3 10.10.40.101/24
Router_2 GE2/0/1 10.10.10.102/24
GE2/0/2 10.10.30.101/24
GE2/0/3 10.10.50.101/24
Router_3 GE2/0/1 10.10.20.102/24
GE2/0/2 10.10.30.102/24

Procedure

  1. Configure Router_1.

    #
     sysname Router_1
    #
    bfd
    #
    interface GigabitEthernet2/0/1     //Configure an IP address for GigabitEthernet2/0/1 on Router_1.
     ip address 10.10.10.101 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     ip address 10.10.20.101 255.255.255.0
    #
    interface GigabitEthernet2/0/3
     ip address 10.10.40.101 255.255.255.0
    #
    bfd aa bind peer-ip 10.10.10.102 interface GigabitEthernet0/0/1 one-arm-echo    //Configure the BFD session between Router_1 and Router_2.
     discriminator local 1
     min-echo-rx-interval 100
     commit  
    #
     ip route-static 10.10.50.0 24 GigabitEthernet2/0/1 10.10.10.102 track bfd-session aa    //Configure a static route from Router_1 to 10.10.50.0/24. Ensure that traffic from Router_1 to Router_2 is first forwarded along the link Router_1 –> L2 Switch –> Router_2. When the link fails, the traffic is switched to the link Router_1 –> Router_3 –> Router_2.
     ip route-static 10.10.50.0 24 GigabitEthernet2/0/2 10.10.20.102 preference 65
    #
    return

  2. Configure Router_2.

    #
     sysname Router_2
    #
    interface GigabitEthernet2/0/1    //Configure an IP address for GigabitEthernet2/0/1 on Router_2.
     ip address 10.10.10.102 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     ip address 10.10.30.101 255.255.255.0
    #
    interface GigabitEthernet2/0/3
     ip address 10.10.50.101 255.255.255.0
    #
    ip route-static 10.10.40.0 24 GigabitEthernet2/0/1 10.10.10.101   //Configure a static route from Router_2 to 10.10.40.0/24. Ensure that traffic from Router_2 to Router_1 is first forwarded along the link Router_2 –> L2 Switch –> Router_1. When the link fails, the traffic is switched to the link Router_2 –> Router_3 –> Router_1.
    ip route-static 10.10.40.0 24 GigabitEthernet2/0/2 10.10.30.102 preference 65
    #
    return

  3. Configure Router_3.

    #
     sysname Router_3
    #
    interface GigabitEthernet2/0/1    //Configure an IP address for GigabitEthernet2/0/1 on Router_3.
     ip address 10.10.20.102 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     ip address 10.10.30.102 255.255.255.0
    #
    ip route-static 10.10.40.0 24 GigabitEthernet2/0/1 10.10.20.101    //Configure static routes from Router_3 to 10.10.40.0/24 and 10.10.50.0/24.
    ip route-static 10.10.50.0 24 GigabitEthernet2/0/2 10.10.30.101
    #
    return

  4. Verify the configuration.

  5. When Router_1, Router_2, and the links between Router_1 and Router_2 are working normally:
    • Run the display ip routing-table protocol static command on Router_1 to check static route information. The command output shows that there are reachable routes between Router_1 and Router_2.
    • Run the display bfd session all command on Router_1. The command output shows that a BFD session has been set up.
  6. When the link between Router_2 and the L2 Switch fails, run the display ip routing-table protocol static command on Router_1 to check static route information. The command output shows that there are reachable routes between Router_1 and Router_2.

  • x
  • convention:

user_2790689
Created Jan 14, 2017 16:15:34 Helpful(0) Helpful(0)

thank you
  • x
  • convention:

user_2790689
Created Jan 14, 2017 16:17:08 Helpful(0) Helpful(0)

thank you
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login