EtherChannel or Ether trunk

254 0 0 0

EtherChannel or Ether trunk


Port aggregation

A network will often span across multiple switches. Trunk ports are usually used to connect switches together.

There are two issues with using only a single physical port for the trunk connection:

1. the port represents a single point of failure. If the port goes down, the trunk connection is lost;

2. the port represents a traffic bottleneck. All other ports on the switch will use that one port to communicate across the trunk connection.


Thus, the obvious benefits of adding redundancy to the trunk connection are fault tolerance and increased bandwidth via load balancing.


However, simply trunking two or more ports between the switches will not work, as this creates a switching loop. One of two things will occur:

1. the Spanning Tree Protocol (STP) will disable one or more ports to eliminate the loop.


2. if STP is disabled, the switching loop will result in an almost instantaneous broadcast storm, crippling the network. Port aggregation allows multiple physical ports to be bundled together to form a single logical port. The switch and STP will treat the bundled ports as a single interface, eliminating the possibility of a switching loop.

Huawei's implementation of port aggregation is called Eth-Trunk. Eth-Trunk supports the Fast, Gigabit, and 10 Gigabit Ethernet ports. A maximum of 8 active ports are supported on a single EtherChannel. If the ports are operating in full duplex, the maximum theoretical bandwidth supported is as follows:

1. Fast Ethernet – 1600 Mbps


2. Gigabit Ethernet – 16 Gbps


3. 10 Gigabit Ethernet – 160 Gbps.


The maximum number of supported Eth-trunks on a single switch is platform-dependent, though most support from a maximum of 64 to a maximum of 128 Eth-Trunks.



EtherChannel requirements


The previous section described the benefits of port aggregation for a trunk connection. However, the Eth-Trunk can be formed with either access or trunk ports. The Eth-trunk is also supported on Layer-3 interfaces.


Implementing an Eth-Trunk for access ports provides increased bandwidth and redundancy to a host device, such as a server. However, the host device must support a
port aggregation protocol, such as LACP. Port aggregation protocols are covered in great detail later in this articles series.


Similarly, implementing EtherChannel for trunk connections provides increased bandwidth and redundancy to other switches.


093743u0ok3w3g6evvazfr.jpg?Screenshot.JP


If a port in an EtherChannel bundle fails, the traffic will be redistributed across the remaining ports in the bundle. This happens nearly instantaneously.


For an EtherChannel to become active, all ports in the bundle
must be configured identically, regardless if the EtherChannel is being used with
access or trunk ports. Port settings that must be identical include the following:


1. Speed settings


2. Duplex settings


3. STP settings


4. VLAN membership (for access ports)


6. Native VLAN (for trunk ports)


7. Allowed VLANs (for trunk ports)


8. Trunking encapsulation protocol (for trunk ports) if you usesd a Cisco Switch be careful to change encapsulation to dot1Q.


On trunk connections, the above settings must be configured identically across all participating ports on
both switches.


Historically, port-security has not been supported on an Eth-Trunk. Newer platforms may provide support as long as port-security is enabled on
both the physical interfaces and the ether-trunk itself.


Eth-Trunk Load-Balancing


Traffic sent across an eth-trunk is not evenly distributed across all ports in the bundle. Instead, the Eth-Trunk utilizes a load-balancing algorithm to determine the port to send the traffic out, based on one of several criteria:


1. Source IP address - src-ip


2. Destination IP address - dst-ip


3. Source and destination IP address - src-dst-ip


4. Source MAC address - src-mac


5. Destination MAC address - dst-mac


6. Source and Destination MAC address - src-dst-mac


Source TCP/UDP port number - src-port
Destination TCP/UDP port number - dst-port
Source and destination port number - src-dst-port
Using a deterministic algorithm prevents perfect load-balancing. However, a
particular traffic flow is forced to always use the same port in the bundle,
preventing out-of-order delivery.
The default load-balancing method for a Layer-2 Eth-trunk is either
srcmac or src-dst-mac, depending on the platform. The default method for a
Layer-3 Eth-trunk is
src-dst-ip.


To lad balance method you must configure it under interface trunk command as below:


[Huawei]inter Eth-Trunk 1 [0-63]

[Huawei-Eth-Trunk1]load-balance ?

  dst-ip       According to destination IP hash arithmetic

  dst-mac      According to destination MAC hash arithmetic

  src-dst-ip   According to source/destination IP hash arithmetic

  src-dst-mac  According to source/destination MAC hash arithmetic

  src-ip       According to source IP hash arithmetic

  src-mac      According to source MAC hash arithmetic

====


The configuration example of Eth-Trunk.


Networking requirements

As shown in the topology, SwitchA and SwitchB connect to devices in VLAN 10 and VLAN 20 through Ethernet links and heavy traffic is transmitted between SwitchA and SwitchB.


SwitchA and SwitchB can provide higher link bandwidth to implement inter-VLAN communication. Reliability of data transmission needs to be ensured.


102135asovu5lfssoupv71.jpg?Screenshot1.J


Configuration roadmap

The configuration roadmap is as follows:


1. Create an Eth-Trunk and add member interfaces to the Eth-Trunk to increase link bandwidth.


2. Create VLANs and add interfaces to the VLANs.


3. Set the load balancing mode to ensure that traffic is load balanced between member interfaces of the Eth-Trunk.


Procedure

1. Create an Eth-Trunk on SwitchA and SwitchB, and add member interfaces to the Eth-Trunk.

<HUAWEI> system-view[HUAWEI] sysname SwitchA[SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3[SwitchA-Eth-Trunk1] quit
<HUAWEI> system-view[HUAWEI] sysname SwitchB[SwitchB] interface eth-trunk 1[SwitchB-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3[SwitchB-Eth-Trunk1] quit


2. Create VLANs and add interfaces to the VLANs.


# Create VLAN 10 and VLAN 20 and add interfaces to VLAN 10 and VLAN 20. The configuration of SwitchB is similar to the configuration of SwitchA and the configuration details are not mentioned here.


[SwitchA] vlan batch 10 20[SwitchA] interface gigabitethernet 0/0/4[SwitchA-GigabitEthernet0/0/4] port link-type trunk[SwitchA-GigabitEthernet0/0/4] port trunk allow-pass vlan 10[SwitchA-GigabitEthernet0/0/4] quit[SwitchA] interface gigabitethernet 0/0/5[SwitchA-GigabitEthernet0/0/5] port link-type trunk[SwitchA-GigabitEthernet0/0/5] port trunk allow-pass vlan 20[SwitchA-GigabitEthernet0/0/5] quit


# Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration of SwitchB is similar to the configuration of SwitchA, and the configuration details are not mentioned here.


[SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] port link-type trunk[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20[SwitchA-Eth-Trunk1] quit

3. Set the load balancing mode of Eth-Trunk 1. The configuration of SwitchB is similar to the configuration of SwitchA, and the configuration details are not mentioned here.

[SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] load-balance src-dst-mac[SwitchA-Eth-Trunk1] quit

4. Verify the configuration.


Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created and whether member interfaces are added.


[SwitchA] display eth-trunk 1Eth-Trunk1's state information is: 
WorkingMode: NORMAL Hash arithmetic: According to SA-XOR-DA
Least Active-linknumber: 1 Max Bandwidth-affected-linknumber: 8
Operate status: up Number Of Up Port In Trunk: 3 
--------------------------------------------------------------------------------
PortName Status WeightGigabitEthernet0/0/1 Up 1GigabitEthernet0/0/2 Up 1GigabitEthernet0/0/3 Up 1


The preceding command output shows that Eth-Trunk 1 has three member interfaces: GigabitEthernet0/0/1, GigabitEthernet0/0/2, and GigabitEthernet0/0/3. The member interfaces are both in Up state. The Operate status of Eth-Trunk 1 is up.


Configuration files

1. Configuration file of SwitchA


#
sysname SwitchA
#
vlan batch 10 20
#
interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 10 20
 load-balance src-dst-mac 
# 
interface GigabitEthernet0/0/1 
 eth-trunk 1
# 
interface GigabitEthernet0/0/2 
 eth-trunk 1
# 
interface GigabitEthernet0/0/3 
 eth-trunk 1
#
interface GigabitEthernet0/0/4 
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/5 
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return

2. Configuration file of SwitchB


#
sysname SwitchB
#
vlan batch 10 20
#
interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 10 20
 load-balance src-dst-mac 
# 
interface GigabitEthernet0/0/1 
 eth-trunk 1
# 
interface GigabitEthernet0/0/2 
 eth-trunk 1
# 
interface GigabitEthernet0/0/3 
 eth-trunk 1
#
interface GigabitEthernet0/0/4 
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/5 
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return


  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login