Eth-trunk design consideration

Latest reply: Jul 21, 2015 18:54:23 1943 4 0 0

Hello,

I have a question regarding design consideration with Eth-Trunk.

I have an existing L2 STP network with two separated core switches (please take a look at attached PDF topology). I cannot change the design at the moment but I would like to redundantly connect a Huawei router by using two physical connections onto two different core switches. I would like to achieve redundancy at L2 but I do not want to use STP.

I am considering to implement Eth-Trunk with mode manual load-balancing. Although that may work, I am expecting to see MAC flapping messages since MAC address from router VlanIf would occasionally move between trunk members in load-balancing mode.

Can anyone suggest alternative way of solving that issue or state any other relevant consideration that on suggested design?

Regards

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

Created Mar 25, 2015 00:20:39 Helpful(0) Helpful(0)

Hi,

I don't think your design will work as standard LACP will not work when the endpoints are connected to different devices. There is an enhanced version for exactly this type of scenraio using "e-trunks" however as far as I can see it is not supported on the router OS. This could be configured using a L3 switch instead of a router if that is a possible solution.

L2 redundancy features are not generally implemented on routers, so the questions that arise are, does it have to be a router and why exactly does it need to be L2 redundancy?

Regards Nigel

 

  • x
  • convention:

Created Mar 25, 2015 00:36:20 Helpful(0) Helpful(0)

Thanks for the answer Nigel.

We are talking about NE series router.

You probably didn't see my attachment with actual configuration snippet: (https://www.dropbox.com/s/fz05npr2dnae82w/Huawei-Failover-EthTrunk.pdf?dl=0). I am using Huawei Eth-trunk implementation, not LACP (http://enterprise.huawei.com/ilink/enenterprise/download/HW_U_150282 - please see section 2.3 of Huawei Ethernet Configuration guide)

Here is the router configuration:
interface Vlanif10
ip address 192.168.10.1 255.255.255.0
#
interface Vlanif20
ip address 192.168.20.1 255.255.255.0
#
interface Eth-Trunk0
port link-type trunk
port trunk allow-pass vlan 2 to 4094
stp disable
#
interface GigabitEthernet5/0/0
eth-trunk 0
#
interface GigabitEthernet5/0/1
eth-trunk 0
#


I have done some tests with eNSP and it seem to work. I just don’t feel confident with it and I’m asking for the second opinion. And again, there is an issue with MAC flapping. Any suggestions?

I would really like to avoid using STP on the router.

  • x
  • convention:

Created Mar 25, 2015 01:31:09 Helpful(0) Helpful(0)

Hi,

eNSP only supports AR routers and although the NE routers still have VRP they generally have better features, certainly for what you are trying to do. I was assuming you were talking about AR routers.

The Eth-trunk feature, even in manual mode is only designed to operate between between 2 directly connected devices, even though it may look like it is working, it is not how it was designed to work and is likely to give you errors and problems.

I have just had a look in the documentation for NE40 and it does support the "e-trunk" feature is supported, however I imgaine it will depend on exactly what NE router you are using and what OS version you have.

I suggest you check the documentation for the product and OS version you are using and look at the "e-trunk" option within eth-trunk configuration, as beleive this will give you the functionality you require.

If that is not supported then it may be worth looking at something like RRPP between the router and the switches.

Regards Nigel

  • x
  • convention:

Created Jul 21, 2015 18:54:23 Helpful(0) Helpful(0)


Yes, usually I use the Ahsay Online Backup software. It is an advanced disk-to-disk-to-disk (D2D2D) backup solution for Businesses and MSPs / VARs. It comes with the most comprehensive features that can fulfill all the on-premises backup, online backup, offsite backup, and cloud backup needs of nowadays businesses. At the same time, it is the most affordable backup solution available in the market. For more information check this:

  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top