Got it

eNSP Bug Report - QinQ

Latest reply: Jun 19, 2016 04:53:11 7433 4 0 0 0

Hello everyone,

This post refers to the eNSP Bug Report - QinQ. Please find more information below.

QinQ seems to be broken in the switch module at least.

In my scenario, packets only flow correctly in 1 direction. Packets flow between R1 towards R2. But packets from R2 do not reach R1. VLAN 10 is the PE (outer) VLAN. VLAN 100 is the CE (inner) VLAN.

AR1220_R1 (QinQ termination subinterface) <-----QinQ packets---> Switch <----dot1Q packets ----> AR1220_R2 (vlanif interface) 

Configuration R1:

interface GigabitEthernet0/0/1.1

control-vid 1000 qinq-termination

qinq termination pe-vid 10 ce-vid 100

ip address 192.168.10.1 255.255.255.0

arp broadcast enable

#

Configuration switch:

interface GigabitEthernet0/0/1

description TOWARDS_R1

port link-type trunk

port trunk allow-pass vlan 10

#

interface GigabitEthernet0/0/2

description TOWARDS_R2

port link-type dot1q-tunnel

port default vlan 10

#

Configuration R2:

interface Vlanif100

ip address 192.168.10.2 255.255.255.0

#

interface Ethernet0/0/0

portswitch

port link-type trunk

port trunk allow-pass vlan 100

On R2 we can see evidence of R1.

[R2]dis arp

IP ADDRESS MAC ADDRESS EXPIRE(M) TYPE INTERFACE VPN-INSTANCE VLAN/CEVLAN PVC

------------------------------------------------------------------------------

192.168.10.2 5489-989e-257d I - Vlanif100

192.168.10.1 5489-98a3-8442 20 DF0 Eth0/0/1 100/-

------------------------------------------------------------------------------

Total:2 Dynamic:1 Static:0 Interface:1

[R2] 

On R1, we are not getting the arp reply (or any packets) from R2.

[R1]ping 192.168.10.2

PING 192.168.10.2: 56 data bytes, press CTRL_C to break

Request time out

Request time out

Request time out

Request time out

Request time out

--- 192.168.10.2 ping statistics ---

5 packet(s) transmitted

0 packet(s) received

100.00% packet loss

[R1]dis arp

IP ADDRESS MAC ADDRESS EXPIRE(M) TYPE INTERFACE VPN-INSTANCE 

VLAN/CEVLAN PVC

------------------------------------------------------------------------------

192.168.10.1 5489-98a3-8442 I - GE0/0/1.1

------------------------------------------------------------------------------

Total:1 Dynamic:0 Static:0 Interface:1

[R1]

  • x
  • convention:

l00219614
Created Nov 5, 2012 02:48:10

hi~ QinQ is not support, thanks~
View more
  • x
  • convention:

c00737409
Created Nov 5, 2012 09:29:57

OK Thank You - do you have a list of supported and unsupported features?
View more
  • x
  • convention:

l00219614
Created Nov 7, 2012 04:38:39

Reply 3 #

hi~~ Open the help document in the software of eNSP, and you will find the list ~

 

View more
  • x
  • convention:

user_2296671
Created Jun 19, 2016 04:53:11

楼主后续报道
View more
  • x
  • convention:

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.
Information Protection Guide
Thanks for using Huawei Enterprise Support Community! We will help you learn how we collect, use, store and share your personal information and the rights you have in accordance with Privacy Policy and User Agreement.