How to configure Ethernet link aggregation on WLAN devices

7

Eth-Trunk is a link aggregation technology that bundles multiple physical Ethernet links into one logical link to increase link bandwidth. The Ethernet physical links implement redundancy and improve link reliability. Link aggregation is also called Ethernet link aggregation, port aggregation, link bundling, port bundling, Eth-Trunk, Eth-Trunk link aggregation, and interface aggregation.
Currently, all Huawei ACs and only APs with dual network ports (such as the AP5030DN) support Ethernet link aggregation.
Currently, Ethernet link aggregation can be configured only on the CLI of WLAN devices.
Link aggregation can work in manual load balancing mode or LACP mode.
Link aggregation implement load balancing. WLAN devices support flow-based load balancing.
You can configure link aggregation in manual load balancing mode or LACP mode.
The following example describes how to configure link aggregation on an AC and an S series switch in manual load balancing mode. The right figure shows the networking diagram.
1. Create an Eth-Trunk on the AC and switch respectively, and add member interfaces to each Eth-Trunk.
[AC6605] sysname AC
[AC] interface eth-trunk 1 //Create Eth-Trunk 1 on the AC.
[AC-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3 //Add GE0/0/1, GE0/0/2, and GE0/0/3 to Eth-Trunk 1.
[AC-Eth-Trunk1] quit
[HUAWEI] sysname Switch
[Switch] interface eth-trunk 1 //Create Eth-Trunk 1 on the switch.
[Switch-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3 //Add GE0/0/1, GE0/0/2, and GE0/0/3 to Eth-Trunk 1.
[Switch-Eth-Trunk1] quit
2. Create VLANs and add interfaces to the VLANs.
# Create VLAN 10 and VLAN 20, and add interfaces to the VLANs. The configuration on the switch is similar to that on the AC, and is not described here.
[AC] vlan batch 10 20
[AC] interface gigabitethernet 0/0/4
[AC-GigabitEthernet0/0/4] port link-type trunk //Set the link type of the interface to trunk, which is not the default type.
[AC-GigabitEthernet0/0/4] port trunk allow-pass vlan 10
[AC-GigabitEthernet0/0/4] quit
[AC] interface gigabitethernet 0/0/5
[AC-GigabitEthernet0/0/5] port link-type trunk //Set the link type of the interface to trunk, which is not the default type.
[AC-GigabitEthernet0/0/5] port trunk allow-pass vlan 20
[AC-GigabitEthernet0/0/5] quit
# Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration on the switch is similar to that on the AC, and is not described here.
[AC] interface eth-trunk 1
[AC-Eth-Trunk1] port link-type trunk //Set the link type of the interface to trunk, which is not the default type.
[AC-Eth-Trunk1] port trunk allow-pass vlan 10 20
[AC-Eth-Trunk1] quit
3. Set the load balancing mode of Eth-Trunk 1. The configuration on the switch is similar to that on the AC, and is not described here.
[AC] interface eth-trunk 1
[AC-Eth-Trunk1] load-balance src-dst-mac //Configure load balancing of Eth-Trunk 1 based on source and destination MAC addresses.
[AC-Eth-Trunk1] quit

Other related questions:
Do WLAN devices support Ethernet link aggregation
Currently, all Huawei ACs and only APs with dual network ports (such as the AP5030DN) support Ethernet link aggregation.

What link aggregation modes are supported by the device
The following link aggregation modes are supported: -Manual load balancing mode: This mode allows you to manually add interfaces to an Eth-Trunk. All the member interfaces are in forwarding state and perform load balancing. -LACP mode: This mode allows the AR to select active links by negotiating parameters using LACP. In LACP mode, you need to manually set up an Eth-Trunk and add interfaces to the Eth-Trunk.

Commands to configure link aggregation on S series switches
S series switches (except the S1700) implement link aggregation by using commands. Different commands have different functions. For example: interface eth-trunk: //Create an Eth-Trunk interface and enter the interface view. mode: //Configure the working mode of the Eth-Trunk. trunkport: //Add member interfaces to the Eth-Trunk. For more commands about link aggregation, see "Ethernet Switching Configuration Commands-Link Aggregation Commands" in S1720&S2700&S5700&S6720 V200R010C00 Command Reference. Link aggregation commands are applicable to all S series switch models. The Sx700 series switch is used here as an example.

If you have more questions, you can seek help from following ways:
To iKnow To Live Chat
Scroll to top