How do I configure batch port mapping

29

When a private IP address and a range of consecutive port numbers need to be mapped to a public IP address and a range of consecutive port numbers, you can reference an ACL to complete batch port mapping configuration.

On the private network shown in the right figure, multiple consecutive ports of a server need to be open to users on the public network. The private IP address of the server is 192.168.2.2/24, its server port is in the range of 2000-4000 or 5000, and its public IP address is 202.1.22.3/24. The interconnected IP address on the carrier network is 202.1.22.10. The private IP address and ports 2000-4000 and 5000 of the internal server need to be mapped to public IP address 202.1.22.3 and corresponding ports.


Procedure



  1. Set the IP address for the interface.

    <Huawei> system view
    [Huawei] sysname Router
    [Router] vlan 100
    [Router-vlan100] quit
    [Router] interface vlanif 100
    [Router-Vlanif100] ip address 192.168.2.1 24
    [Router-Vlanif100] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type access
    [Router-Ethernet2/0/0] port default vlan 100
    [Router-Ethernet2/0/0] quit
    [Router] interface GigabitEthernet 1/0/0
    [Router-GigabitEthernet1/0/0] ip address 202.1.22.4 24
    [Router-GigabitEthernet1/0/0] quit

  2. Create an ACL that matches the port numbers to be mapped.

    [Router] acl number 3001
    [Router-acl-adv-3001] rule 5 permit tcp destination-port range 2000 4000
    [Router-acl-adv-3001] rule 5 permit tcp destination-port eq 5000
    [Router-acl-adv-3001] quit

  3. Configure NAT server and reference the ACL.

    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] nat server global 202.1.22.3 inside 192.168.2.2 acl 3001
    [Router-GigabitEthernet1/0/0] quit

  4. Configure a default route on the router, with 202.1.22.10 as the next-hop address.

    [Router] ip route-static 0.0.0.0 0.0.0.0 202.1.22.10

More information


.
Referencing an ACL to batch configure port mapping completes the mapping of consecutive port numbers and reduces the configuration workload. You do not need to run the nat server command on interfaces one by one. Additionally, to change the range of port numbers, you only need to change the ACL rules for future maintenance. One public IP address can be used for batch port mapping configuration only once. If other internal servers need to provide services for public network users, use other public IP addresses for port mapping configuration.

Other related questions:
Does an AR support the mapping of consecutive port numbers
An AR supports the mapping of consecutive port numbers with restrictions: A public IP address can only be configured in the nat server command once. If it is configured in another nat server command, the system displays a message indicating that the previous configuration will be overwritten.

1. Create an ACL to match the ports to be mapped. [Huawei] acl number 3001 [Huawei] rule 5 permit tcp destination-port range 1 4000

2. Configure a NAT server without specifying the internal and external port numbers, and reference ACL 3001. [Huawei] interface GigabitEthernet0/0/1 [Huawei-GigabitEthernet0/0/1] nat server global 202.1.22.3 inside 192.168.2.22 acl 3001

This method completes the mapping of consecutive port numbers (intranet ports matching an ACL rule are mapped to the same ports on the public network) without the need to configure port mapping one by one using the nat server command.

202.1.22.3 inside 192.168.2.22 acl 3001


How to implement port mapping on an AR router
Run the port-mapping command on an AR router to configure port mapping based on basic ACLs (number 2000 to 2999). Port mapping is implemented after packets match an ACL rule. To filter packets based on the ACLs, port mapping tries to match the destination IP addresses in the packets with the IP addresses defined in the basic ACL rules.
Example:
# Set the mapping port of the HTTP service to 10. If packets comply with the rules defined in the ACL 2000, the mapping relationship takes effect.
system-view
[Huawei] acl 2000
[Huawei-acl-basic-2000] rule permit
[Huawei-acl-basic-2000] quit
[Huawei] port-mapping http port 10 acl 2000


How do I configure number mapping
Number mapping implements change of irregular numbers. The priorities of number change methods are the short-to-long number change, number mapping, and number change in descending order. Add number 1000, configure no long number, and map 1000 to 12341000 as the external number. config add numbermap innernum 1000 externnum 12341000 After number mapping is configured, add a corresponding intra-office prefix so that external users can call the intra-office number. config add prefix dn 1234 callcategory basic callattribute inter cldpredeal no cldmap yes minlen 8 maxlen 8

How to configure all-port mapping on the AR

Procedure

# Configure the NAT server on a public network interface to map all TCP ports with public IP address 1.1.1.1 to all ports with private IP address 192.168.0.1.

<Huawei> system-view
[Huawei] interface gigabitethernet 1/0/0
[Huawei-GigabitEthernet1/0/0] nat server protocol tcp global 1.1.1.1 inside 192.168.0.1

More information

If an enterprise has two or more allocatable public IP addresses and an internal server needs to provide services for public network users, all-port mapping can be configured for one public IP address. If you do not specify the range of port numbers open to public network users in the nat server command, all ports of the internal server are mapped to the same public IP address. That is, the server provides all types of services to public network users using all ports with the public IP address. If the IP address of a public network interface is used to provide services to public network users, configuring all-port mapping on this interface will cause failures of public network users to access the web interface or other services on the AR router, because all port numbers associated with the IP address are mapped to the internal server. Therefore, if only one public IP address is available, you are advised to configure mapping of specific port numbers. All-port mapping allows multiple ports to be mapped at one time, but this configuration lowers the network security because all ports are open to the public network.

If you have more questions, you can seek help from following ways:
To iKnow To Live Chat
Scroll to top