Configuring the MAC Authentication Script and Comments

Latest reply: Dec 27, 2018 07:28:59 1065 5 10 1

Figure 1 Networking diagram for configuring MAC address authentication

142820sqbfz3zvib2pgqxl.png

#
sysname Switch
#
vlan batch 10 20
#
authentication-profile name p1 //  In this mode, you can reference multiple ports and modify authentication parameters in batches.


 mac-access-profile m1 
//  Specifies the authentication mode used by the template.


 authentication mode multi-authen max-user 100  //  applies to the scenario that requires high security and in which multiple data terminals are connected to the network on the device interface. In this access mode, you can configure the maximum number of access users based on the actual user quantity on the interface. This prevents malicious users from occupying a large amount of device resources and ensures that the users on other device interfaces can normally go online.


 access-domain huawei.com force // All users connected to the port that references the authentication profile are managed by the domain huawei.com. If this command does not exist, the user is managed in the default global default domain.
#
radius-server template rd1
radius-server shared-key cipher %#%#4*SO-2u,Q.\1C~%[eiB77N/^2wME;6t%6U@qAJ9:%#%#
radius-server authentication 192.168.2.30 1812 weight 80
#
mac-access-profile name m1
#
aaa
authentication-scheme abc
  authentication-mode radius
domain huawei.com  //  A domain is required to manage dumb terminals with MAC address authentication.
  authentication-scheme abc
  radius-server rd1
#
interface GigabitEthernet1/0/1
port link-type access
port default vlan 10
authentication-profile p1  //  Do not forget to apply the created authentication profile to an interface.
#
interface GigabitEthernet1/0/2
port link-type access
port default vlan 20
#
interface Vlanif10
ip address 192.168.1.10 255.255.255.0
#
interface Vlanif20
ip address 192.168.2.10 255.255.255.0
#
return


  • x
  • convention:

yiyi0519
Created Dec 19, 2018 09:02:05 Helpful(0) Helpful(0)

if the authentication point on the access switch, how to configure it?
  • x
  • convention:

Yolanda_617
Created Dec 21, 2018 01:31:46 Helpful(0) Helpful(0)

Very helpful
  • x
  • convention:

YOO
Created Dec 21, 2018 03:13:03 Helpful(0) Helpful(0)

Such an good sharing for us
  • x
  • convention:

user_2915719
Created Dec 21, 2018 09:30:07 Helpful(0) Helpful(0)

I wonder, is this configuration done on Radius server or on the switch?
  • x
  • convention:

dagui
Created Dec 27, 2018 07:28:59 Helpful(0) Helpful(0)

radius-server shared-key cipher %#%#4*SO-2u,Q.\1C~%[eiB77N/^2wME;6t%6U@qAJ9:%#%#Can you provide a more detailed explanation?
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login