Configure a GRE Tunnel interface between CE6850-48S4Q-EI stack and a Cisco 6509

Latest reply: Dec 24, 2018 09:27:32 406 1 0 0

I would like to configure a GRE tunnel interface between his CloudEngine CE6850-48S4Q-EI and CISCO 6509. I have L3 connectivity between the source and destination IP addresses but the tunnel interface is down on the CE.


Configuration on CE6850:

interface Tunnel0

mtu 1476

ip address 192.168.121.1 255.255.255.252

tunnel-protocol gre

source 10.163.50.14

destination 10.34.75.2

 

Configuration on CISCO 6509:

interface Tunnel0

ip address 192.168.121.2 255.255.255.252

tunnel source 10.34.75.2

tunnel destination 10.163.50.14


Check to tunnel and is down:

<SCC-Niciman-C01>dis int t0

Tunnel0 current state : DOWN (ifindex: 156)

Line protocol current state : DOWN

Description: ** Niciman VNOC Staff **

Route Port,The Maximum Transmit Unit is 1500, Current BW: 65.53Kbps

Internet Address is 10.255.255.1/30

Encapsulation is TUNNEL, loopback not set

Tunnel source 10.163.50.14 (Vlanif1073), destination 10.34.75.2

Tunnel protocol/transport GRE/IP, key disabled

keepalive enable period 10 retry-times 3

Checksumming of packets disabled

Current system time: 2017-08-08 09:45+01:00 DST

    300 seconds input rate 0 bits/sec, 0 packets/sec

    300 seconds output rate 0 bits/sec, 0 packets/sec

    0 seconds input rate 0 bits/sec, 0 packets/sec

    0 seconds output rate 0 bits/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    0 packets output,  0 bytes

    0 output error

    Input:

      Unicast: 0 packets, Multicast: 0 packets

    Output:

      Unicast: 0 packets, Multicast: 0 packets

    Input bandwidth utilization  : --

    Output bandwidth utilization : --


I configured the keepalive to 10 seconds and retried but the interface tunnel status was still down.


On CISCO:

interface Tunnel0

keepalive 10 3


On CE:

interface Tunnel1

keepalive period 10

Then removed the MTU 1476 from the Cloud Engine and test again, the tunnel interface ststus was still down.

interface Tunnel0

undo mtu


Root cause: There is a software limitation for V100R003C00 version and a loopback eth-trunk must be configured for the GRE tunnelAfter this version there is no need to configure the service type tunnel on the Eth-trunk interface.


The loopback eth-trunk must be configured for the GRE tunnel. Configure an eth-trunk for GRE tunnel (The eth-trunk must have some member ports but no need to connect the port.)

[~SwitchA] interface eth-trunk 1

[*SwitchA-Eth-Trunk1] service type tunnel

[*SwitchA-Eth-Trunk1] quit

 

Binding the eth-trunk to the tunnel.

[*SwitchC-Tunnel0] binding interface eth-trunk 1

  • x
  • convention:

Created Dec 24, 2018 09:27:32 Helpful(0) Helpful(0)


Very helpful
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top