configuration conversation from cisco to huawei

Created: Dec 1, 2019 12:59:17Latest reply: Dec 2, 2019 01:49:54 174 7 0 0
  Rewarded Hi-coins: 0 (problem resolved)

Please can some one help me convert this configuration from cisco to Huawei?


ip sla auto discovery

ip sla 1

 icmp-echo 172.16.1.1 source-interface Tunnel0

ip sla schedule 1 life forever start-time now

ip sla 2

 icmp-echo 172.16.0.1 source-interface Tunnel1

ip sla schedule 2 life forever start-time now

ip sla 3

 icmp-echo 172.16.1.1 source-interface Tunnel0

ip sla 4  


ip sla schedule 5 life forever start-time now

ip sla 6

 icmp-echo 172.16.X.X

ip sla schedule 6 life forever start-time now




route-map phase3-glo permit 20

 set ip next-hop verify-availability 172.16.0.1 2 track 2

 set ip next-hop verify-availability 172.16.1.1 3 track 3



ip nat inside source route-map glo interface GigabitEthernet0/2 overload

ip nat inside source route-map phase3 interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 172.16.1.1 89 track 1

ip route 0.0.0.0 0.0.0.0 172.16.0.1 89 track 2


  • x
  • convention:

Featured Answers
chenhui
Admin Created Dec 1, 2019 13:33:43 Helpful(0) Helpful(0)

@Doncharles hello,
IP SLA in Cisco is corresponding to the BFD or NQA in Huawei.
you can find the configuration example at https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_nqa_0001&lang=en (for NQA)
and https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_bfd_0001_2&lang=en (for BFD)
  • x
  • convention:

Doncharles
Doncharles Created Dec 1, 2019 13:43:44
Thanks i will check it out  
All Answers
wissal
wissal MVE Created Dec 1, 2019 13:12:07 Helpful(0) Helpful(0)

Hello,
Please refer to the link below, you can resolve your issue
https://support.huawei.com/enterprise/en/bulletins-service/ENEWS1000012556
Thanks
  • x
  • convention:

Doncharles
Doncharles Created Dec 1, 2019 13:27:23
I used eDesk to translate the script, the above cmd i posted was not converted. can you help  
wissal
wissal Reply Doncharles  Created Dec 1, 2019 13:36:34
Please use the Version mapping table link: http://support.huawei.com/enterprise/en/doc/DOC1000179655  
I%20would%20like%20to%20share%20with%20you%20my%20experience%2C%20I'm%20telecommunications%20engineer%2C%20currently%20senior%20project%20manager%20at%20an%20operator%2C%20partner%20of%20Huawei%2C%20in%20the%20radio%20access%20network%20department%2C%20for%2020%20years%20I%20managed%20several%20types%20of%20projects%2C%20for%20the%20different%20nodes%20of%20the%20network.%3Cbr%2F%3EAt%20the%20same%20time%2C%20I%20give%20courses%20in%20universities%20as%20a%20temporary%2C%20to%20bring%20the%20operational%20side%20of%20telecommunication%20technologies%20to%20students%2C%20for%20network%20supervision%20systems%2C%20mobile%20radio%20networks%20and%20access%20networks%20etc.
chenhui
chenhui Admin Created Dec 1, 2019 13:33:43 Helpful(0) Helpful(0)

@Doncharles hello,
IP SLA in Cisco is corresponding to the BFD or NQA in Huawei.
you can find the configuration example at https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_nqa_0001&lang=en (for NQA)
and https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_bfd_0001_2&lang=en (for BFD)
  • x
  • convention:

Doncharles
Doncharles Created Dec 1, 2019 13:43:44
Thanks i will check it out  
Doncharles
Doncharles Created Dec 1, 2019 14:12:58 Helpful(0) Helpful(0)

Thanks all. i have done the nqa configurations, but this is still pending????

route-map phase3-glo permit 20

set ip next-hop verify-availability 172.16.0.1 2 track 2

set ip next-hop verify-availability 172.16.1.1 3 track 3

ip nat inside source route-map glo interface GigabitEthernet0/2 overload

ip nat inside source route-map phase3 interface GigabitEthernet0/1 overload
  • x
  • convention:

chenhui
chenhui Admin Created Dec 2, 2019 01:49:54 Helpful(0) Helpful(0)

Posted by Doncharles at 2019-12-01 14:12 Thanks all. i have done the nqa configurations, but this is still pending????route-map phase3-glo pe ...
route-map is corresponded to the route-policy in Huawei VRP platform.
But from your configuration, it seems that you want to modify the next-hop when the next-hop ip address is available after the NAT.
If you use the route-map to redirect the traffic, you might use the traffic policy in Huawei to do the same thing.
please check
https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_qos_0030&lang=en (for traffic policy)
https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_NAT_0001&lang=en (for NAT)

Also, you can find the route policy, but I think you might don't need this.
https://support.huawei.com/hedex/hdx.do?docid=EDOC1100007335&id=dc_cfg_route-policy_0000&lang=en
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login