CE6856 M-LAG VxLAN L2 trunk downlink to Cisco 2960X

Created: Nov 26, 2019 14:09:33Latest reply: Nov 29, 2019 07:36:34 134 8 0 0
  Rewarded Hi-coins: 0 (problem resolved)

Hi all,


I am deploying VxLAN solution. When I configuring the downlink to Cisco Switch with trunk, 

The ports are in up status, but both switches said it is the root bridge, seems it cannot see each others.

Does anyone know how to configure/suggestion on huawei and cisco?


Also, I also want to configure with 2 Huawei Switches with MLAG, do I add "dfs-group 1 m-lag 1", is it still working with cisco?


Huawei configuration:

interface Eth-Trunk10

 description Link to 2960X-3 L2

 mode lacp-static

#

interface Eth-Trunk10.218020 mode l2

 encapsulation dot1q vid 20

 bridge-domain 218020

#

interface 10GE1/0/34

 description Link to KDC-2960X-3 L2

 eth-trunk 10

 lacp force-up




Cisco configuration:

interface port-channel10

switchport mode trunk

switchport trunk vlan 20

(I forgot the cisco configuration, just simple trunk allow vlan)



  • x
  • convention:

Featured Answers
chenhui
Admin Created Nov 26, 2019 14:23:57 Helpful(0) Helpful(0)

@WesKerT hello,
here are examples for link aggregation between Huawei and Cisco switch, https://support.huawei.com/hedex/hdx.do?docid=EDOC1100101219&id=EN-US_TASK_0138784589&lang=en

For the second question, did you mean you want to configure M-LAG on two Huawei switches and connect it to the Cisco switch?
  • x
  • convention:

All Answers
chenhui
chenhui Admin Created Nov 26, 2019 14:23:57 Helpful(0) Helpful(0)

@WesKerT hello,
here are examples for link aggregation between Huawei and Cisco switch, https://support.huawei.com/hedex/hdx.do?docid=EDOC1100101219&id=EN-US_TASK_0138784589&lang=en

For the second question, did you mean you want to configure M-LAG on two Huawei switches and connect it to the Cisco switch?
  • x
  • convention:

WesKerT
WesKerT Created Nov 26, 2019 15:19:03 Helpful(0) Helpful(0)

Thanks for your reply.
The link aggregation between Huawei and Cisco is working (I have tried this for Layer 3 link).
but when I do it on layer 2 with VxLAN, the link is up, but seems not working.

For the second question, yes, I would like to configure MLAG to connect with cisco SW, but now I am still stacking on the first problem.

Thank you.
  • x
  • convention:

lubna
lubna Created Nov 26, 2019 15:38:07 Helpful(0) Helpful(0)

Issue Description
S5720 (V200R010C00SPC600) connect to Cisco Catalist 2960 by 2 links in eth-trunk.
Configuration example - KB EKB1000435123 (for Cisco 4506) did not help to solve the issue.

Eth-trunk at Huawei – DOWN, at Cisco – UP.

transparent.gif Alarm Information
Huawei S5720 diagnostic:

5f94909f6f634da288e3d90b0143be26

Cisco Catalist 2960 diagnostic:

81ff3f8b963e4d0aa6092c7e9b945d71

transparent.gif Handling Process
Huawei switch config:

interface Eth-Trunk11
description Cisco2960-4-2
port link-type trunk
port trunk allow-pass vlan 3 8 21 30 to 31
stp bpdu-filter enable
stp edged-port disable
mode lacp

interface GigabitEthernet0/0/14
undo negotiation auto
description Cisco2960-4-2_1
eth-trunk 11

interface GigabitEthernet1/0/14
undo negotiation auto
description Cisco2960-4-2_2
eth-trunk 11

Cisco 2960 switch config:

interface Port-channel1
description UpSwitch
switchport trunk allowed vlan 1,3,8,21
switchport mode trunk

interface GigabitEthernet1/0/25
description UpSwitch_1
switchport trunk allowed vlan 1,3,8,21
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/26
description UpSwitch_2
switchport trunk allowed vlan 1,3,8,21
switchport mode trunk
channel-group 1 mode on

transparent.gif Root Cause
As LACP is used in EtherChannel, at Cisco side interfaces must be added to EtherChannel in passive mode.



transparent.gif Solution
Modify Cisco switch configuration of port-channel group at member-Interface view :
channel-group 1 mode on ------>>> channel-group 1 mode passive
  • x
  • convention:

i%20am%20student%20%20and%20i%20am%20doing%20BSIT%20from%20international%20Islamic%20university%20in%20islamabad
lubna
lubna Created Nov 26, 2019 15:38:39 Helpful(0) Helpful(0)

Issue Description
S5720 (V200R010C00SPC600) connect to Cisco Catalist 2960 by 2 links in eth-trunk.
Configuration example - KB EKB1000435123 (for Cisco 4506) did not help to solve the issue.

Eth-trunk at Huawei – DOWN, at Cisco – UP.

transparent.gif Alarm Information
Huawei S5720 diagnostic:

5f94909f6f634da288e3d90b0143be26

Cisco Catalist 2960 diagnostic:

81ff3f8b963e4d0aa6092c7e9b945d71

transparent.gif Handling Process
Huawei switch config:

interface Eth-Trunk11
description Cisco2960-4-2
port link-type trunk
port trunk allow-pass vlan 3 8 21 30 to 31
stp bpdu-filter enable
stp edged-port disable
mode lacp

interface GigabitEthernet0/0/14
undo negotiation auto
description Cisco2960-4-2_1
eth-trunk 11

interface GigabitEthernet1/0/14
undo negotiation auto
description Cisco2960-4-2_2
eth-trunk 11

Cisco 2960 switch config:

interface Port-channel1
description UpSwitch
switchport trunk allowed vlan 1,3,8,21
switchport mode trunk

interface GigabitEthernet1/0/25
description UpSwitch_1
switchport trunk allowed vlan 1,3,8,21
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/26
description UpSwitch_2
switchport trunk allowed vlan 1,3,8,21
switchport mode trunk
channel-group 1 mode on

transparent.gif Root Cause
As LACP is used in EtherChannel, at Cisco side interfaces must be added to EtherChannel in passive mode.



transparent.gif Solution
Modify Cisco switch configuration of port-channel group at member-Interface view :
channel-group 1 mode on ------>>> channel-group 1 mode passive
  • x
  • convention:

i%20am%20student%20%20and%20i%20am%20doing%20BSIT%20from%20international%20Islamic%20university%20in%20islamabad
lubna
lubna Created Nov 26, 2019 15:43:29 Helpful(0) Helpful(0)

transparent Issue Description
S5720 (V200R010C00SPC600) connect to Cisco Catalyst 2960 by 2 links in eth-trunk.
Configuration example - KB EKB1000435123 (for Cisco 4506) did not help to solve the issue.

Eth-trunk at Huawei – DOWN, at Cisco – UP.


Handling Process
Huawei switch config:

interface Eth-Trunk 11
description Cisco 2960-4-2
port link-type trunk
port trunk allow-pass vlan 3 8 21 30 to 31
step bpdu-filter enable
step edged-port disable
mode lacp

interface Gigabit Ethernet /0/14
undo negotiation auto
description Cisco 2960-4-2_1
eth-trunk 11

interface Gigabit Ethernet/0/14
undo negotiation auto
description Cisco 2960-4-2_2
eth-trunk 11

Cisco 2960 switch config:

interface Port-channel
description Up Switch
switch-port trunk allowed vlan 1,3,8,21
switch port mode trunk

interface Gigabit Ethernet/0/25
description Up Switch_1
switch-port trunk allowed vlan 1,3,8,21
switch-port mode trunk
channel-group 1 mode on
!
interface Gigabit Ethernet/0/26
description Up Switch_2
switch port trunk allowed vlan 1,3,8,21
switch port mode trunk
channel-group 1 mode on

transparent.gif Root Cause
As LACP is used in Ether-channel, at Cisco side interfaces must be added to Ether Channel in passive mode.



transparent Solution
Modify Cisco switch configuration of port-channel group at member-Interface view :
channel-group 1 mode on ------>>> channel-group 1 mode passive

  • x
  • convention:

i%20am%20student%20%20and%20i%20am%20doing%20BSIT%20from%20international%20Islamic%20university%20in%20islamabad
chenhui
chenhui Admin Created Nov 27, 2019 06:56:00 Helpful(0) Helpful(0)

Posted by WesKerT at 2019-11-26 15:19 Thanks for your reply.The link aggregation between Huawei and Cisco is working (I have tried this fo ...
well, I think you should try to verify if the vxlan configuration is fine and the vxlan tunnel is fine. As you said both switches(Huawei and Cisco) reported itself which is the root bridge, I think you mean the root bridge in xSTP, if the vxlan tunnel is fine, it's better to check the xSTP protocol enabled on both Huawei and Cisco switch, cause PVST/PVST+ is the default xSTP protocol on Cisco switch while MSTP on the Huawei switch.

For the second problem, you can check https://support.huawei.com/hedex/hdx.do?docid=EDOC1100020548&id=dc_cfg_eth-trunk_0087&lang=en
  • x
  • convention:

WesKerT
WesKerT Created Nov 27, 2019 07:13:47 Helpful(0) Helpful(0)

Thanks for your reply.
I have tried cisco configure with MSTP, then it can communicate with Huawei.
But may I ask does MLAG pair can work Cisco RPVST?
Or can Huawei SW configure to have per vlan STP?

I cannot find any way to communicate with Cisco xSTP, as MLAG does not support VBST.
  • x
  • convention:

chenhui
chenhui Admin Created Nov 29, 2019 07:36:34 Helpful(0) Helpful(0)

Posted by WesKerT at 2019-11-27 07:13 Thanks for your reply.I have tried cisco configure with MSTP, then it can communicate with Huawei.Bu ...
PVST is a private protocol released by Cisco, Huawei doesn't support it.
M-LAG could connect to Cisco, when M-LAG enabled, the switch only supports RSTP.
For Huawei switch, VBST works similar as the PVST.
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login