Can Huawei S12700 with VBST receice BPDU with topology-change flag from Cisco PV

Latest reply: Oct 22, 2015 06:21:50 2798 3 0 0

Can Huawei S12700 with VBST receice BPDU with topology-change flag from Cisco PVST?


Huawei S12700------cisco 3750
   VBST              PVST            

When disconnect and connect computer on port GigabitEthernet1/0/13
BPDU with topology-change flag is sent from 3750 to S12700,
but on S12700 i can see no new opology-change:

display stp  vlan 2 topology-change
VLAN 2 topology change information
   Number of topology changes             :20
   Topology change initiator(detected)    :GigabitEthernet5/0/16
   Time since last topology change        :1 days 18h:26m:44s   (OLD)



---- Huawei S12700 config ------------
stp transmit-limit 10
stp mode vbst
stp pathcost-standard dot1d-1998
stp tc-protection threshold 10


interface Eth-Trunk7
description UIT
port link-type trunk
port trunk allow-pass vlan 2 to 16 20 to 22 30 to 32 200 to 220
stp no-agreement-check
bpdu bridge enable

interface XGigabitEthernet7/0/0
description UIT
eth-trunk 7
broadcast-suppression 1

interface XGigabitEthernet8/0/0
description UIT
eth-trunk 7
broadcast-suppression 1

stp vlan 1 to 4094 root primary


--- cisco 3750 config ----

spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!        


interface Port-channel2
description S12700
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-16,20-22,30-32,200-220
switchport trunk pruning vlan none
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00

interface TenGigabitEthernet1/1/1
description S12700
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-16,20-22,30-32,200-220
switchport trunk pruning vlan none
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
channel-group 2 mode on


interface TenGigabitEthernet1/1/2
description S12700
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-16,20-22,30-32,200-220
switchport trunk pruning vlan none
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
channel-group 2 mode on



interface GigabitEthernet1/0/13
switchport trunk allowed vlan 1-16,20-22,200-220
switchport trunk pruning vlan none
switchport mode trunk
switchport nonegotiate







This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

lizhuzhu
Created Oct 22, 2015 02:28:09 Helpful(0) Helpful(0)

I suggest you refer to the product document. There're some interconnection examples.

As I know, Huawei VBST is compatible with Cisco PVST.

  • x
  • convention:

Busy_with_lazy_mind
Created Oct 22, 2015 02:40:59 Helpful(0) Helpful(0)

Can you show the STP state on CISCO 3750.

Usually, the state change of edged-port would not trigger STP change by using portfast function, so we have to check whether the STP topology changed or not on CISCO 3750.

  • x
  • convention:

ymklenov
Created Oct 22, 2015 06:21:50 Helpful(0) Helpful(0)

on cisco:

VLAN0002 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, sysid 2, address 0017.95c6.7a00
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 2, address 7ca2.3efe.dc00
  Root port is 496 (Port-channel2), cost of root path is 1
  Topology change flag not set, detected flag set
  Number of topology changes 12 last change occurred 2d15h ago
          from StackPort3
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 1, aging 3600

#debug sp events
Spanning Tree event debugging is on

024169: 1y21w: STP: VLAN0030 sent Topology Change Notice on Po2
024170: 1y21w: STP: VLAN0031 sent Topology Change Notice on Po2
024171: 1y21w: STP: VLAN0032 sent Topology Change Notice on Po2
024172: 1y21w: STP: VLAN0007 sent Topology Change Notice on Po2
024173: 1y21w: STP: VLAN0008 sent Topology Change Notice on Po2
024174: 1y21w: STP: VLAN0001 sent Topology Change Notice on Po2
024175: 1y21w: STP: VLAN0003 sent Topology Change Notice on Po2
024176: 1y21w: STP: VLAN0009 sent Topology Change Notice on Po2
024177: 1y21w: STP: VLAN0010 sent Topology Change Notice on Po2
024178: 1y21w: STP: VLAN0011 sent Topology Change Notice on Po2
024179: 1y21w: STP: VLAN0012 sent Topology Change Notice on Po2
024180: 1y21w: STP: VLAN0013 sent Topology Change Notice on Po2
024181: 1y21w: STP: VLAN0014 sent Topology Change Notice on Po2
024182: 1y21w: STP: VLAN0015 sent Topology Change Notice on Po2
024183: 1y21w: STP: VLAN0016 sent Topology Change Notice on Po2
024184: 1y21w: STP: VLAN0020 sent Topology Change Notice on Po2
024185: 1y21w: STP: VLAN0021 sent Topology Change Notice on Po2
024186: 1y21w: STP: VLAN0022 sent Topology Change Notice on Po2
024187: 1y21w: STP: VLAN0200 sent Topology Change Notice on Po2
024188: 1y21w: STP: VLAN0201 sent Topology Change Notice on Po2
024189: 1y21w: STP: VLAN0202 sent Topology Change Notice on Po2
024190: 1y21w: STP: VLAN0203 sent Topology Change Notice on Po2
024191: 1y21w: STP: VLAN0206 sent Topology Change Notice on Po2
024192: 1y21w: STP: VLAN0207 sent Topology Change Notice on Po2
024193: 1y21w: STP: VLAN0004 sent Topology Change Notice on Po2
024194: 1y21w: STP: VLAN0005 sent Topology Change Notice on Po2
024195: 1y21w: STP: VLAN0205 sent Topology Change Notice on Po2
024196: 1y21w: STP: VLAN0006 sent Topology Change Notice on Po2
024197: 1y21w: STP: VLAN0204 sent Topology Change Notice on Po2
024198: 1y21w: STP: VLAN0002 sent Topology Change Notice on Po2
024199: 1y21w: STP: VLAN0030 sent Topology Change Notice on Po2
024200: 1y21w: STP: VLAN0031 sent Topology Change Notice on Po2
024201: 1y21w: STP: VLAN0032 sent Topology Change Notice on Po2
024202: 1y21w: STP: VLAN0007 sent Topology Change Notice on Po2
024203: 1y21w: STP: VLAN0008 sent Topology Change Notice on Po2
024204: 1y21w: STP: VLAN0001 sent Topology Change Notice on Po2
024205: 1y21w: STP: VLAN0003 sent Topology Change Notice on Po2
024206: 1y21w: STP: VLAN0009 sent Topology Change Notice on Po2
024207: 1y21w: STP: VLAN0010 sent Topology Change Notice on Po2
024208: 1y21w: STP: VLAN0011 sent Topology Change Notice on Po2
024209: 1y21w: STP: VLAN0012 sent Topology Change Notice on Po2
024210: 1y21w: STP: VLAN0013 sent Topology Change Notice on Po2
024211: 1y21w: STP: VLAN0014 sent Topology Change Notice on Po2
024212: 1y21w: STP: VLAN0015 sent Topology Change Notice on Po2
024213: 1y21w: STP: VLAN0016 sent Topology Change Notice on Po2
024214: 1y21w: STP: VLAN0020 sent Topology Change Notice on Po2
024215: 1y21w: STP: VLAN0021 sent Topology Change Notice on Po2
024216: 1y21w: STP: VLAN0022 sent Topology Change Notice on Po2
024217: 1y21w: STP: VLAN0200 sent Topology Change Notice on Po2
024218: 1y21w: STP: VLAN0201 sent Topology Change Notice on Po2
024219: 1y21w: STP: VLAN0202 sent Topology Change Notice on Po2
024220: 1y21w: STP: VLAN0203 sent Topology Change Notice on Po2
024221: 1y21w: STP: VLAN0206 sent Topology Change Notice on Po2
024222: 1y21w: STP: VLAN0207 sent Topology Change Notice on Po2
024223: 1y21w: STP: VLAN0004 sent Topology Change Notice on Po2
024224: 1y21w: STP: VLAN0005 sent Topology Change Notice on Po2
024225: 1y21w: STP: VLAN0205 sent Topology Change Notice on Po2
024226: 1y21w: STP: VLAN0006 sent Topology Change Notice on Po2
024227: 1y21w: STP: VLAN0204 sent Topology Change Notice on Po2
024228: 1y21w: STP: VLAN0002 sent Topology Change Notice on Po2
024229: 1y21w: STP: VLAN0030 sent Topology Change Notice on Po2
024230: 1y21w: STP: VLAN0031 sent Topology Change Notice on Po2
024231: 1y21w: STP: VLAN0032 sent Topology Change Notice on Po2
024232: 1y21w: STP: VLAN0007 sent Topology Change Notice on Po2


18962: Oct 22 05:01:42: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/13, changed state to up
018963: Oct 22 05:01:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/13, changed state to up
018964: Oct 22 05:01:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/13, changed state to down
018965: Oct 22 05:01:59: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/13, changed state to down
018966: Oct 22 05:02:06: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/13, changed state to up
018967: Oct 22 05:02:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/13, changed state to up
018968: Oct 22 05:02:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/13, changed state to down
018969: Oct 22 05:02:15: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/13, changed state to down


interface GigabitEthernet1/0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-16,20-22,200-220
switchport mode trunk
switchport nonegotiate


on S12700:

<s12700>display stp vlan 2 tc-bpdu statistics 
-------------------------- STP TC/TCN information --------------------------
VLAN-ID Port                        TC(Send/Receive)      TCN(Send/Receive)
   2     Eth-Trunk0                  0/0                   0/0
   2     Eth-Trunk1                  0/0                   0/0
   2     Eth-Trunk2                  0/0                   0/0
   2     Eth-Trunk3                  0/0                   0/0
   2     Eth-Trunk4                  0/0                   0/0
   2     Eth-Trunk5                  0/0                   0/0
   2     Eth-Trunk6                  0/0                   0/0
   2     Eth-Trunk7                  0/0                   0/0
   2     Eth-Trunk8                  0/0                   0/0
   2     Eth-Trunk9                  0/0                   0/0
   2     GigabitEthernet5/0/14       0/0                   0/0
   2     GigabitEthernet5/0/16       0/0                   0/0
   2     GigabitEthernet6/0/14       0/0                   0/0
 


Cisco send TCN, but S12700 not recieved it.




  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login