Basic commands for configuring Huawei switches

Latest reply: Dec 27, 2018 07:08:53 2480 5 11 0

This post features the basic commands for configuring Huawei switches. Please have a look below.


If a switch is configured, the following commands may help you. The following is a comment after //.


[Quidway] display current-configuration// Display the current configuration.
[Quidway] display interfaces// Displays interface information.
[Quidway] display vlan all// Displays vlan information.
[Quidway] display version// Displays the version information.

[Quidway] super password// Changing the Password of a Privileged User
[Quidway] sysname// Switch Naming
[Quidway] interface ethernet 0/0/1// Enter the interface view.
[Quidway] interface vlanif x// Enter the interface view.
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0// Configure the IP address of the VLAN.

[Quidway] ip route-static 0.0.0.0 0.0.0.0 10.65.1.2// Static route = gateway

[Quidway] user-interface vty 0 4// Access the virtual terminal
[S3026-ui-vty0-4]authentication-mode password// Setting the password mode
[S3026-ui-vty0-4]set authentication-mode password simple 222// Setting a password
[S3026-ui-vty0-4]user privilege level 3// User level

[Quidway] interface ethernet 0/0/1// Enter the port mode.
[Quidway] int e0/0/1// Enter the port mode.
[Quidway-Ethernet0/1]duplex {half|full|auto}// Configuring the Working Status of a Port
[Quidway-Ethernet0/1]speed {10|100|auto}// Configuring the Working Rate of a Port
[Quidway-Ethernet0/1]flow-control// Configuring Port Flow Control
[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid}// To set the working mode of a port
[Quidway-Ethernet0/1]port access vlan 3// The current port is added to the VLAN.
[Quidway-Ethernet0/2]port trunk allow-pass vlan {ID|All}// Set the VLAN allowed by the trunk.
[Quidway-Ethernet0/3]port trunk pvid vlan 3// Setting the PVID of a Trunk Port
[Quidway-Ethernet0/1]undo shutdown// Activating a Port
[Quidway-Ethernet0/1]shutdown// Disable the port.
[Quidway-Ethernet0/1]quit// Return


  • x
  • convention:

dagui
Created Dec 26, 2018 03:20:54 Helpful(0) Helpful(0)

port link-type {trunk|access|hybrid}// To set the working mode of a port.Can you provide a more detailed explanation?
  • x
  • convention:

JoneSnow
Created Dec 26, 2018 03:21:40 Helpful(0) Helpful(0)

great~ Use // this symbol to interpret each command.
  • x
  • convention:

yiyi0519
Created Dec 26, 2018 06:09:56 Helpful(0) Helpful(0)

These basic configuration commands are very useful when the device is started, which is very helpful for a beginner.
  • x
  • convention:

user_2915719
Created Dec 27, 2018 02:49:31 Helpful(0) Helpful(0)

user-interface vty 0 4 means the user to log into the management console, right?
  • x
  • convention:

liwaye
Created Dec 27, 2018 07:08:53 Helpful(0) Helpful(0)

what different between access trunk and hybrid ,and can you help to share if i want undo the system information ,what can i do ?
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login