bandwidth throughput is not oPtimal in qinq mode

Created: Jun 25, 2019 14:25:18Latest reply: Jul 2, 2019 17:36:21 405 17 0 0
  Rewarded Hi-coins: 0 (problem resolved)

Hi All

We have S5700 Series switch through which , I am not able to get the desired speed at user side .



Description:

 

  1. We have enabled QinQ configuration on Huawei 5720 switch with outer VLAN – Service Provider VLAN( point to multi-point)


112217et9t9nxhyyzzmtht.jpg?aaaaa.jpg

  1. We have a trunk switch Huawei 5720 switch  where the inner VLAN is configured  - Customer VLAN
  2. We have end to end reachability on the customer VLANs with the Internet

 

 

Issues:

 

  1. We are unable to cumulatively switch more than 1 Gbps although input ( internet) bandwidth is 1.5 Gbps.

2. all the member of the eth-trunk are 1gbps bandwidth .

3. if we byppass the qinq switch we are able to pass the desired bandwidth


attached is the qinq switch config




vlan batch 20 24 to 25 1003 to 1006 2005 to 2006 2008 to 2010 2012 to 2013


telnet server enable

#


vlan 20

 name POP-PRIVATE

vlan 24

 name MGMT

vlan 25

 name POP-PUBLIC

vlan 1003

 name HYD-NAMPALLY

vlan 1004

 name HYD-SR-NAGAR

vlan 1005

 name MANGAMMANAPALYA-SLN

vlan 1006

 name BOMMANAHALLI-JASMILE

vlan 2005

 name HYDERABAD-NLD

vlan 2006

 name CHETHAN-P2P

vlan 2008

 name CHANNAPATNA-YOUTH-BB

vlan 2010

 name SONU-P2P

vlan 2012

 name FCI

vlan 2013

 name SNEHA-CABLE

#

interface Vlanif1

#

interface Vlanif25

 description ### WAN PUBLIC ###

 ipv6 enable

 ip address 103.130.109.10 255.255.255.0

 ipv6 address 2001:DF6:E300:500::A/64

#


#

interface Eth-Trunk4

 description ### QinQ SWITCH to CORE TRUNK SWITCH ###

 port link-type hybrid

 qinq vlan-translation enable

 port hybrid tagged vlan 20 24 to 25 1001 1005 to 1006 2006 2008 2010 2012 to 2013

 port hybrid untagged vlan 2005 2009

 port vlan-stacking vlan 24 stack-vlan 2005

 port vlan-stacking vlan 499 stack-vlan 2005

 port vlan-stacking vlan 501 to 505 stack-vlan 2005

 port vlan-stacking vlan 506 to 510 stack-vlan 2005

 port vlan-stacking vlan 511 to 514 stack-vlan 2005

 port vlan-stacking vlan 515 to 518 stack-vlan 2005

 port vlan-stacking vlan 30 stack-vlan 2009

 port vlan-stacking vlan 50 to 60 stack-vlan 2009

#


#

interface GigabitEthernet0/0/17

 description ## QinQ ##

 eth-trunk 4

#

interface GigabitEthernet0/0/18

 description ## QinQ ##

 eth-trunk 4

#

interface GigabitEthernet0/0/19

 description ## QinQ ##

 eth-trunk 4

#

interface GigabitEthernet0/0/20

 description ## QinQ ##

 eth-trunk 4

#

interface GigabitEthernet0/0/21

 description ## PRI-CACTI ##

 port link-type access

 port default vlan 25

#

interface GigabitEthernet0/0/22

 description ## PRI-DNS ##

 port link-type access

 port default vlan 24

#

interface GigabitEthernet0/0/23

 port link-type access

 port default vlan 2010

#

interface GigabitEthernet0/0/24

 port link-type access

 port default vlan 700

#

interface XGigabitEthernet0/0/1

 description ### AIRTEL-P2P ###

 port link-type trunk

 port trunk allow-pass vlan 1005 to 1006 2005 to 2006 2008 to 2010 2012 to 2013

#


#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 103.130.109.1


[NXTRA-QinQ-SWITCH]



  • x
  • convention:

Featured Answers
Admin Created Jun 27, 2019 20:00:13 Helpful(0) Helpful(0)

Posted by yogijain at 2019-06-27 12:35 Hi ChenhuiPlease find the below response 1) Yes2) No, Please share the required commands / configura ...
hi,
I checked the configuration you provided previous, it seems that the load balance for all the eth-trunk is based on src-dst-IP, you said that when the qinq switch is introduced into the network, the bandwidth reachs only 1Gbps, I think it is the load balance mode which caused this problem.
please try to adjust the load balance mode between qinq switch and CORE switch to src-dst-mac, rather than src-dst-IP.
reference command:
interface eth-trunk xx
load-balance src-dst-mac
  • x
  • convention:

Admin Created Jun 28, 2019 09:05:04 Helpful(0) Helpful(0)

Posted by yogijain at 2019-06-27 22:53 Hi, after changing load balance to arc dst mac data transfer failed even at 1Gbps.
Hi,
please confirm if the maximum 1G bandwidth is generated when the user access to a specific site, and in which scenario does the bandwidth reach 1.6G. In another word, whether the bandwidth could reach 1.6G when the user access the same specific site with the qinq switch removed.
the load balance mode is based on per flow, when the user access to a specific site, all the traffic will be hashed to the specific physical interface if the source IP address and destination IP address doesn't change, in that scenario, the maximum access bandwidth couldnot exceed the physical interface bandwidth.
  • x
  • convention:

All Answers
chenhui Admin Created Jun 25, 2019 14:51:25 Helpful(0) Helpful(0)

@yogijain hi,
qinq

since the picture you uploaded is too blurred, I need to confirm some doubts with you.
1. you said that your are unable to cumulatively switch more than 1 Gbps, did you mean the eth-trunk link which marked green in the picture?
2. Is the blue mark in the picture a edge router of the user?
3. Is the quadrangle which marked with TRUNK the trunk switch Huawei 5720?

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

yogijain MVE Created Jun 25, 2019 14:56:08 Helpful(0) Helpful(0)

Hi
regret for rough sketch

Please find my answer
1) the box with question marks / l2 B/W , aggregate bandwidth after qinq switch is not more than 1 GB although each port has capacity off 1G

2)Yes

3) Yes
  • x
  • convention:

Yogendra%20Jain
chenhui Admin Created Jun 25, 2019 16:03:36 Helpful(0) Helpful(0)

Posted by yogijain at 2019-06-25 14:56 Hi regret for rough sketchPlease find my answer 1) the box with question marks / l2 B/W , aggregat ...
hi,
one more question, is there another switch between the trunk switch Huawei 5720 and the P2P device?
in theoretically, there should be anoter device to connect the S5720 through eth-trunk.
Besides, please check the eth-trunk interface on the s5720, make sure all the physical interfaces are selected.(display eth-trunk xxx)
  • x
  • convention:

yogijain MVE Created Jun 25, 2019 16:24:05 Helpful(0) Helpful(0)

Posted by chenhui at 2019-06-25 13:03hi,one more question, is there another switch between the trunk switch Huawei 5720 and the P2P dev ...

there is  QINQ switch of Huawei Make between Huawei Trunk Switch and p2p .

QINQ switch output

[NXTRA-QinQ-SWITCH]dis interface Eth-Trunk 4
Eth-Trunk4 current state : UP
Line protocol current state : UP
Description:### QinQ SWITCH to CORE TRUNK SWITCH ###
Switch Port, Link-type : hybrid,
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 4G, Current BW: 4G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is b4fb-f9bc-7020
Current system time: 2019-06-25 13:03+05:30
Last 300 seconds input rate 129872 bits/sec, 122 packets/sec
Last 300 seconds output rate 33392 bits/sec, 29 packets/sec
Input:  63110042447 packets, 81292209867523 bytes
  Unicast:                62709417226,  Multicast:                    11758425
  Broadcast:                388866796,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  37895428498 packets, 12022316687207 bytes
  Unicast:                37527847715,  Multicast:                   233346427
  Broadcast:                134234356,  Jumbo:                               0
  Discard:                          0,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  Late Collisions:                     0
  Deferreds:                        0

    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
GigabitEthernet0/0/17         UP          1
GigabitEthernet0/0/18         UP          1
GigabitEthernet0/0/19         UP          1
GigabitEthernet0/0/20         UP          1
-----------------------------------------------------
The Number of Ports in Trunk : 4
The Number of UP Ports in Trunk : 4

[NXTRA-QinQ-SWITCH]












trunk switch output



[NURON-CORE-TRUNK-S5720]                           dis interface Eth-Trunk 1
Eth-Trunk1 current state : UP
Line protocol current state : UP
Description:ROUTER-LAN
Switch Port, Link-type : trunk(configured),
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 4G, Current BW: 4G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is b4fb-f9bc-7570
Current system time: 2019-06-25 13:03+05:30
Last 300 seconds input rate 1509859488 bits/sec, 195141 packets/sec
Last 300 seconds output rate 220559248 bits/sec, 140672 packets/sec
Input:  91141971134 packets, 103512225529807 bytes
  Unicast:                90954837748,  Multicast:                     7053091
  Broadcast:                180080295,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  87176581061 packets, 26312018581520 bytes
  Unicast:                86906869440,  Multicast:                     8386760
  Broadcast:                261324861,  Jumbo:                               0
  Discard:                      39782,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  Late Collisions:                     0
  Deferreds:                        0

    Input bandwidth utilization  : 37.75%
    Output bandwidth utilization : 5.51%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
GigabitEthernet0/0/1          UP          1
GigabitEthernet0/0/2          UP          1
GigabitEthernet0/0/3          UP          1
GigabitEthernet0/0/4          UP          1
-----------------------------------------------------
The Number of Ports in Trunk : 4
The Number of UP Ports in Trunk : 4

[NURON-CORE-TRUNK-S5720]                           dis interface Eth-Trunk 2
Eth-Trunk2 current state : UP
Line protocol current state : UP
Description:NAS-WAN
Switch Port, Link-type : trunk(configured),
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 4G, Current BW: 4G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is b4fb-f9bc-7570
Current system time: 2019-06-25 13:03+05:30
Last 300 seconds input rate 219692152 bits/sec, 140634 packets/sec
Last 300 seconds output rate 1511425352 bits/sec, 195178 packets/sec
Input:  85769636664 packets, 25028221888913 bytes
  Unicast:                85546094852,  Multicast:                     6466048
  Broadcast:                217075764,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  89732886961 packets, 102106878203188 bytes
  Unicast:                89501664219,  Multicast:                     7955285
  Broadcast:                223267457,  Jumbo:                               0
  Discard:                    2967480,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  Late Collisions:                     0
  Deferreds:                        0

    Input bandwidth utilization  : 5.49%
    Output bandwidth utilization : 37.79%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
GigabitEthernet0/0/5          UP          1
GigabitEthernet0/0/6          UP          1
GigabitEthernet0/0/7          UP          1
GigabitEthernet0/0/8          UP          1
-----------------------------------------------------
The Number of Ports in Trunk : 4
The Number of UP Ports in Trunk : 4

[NURON-CORE-TRUNK-S5720]                           dis interface Eth-Trunk 3
Eth-Trunk3 current state : UP
Line protocol current state : UP
Description:NAS-LAN
Switch Port, Link-type : trunk(configured),
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 4G, Current BW: 4G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is b4fb-f9bc-7570
Current system time: 2019-06-25 13:03+05:30
Last 300 seconds input rate 224 bits/sec, 0 packets/sec
Last 300 seconds output rate 64344 bits/sec, 92 packets/sec
Input:  73521096077 packets, 95214949107081 bytes
  Unicast:                73496121551,  Multicast:                     9915080
  Broadcast:                 15059446,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  44166038618 packets, 13806033223115 bytes
  Unicast:                43328134196,  Multicast:                   252087942
  Broadcast:                585816480,  Jumbo:                               0
  Discard:                          0,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  Late Collisions:                     0
  Deferreds:                        0

    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
GigabitEthernet0/0/9          UP          1
GigabitEthernet0/0/10         UP          1
GigabitEthernet0/0/11         UP          1
GigabitEthernet0/0/12         UP          1
-----------------------------------------------------
The Number of Ports in Trunk : 4
The Number of UP Ports in Trunk : 4

[NURON-CORE-TRUNK-S5720]                           dis interface Eth-Trunk 4
Eth-Trunk4 current state : UP
Line protocol current state : UP
Description:## CORE-TRUNK-SW-TO-QinQ-SW ##
Switch Port, Link-type : trunk(configured),
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 4G, Current BW: 4G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is b4fb-f9bc-7570
Current system time: 2019-06-25 13:03+05:30
Last 300 seconds input rate 31496 bits/sec, 27 packets/sec
Last 300 seconds output rate 127680 bits/sec, 120 packets/sec
Input:  37895431301 packets, 12022321943361 bytes
  Unicast:                37527850890,  Multicast:                   233345068
  Broadcast:                134235343,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  63110022196 packets, 81292214435671 bytes
  Unicast:                62709420792,  Multicast:                    11755716
  Broadcast:                388845688,  Jumbo:                               0
  Discard:                  119792717,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  Late Collisions:                     0
  Deferreds:                        0

    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
GigabitEthernet0/0/19         UP          1
GigabitEthernet0/0/20         UP          1
GigabitEthernet0/0/18         UP          1
GigabitEthernet0/0/17         UP          1
-----------------------------------------------------
The Number of Ports in Trunk : 4
The Number of UP Ports in Trunk : 4

[NURON-CORE-TRUNK-S5720]
  • x
  • convention:

Yogendra%20Jain
chenhui Admin Created Jun 25, 2019 19:09:15 Helpful(0) Helpful(0)

Posted by yogijain at 2019-06-25 16:24 there is QINQ switch of Huawei Make between Huawei Trunk Switch and p2p .QINQ switch output [NXTR ...
hi, 

bandwidth
from the output, the bandwidth is normal, 

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

yogijain MVE Created Jun 25, 2019 20:29:39 Helpful(0) Helpful(0)

Agreed , I will revert if more support required related to same.
  • x
  • convention:

yogijain MVE Created Jun 26, 2019 11:06:14 Helpful(0) Helpful(0)

Posted by chenhui at 2019-06-25 16:09 hi, from the output, the bandwidth is normal, 
Hi
As per end customer, if they remove the qinq switch from the network, they got full 1.6 Gbps bandwidht
But as they introduce the switch bandwidth got reduced to 1 Gb.

The capture shows lan to wan speed not the speed passing through qinq switch.
Regards
  • x
  • convention:

yogijain MVE Created Jun 26, 2019 22:31:03 Helpful(0) Helpful(0)

May I Know Resolution of the problem reported,its escalated from end customer side
  • x
  • convention:

Yogendra%20Jain
chenhui Admin Created Jun 27, 2019 10:06:59 Helpful(0) Helpful(0)

Posted by yogijain at 2019-06-26 22:31May I Know Resolution of the problem reported,its escalated from end customer side

sorry for the late.
I got some questions, please confirm these questions.
1. as you said if they remove the qinq switch from the network, they got full 1.6Gbps bandwidth, did you mean remove the qinq switch and connect the 10G link to the TRUNK switch directly?
2. will you please confirm the load balance mode between the qinq switch and the TRUNK switch, TRUNK switch and the edge Router.
3. Is the eth-trunk between the qinq switch and TRUNK switch, TRUNK switch and edge Router a layer 2 or layer 3 connection?
  • x
  • convention:

12
Back to list

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top