Got it

AR2240C-S with S5720 and AP3030DN configuration issue

Created: Sep 26, 2018 10:45:51Latest reply: Sep 27, 2018 06:30:15 1874 13 0 0 0
  Rewarded HiCoins: 0 (problem resolved)
This post was last edited by RollyNg at 2018-09-26 11:01. Hi Sergio,

Update to my setup and it does not work yet.

The S5720 software version is V200R010C00SPC600, perhaps I have to upgrade the software?

First of all, I would like to configure my IP as,

42.xxx.xxx.xxx (WAN) >> 192.168.1.1/24 (for VLAN100) >> 192.168.2.1/24 (for VLAN101 and the 192.168.2.xxx/24 are also for my wired connected servers which can be access by wireless clients).

Since the AR2240 comes with default management IP 192.168.1.1, so I change the AR2240 management IP to 192.168.0.1 and S5720 to 192.168.0.253 so free up the IPs. Also, I found that the default Vlanif1 is also using 192.168.1.1 so I delete Vlanif1 (what a mistake!).

Here is what it looks like on the AR2240 (only showing active connections):

<AC>display interface brief
Interface                         IP Address/Mask     Physical Protocol
GigabitEthernet0/0/4     192.168.0.1/24         Up          Up
GigabitEthernet0/0/8      42.xxx.xxx.xxx/24  Up          Up
Vlanif100                      192.168.1.1/24          Up          Up
Vlanif101                      192.168.2.1/24          Up          Up

Here is what it looks like on the S5720:
<Switch>display interface brief
Interface                         Physical Protocol
GigabitEthernet0/0/1     Up          Up
GigabitEthernet0/0/2     Up          Up
GigabitEthernet0/0/9     Up          Up
Vlanif1                          Down      Down

To me it seems Vlanif100 and 101 are not added to the S5720 although I have added them by CLI?

By deleting the default Vlanif1, I made the router non-operational as my wired servers loss internet access.

I have also login the S5720 web interface, but it does not add any Vlanif even I tried many times.

Please help me to correct the situation.

Thanks,
Rolly

AR2240C-S with S5720 and AP3030DN configuration issue-2761815-1
AR2240C-S with S5720 and AP3030DN configuration issue-2761815-2
Attachment: You need to log in to download or view. No account? Register
  • x
  • convention:

All Answers
RollyNg
RollyNg Created Sep 26, 2018 17:58:07

Posted by Sergio93 at 2018-09-26 16:59 Hi Rolly,They are in the same subnet( Users with 192.168.2.xx and Server 192.168.2.10) but I'm not ...
Hi Sergio,


The GUI automatically generate VLAN888 and 889 so I have to modify my configure as such:

# On the switch console, add GE0/0/1 that connects Switch to the AP-1 to management VLAN 888 and service VLAN 889; add GE0/0/2 that connects Switch to the AP-2 to the same VLANs; further add GE0/0/9 that connects Switch to the AC to the same VLANs.


<Huawei> system-view

[Huawei] sysname Switch

[Switch] vlan batch 888 to 889

[Switch] interface GigabitEthernet0/0/1

[Switch-GigabitEthernet0/0/1] port link-type trunk

[Switch-GigabitEthernet0/0/1] port trunk pvid vlan 888

[Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 888 889

[Switch-GigabitEthernet0/0/1] port-isolate enable

[Switch-GigabitEthernet0/0/1] quit

[Switch] interface GigabitEthernet0/0/2

[Switch-GigabitEthernet0/0/2] port link-type trunk

[Switch-GigabitEthernet0/0/2] port trunk pvid vlan 888

[Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 888 889

[Switch-GigabitEthernet0/0/2] port-isolate enable

[Switch-GigabitEthernet0/0/2] quit

[Switch] interface GigabitEthernet0/0/9

[Switch-GigabitEthernet0/0/9] port link-type trunk

[Switch-GigabitEthernet0/0/9] port trunk allow-pass vlan 888 889

[Switch-GigabitEthernet0/0/9] quit


# On the router console, add GE7/0/1 that connects the AC to Switch to VLANs 888 and 889.


<Huawei> system-view

[Huawei] sysname AC

[AC] vlan batch 888 to 889

[AC] interface GigabitEthernet7/0/1

[AC-GigabitEthernet7/0/1] port link-type trunk

[AC-GigabitEthernet7/0/1] port trunk pvid vlan 888

[AC-GigabitEthernet7/0/1] port trunk allow-pass vlan 888 889

[AC-GigabitEthernet7/0/1] port-isolate enable

[AC-GigabitEthernet7/0/1] quit


# Configure the AC as the DHCP server to allocate an IP address to the AP from the interface IP address pool on VLANIF 888, and allocate IP addresses to STAs from the interface IP address pool on VLANIF 889.


[AC] dhcp enable

[AC] interface vlanif 888

[AC-Vlanif888] ip address 192.168.100.1 24

[AC-Vlanif888] dhcp select interface

[AC-Vlanif888] quit

[AC] interface vlanif 889

[AC-Vlanif889] ip address 192.168.101.1 24

[AC-Vlanif889] dhcp select interface

[AC-Vlanif889] quit


My final setting is like the following, and I will try to ping the server by wifi tomorrow.

AR2240C-S with S5720 and AP3030DN configuration issue-2762085-1

View more

This article contains more resources

You need to log in to download or view. No account? Register

x
  • x
  • convention:

Sergio93
Sergio93 Created Sep 26, 2018 18:07:03

Posted by RollyNg at 2018-09-26 12:58 Hi Sergio,The GUI automatically generate VLAN888 and 889 so I have to modify my configure as such: ...
Hi Rolly,

It looks ok too, do more tests tomorrow and let us know the result :)
View more
  • x
  • convention:

RollyNg
RollyNg Created Sep 27, 2018 02:48:43

Hi Sergio,

Thanks for your kind guidance, I can ssh to the server with internal IP. Job done and problem solved! AR2240C-S with S5720 and AP3030DN configuration issue-2762375-1

Best,
Rolly
View more
  • x
  • convention:

Sergio93
Sergio93 Created Sep 27, 2018 06:30:15

Posted by RollyNg at 2018-09-26 21:48 Hi Sergio,Thanks for your kind guidance, I can ssh to the server with internal IP. Job done and prob ...
Great news, Rolly. I'm glad I could help you :)
With best regards,
Sergio
View more
  • x
  • convention:

12
Back to list

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.
Information Protection Guide
Thanks for using Huawei Enterprise Support Community! We will help you learn how we collect, use, store and share your personal information and the rights you have in accordance with Privacy Policy and User Agreement.