AR can’t login via GUI by tacacs authentication

Latest reply: Sep 30, 2018 06:25:05 2070 2 10 0

Problem Description

AR can’t login via GUI by tacacs the error as follow:

174615t0mce23smmstm33d.png

Problem Analysis

We have a debug to check the reason:

 

<HW>debugging hwtacacs all

<HW>t m

Info:Current terminal monitor is on.

<HW>t d

Info:Current terminal debugging is on.

 

1.       Debug from AR device four times include two times http login andtwo times ssh login.After check the debug logs we found there have something difference with Privlevel detail as follow:

Http login logs

Ssh login logs

Service=shell Protocol=http
MutilinkMax=0 MultilinkCurrent=0
DisconnectCause=0 DisconnectCauseExtend=0
PacketIn =0 ByteIn=0
PacketOut=0 ByteOut=0
ElapsedTime=0
NasRxSpeed=0 NasTxSpeed=0
TunnelID=0 TunnelConnectionID=0
Command= Event= Reason=
Privlevel=0

Service=shell  Protocol=ssh

  MutilinkMax=0  MultilinkCurrent=0

  DisconnectCause=0  DisconnectCauseExtend=0

  PacketIn =0  ByteIn=0

  PacketOut=0  ByteOut=0

  ElapsedTime=0

  NasRxSpeed=0   NasTxSpeed=0

  TunnelID=0  TunnelConnectionID=0

  Command=  Event=  Reason=

  Privlevel=15

 

2.       If the authorization privlevel is 0 the web login will be reject by device, So we have change the authorization privlevel to 15 in third-part device

174616lhttecywwe7y7qs3.png

3.       After change done we have test and verify that the AR can be login success now.

174617h55jzfuok5qwt5t5.png

 

Root Cause

Configuration wrong in third-part device

 

Solution Description

If the authorization privlevel is 0 the web login will be reject by device, So we have change the authorization privlevel to 15 in third-part device

 

  • x
  • convention:

No.9527
Created Sep 29, 2018 09:27:46 Helpful(0) Helpful(0)

I am very interested for this post, which is very helpful to our daily troubleshooting. I always have similar problems in my daily work, but I do not know how to deal with them. Now I have a clear idea. Thank you very much for your sharing. Hope you can update continue like this
  • x
  • convention:

Skay
Created Sep 30, 2018 06:25:05 Helpful(0) Helpful(0)

Hi Author , I want to add below check steps.
Check the configuration of the tacacs server. The created user name contains the domain name. If the device configuration is suspected, the domain name is not valid. The hwtacacs-server user-name domain-included command is used only when logging in. The user does not log in with the domain name. Even if this command is configured, the device will not send the domain name to the taskacs server to authenticate.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login