[All About Switches] Example of Connecting an S Series Switch to an IP Phone Usi

Latest reply: Aug 24, 2016 03:50:50 7377 1 1 0
 

1.1 Overview of MAC Address-based VLAN Assignment

MAC address-based VLAN assignment assigns VLAN IDs based on source MAC addresses in packets. After MAC address-based VLAN assignment is configured on an interface, untagged packets with the same source MAC address received by the interface are forwarded in the same VLAN.

In addition, MAC address-based VLAN assignment can modify the 802.1p priority in packets, so an IP phone can connect to a switch through MAC address-based VLAN assignment. However, when an IP phone connects to a switch through MAC address-based VLAN assignment, the IP phone is required to send untagged voice packets.

1.2 Applicable Version and Model

Version and Model

IP Phone Model

All versions and models

Voice VLAN cannot be configured through any protocol, for example, Avaya.

 

In this document, V200R006C00 is used as an example. The version differences will be described in section 1.8 Summary.

1.3 Networking Requirements

Voice data flows of HSI, VoIP, and IPTV services are transmitted on a network. Users require high quality of the VoIP service; therefore, voice data flows must be transmitted with a high priority. If a voice device does not support DHCP or LLDP, you can configure MAC address-based VLAN assignment on the switch. Then the switch assigns the voice device the VLAN bound to the MAC address of the voice device.

As shown in the following figure, the IP phone does not support DHCP or LLDP, so the switch cannot assign a voice VLAN to the IP phone and the IP phone sends untagged voice packets. To ensure high quality of the VoIP service, the switch identifies voice packets based on the MAC address of the IP phone and changes the 802.1p priority of voice packets to 5.

[All About Switches] Example of Connecting an S Series Switch to an IP Phone Usi-1292569-1

1.4 Data Plan

VLAN plan: Voice flows (VoIP) are transmitted in VLAN 300 and data flows (HIS and IPTV) are transmitted in VLAN 500.

1.5 Configuration Roadmap

The configuration roadmap is as follows:

l   Create VLANs for voice and data flows.

l   Configure MAC address-based VLAN assignment so that the switch can add the VLAN ID to voice packets and change the 802.1p priority of packets.

l   Configure the uplink interface to transparently transmit voice flows and data flows.

1.6 Procedure

   Step 1      Create VLANs for voice and data flows on the switch.

<HUAWEI> system-view

[HUAWEI] vlan batch 300 500

 

   Step 2      Configure the link type of an interface and PVID. Add the interface to a voice VLAN.

[HUAWEI] interface gigabitethernet 0/0/1

[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid  // Configure the link type of a switch interface connected to an IP phone as hybrid so that the interface can forward voice and data flows.

[HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 500  //Configure the default VLAN ID as 500. Then GE0/0/1 adds VLAN 500 to received packets so that packets are forwarded in VLAN 500.

[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 500  //The switch is configured to remove VLAN 500 from packets sent by GE0/0/1so that downlink devices receive untagged packets.

[HUAWEI-GigabitEthernet0/0/1] quit

 

   Step 3      Configure MAC address-based VLAN assignment to add the VLAN ID to voice packets and change the 802.1p priority of packets.

[HUAWEI] vlan 300

[HUAWEI-vlan300] mac-vlan mac-address 00e0-bb00-1234 ffff-ff00-0000 priority 5  //Configure the switch to add VLAN 300 to packets with the source MAC address of 00e0-bbXX-XXXX, and to change the 802.1p priority to 5.

[HUAWEI-vlan300] quit 

[HUAWEI] interface gigabitethernet 0/0/1

[HUAWEI-GigabitEthernet0/0/1] mac-vlan enable  //Enable MAC address-based VLAN assignment on the interface. Configure the interface to add VLAN 300 to packets with the source MAC address of 00e0-bbXX-XXXX, and to change the 802.1p priority to 5.

[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 300  //Add GE0/0/1 to VLAN 300 bound to the MAC address in untagged mode so that GE0/0/1 removes VLAN 300 from voice packets.

[HUAWEI-GigabitEthernet0/0/1] quit

 

   Step 4      Configure the uplink interface to transparently transmit voice flows and data flows.

[HUAWEI] interface gigabitethernet 0/0/2

[HUAWEI-GigabitEthernet0/0/2] port link-type trunk  //Configure the link type of the interface as trunk so that the interface can transparently transmit VLAN packets.

[HUAWEI-GigabitEthernet0/0/2] port trunk allow-pass vlan 300 500

[HUAWEI-GigabitEthernet0/0/2] quit

 

   Step 5      Verify the configuration.

l   Run the display mac-vlan mac-address all command to check whether the configuration of MAC address-based VLAN assignment is correct.

[HUAWEI] display mac-vlan mac-address all                                                    

---------------------------------------------------

MAC Address     MASK            VLAN    Priority                               

---------------------------------------------------

00e0-bb00-1234    ffff-ff00-0000       300     5

                                                                               

Total MAC VLAN address count: 1

 

l   The VoIP service is normal. Check the MAC address entry of the IP phone. The VLAN ID in the MAC address entry is 300.

[HUAWEI] display mac-address 00e0-bb00-1234

-------------------------------------------------------------------------------

MAC Address    VLAN/VSI      Learned-From        Type      

-------------------------------------------------------------------------------

00e0-bb00-1234 300/-           GE0/0/1             dynamic    

                                                                                

-------------------------------------------------------------------------------

Total items displayed = 1

1.7 Configuration Files

#

sysname HUAWEI

#

vlan batch 300 500

#

vlan 300

 mac-vlan mac-address 00e0-bb00-1234 ffff-ff00-0000 priority 7

#

interface GigabitEthernet0/0/1

port link-type hybrid

  port hybrid pvid vlan 500

port hybrid untagged vlan 300 500

  mac-vlan enable

#

interface GigabitEthernet0/0/2

port link-type trunk

  port trunk allow-pass vlan 300 500

#

return

 

1.8 Summary

l   Modular switches in V200R003C00 and later versions provide MAC address-based VLAN assignment based on masks, whereas modular switches in versions earlier than V200R003C00 provide MAC address-based VLAN assignment using the following method only. If there are multiple voice devices, you need to perform the configuration one by one.

[HUAWEI] vlan 300

[HUAWEI-vlan300] mac-vlan mac-address 00e0-bb00-1234 priority 5  //Configure the device to add VLAN 300 to packets with the source MAC address of 00e0-bb00-1234 and to change the 802.1p priority to 5.

[HUAWEI-vlan300] quit  

 

l   If uplink interface GE0/0/2 is located on the LE0MG24SA or LE0MG24CA of the S9300, ES0D0G24SA00 or ES0D0G24CA00 of the S7700, or EH1D2G24SSA0 or EH1D2S24CSA0 of the S9700, the 802.1p priority cannot be changed to 5.

 

      ★★★Summary★★★ All About Huawei Switch Features and Configurations

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

Created Sep 24, 2015 15:59:40 Helpful(1) Helpful(1)

Tanks, Good.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top