[All About Switches] Example of Connecting an S Series Switch to an IP Phone Usi

Latest reply: Aug 23, 2016 19:50:51 2975 1 1 0
 

1.1 Overview of Voice VLAN

Voice VLAN technology of Huawei switches can assign VLAN IDs to voice flows and modify 802.1p and DSCP priorities of voice flows. Voice VLAN technology can assign a VLAN as a voice VLAN, and can allocate voice VLANs to voice devices only through LLDP, DHCP, or HDP.

In earlier versions of V200R003C00, Voice VLAN technology can identify a voice flow based on only the source MAC address in a packet and then increase the priority of the packet. In V200R003C00 and later versions, Voice VLAN technology can identify a voice flow based on the source MAC address and VLAN ID in a packet. By default, Voice VLAN technology identifies a voice flow based on the VLAN ID.

1.2 Applicable Version and Model

Version and Model

IP Phone Model

All versions and models

A voice VLAN can be configured manually or through protocols. However, the 802.1p priority in a packet cannot be set to 5.

 

In this document, V200R006C00 is used as an example. The version differences will be described in this section 1.8 Summary.

1.3 Networking Requirements

Voice data flows of HSI, VoIP, and IPTV services are transmitted on a network. Users require high quality of the VoIP service; therefore, voice data flows must be transmitted with a high priority. A voice device has obtained a voice VLAN ID through manual configuration or LLDP/DHCP. However, when network congestion occurs, the VoIP service may still be delayed or interrupted. Through packet obtaining, the default 802.1p priority in voice packets forwarded by the voice device is 0.

[All About Switches] Example of Connecting an S Series Switch to an IP Phone Usi-1292557-1

1.4 Data Plan

VLAN plan: Voice flows (VoIP) are transmitted in VLAN 300 and data flows (HIS and IPTV) are transmitted in VLAN 500.

1.5 Configuration Roadmap

The configuration roadmap is as follows:

l   Create VLANs for voice and data flows.

l   Configure the voice VLAN function, and change the 802.1p priority of packets to 5 and the DSCP priority of packets to 46. In addition, configure the switch to identify voice flows based on the voice VLAN ID.

1.6 Procedure

   Step 1      Create VLANs for voice and data flows on the switch.

<HUAWEI> system-view

[HUAWEI] vlan batch 300 500

 

   Step 2      Configure the link type of an interface and PVID. Add the interface to a voice VLAN.

[HUAWEI] interface gigabitethernet 0/0/1

[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid  //Configure the link type of a switch interface connected to an IP phone as hybrid so that the interface can forward voice and data flows.

[HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 500  //Configure the default VLAN ID as 500. Then GE0/0/1 adds VLAN 500 to received packets so that packets are forwarded in VLAN 500.

[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 500  //The switch is configured to remove VLAN 500 from packets sent by GE0/0/1so that downlink devices receive untagged packets.

 

   Step 3      Configure the voice VLAN function on the interface and increase 802.1p and DSCP priorities of voice packets based on VLAN IDs.

[HUAWEI] interface gigabitethernet 0/0/1

[HUAWEI-GigabitEthernet0/0/1] voice-vlan 300 enable  //By default, a priority is increased based on VLAN IDs, so there is no need to configure priority re-marking.

[HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 300  //Add an interface to a voice VLAN so that the interface can forward voice flows.

[HUAWEI-GigabitEthernet0/0/1] quit

[HUAWEI] voice-vlan remark 8021p 5   //By default, the 802.1p priority of packets is changed to 6, and the DSCP priority of packets is changed to 46. Run this command to change the 802.1p priority to 5. The DSCP priority remains unchanged.

 

   Step 4      Configure the uplink interface to transparently transmit voice flows and data flows.

[HUAWEI] interface gigabitethernet 0/0/2

[HUAWEI-GigabitEthernet0/0/2] port link-type trunk  //Configure the link type of the interface as trunk so that the interface can transparently transmit VLAN packets.

[HUAWEI-GigabitEthernet0/0/2] port trunk allow-pass vlan 300 500

[HUAWEI-GigabitEthernet0/0/2] quit

 

   Step 5      Verify the configuration.

l   Run the display voice-vlan 300 status command to check whether the configuration of the voice VLAN is correct.

[HUAWEI] display voice-vlan 300 status

Voice VLAN Configurations:

---------------------------------------------------

Voice VLAN ID           : 300

Voice VLAN status        : Enable

Voice VLAN 8021p remark  : 5

Voice VLAN dscp remark   : 46

-----------------------------------------------------------

Port Information:

----------------------------------------------------------------------------------------------Port               Add-Mode  Security-Mode  Legacy  PribyVLAN  Untag  

----------------------------------------------------------------------------------------------

GigabitEthernet0/0/1  Manual    Normal        Disable  Enable      Disable                               

 

 

l   The VoIP service is normal. Check the MAC address entry of the IP phone. The VLAN ID in the MAC address entry is 300.

[HUAWEI] display mac-address 00e0-bb00-1234

-------------------------------------------------------------------------------

MAC Address    VLAN/VSI      Learned-From        Type      

-------------------------------------------------------------------------------

00e0-bb00-1234 300/-           GE0/0/1             dynamic    

                                                                               

-------------------------------------------------------------------------------

Total items displayed = 1

 

1.7 Configuration Files

#

sysname HUAWEI

#

vlan batch 300 500

#

dhcp enable

#

voice-vlan remark 8021p 5

#

interface GigabitEthernet0/0/1

port link-type hybrid

 voice-vlan 300 enable

 port hybrid pvid vlan 500

 port hybrid tagged vlan 300

 port hybrid untagged vlan 500

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 300 500

#

return

 

1.8 Summary

l   V200R003C00 optimizes the voice VLAN function.

Difference

Earlier Versions of V200R003C00

V200R003C00 and Later Versions

Default configuration

1.    Voice VLAN technology can identify voice packets based on only MAC addresses.

2.    By default, an interface works in automatic or security mode. (An interface joins a VLAN automatically. The interface only processes packets with the matched source MAC address and discards other packets.)

1.    Voice VLAN technology identifies voice packets based on VLAN IDs.

2.    By default, an interface works in manual or common mode. (An interface is added to a VLAN manually through commands. The interface can forward other packets in addition to voice packets.)

Other functions

In automatic mode, an interface can join a voice VLAN automatically, and is removed from a voice VLAN when the aging time is reached.

In automatic mode, an interface joins a voice VALN automatically; however, the interface cannot be removed from the voice VLAN automatically. The aging time is not supported.

 

l   If the priority is changed based on the source MAC address, modify the configuration in step 3.

[HUAWEI] interface gigabitethernet 0/0/1

[HUAWEI-GigabitEthernet0/0/1] voice-vlan 300 enable

[HUAWEI-GigabitEthernet0/0/1] voice-vlan remark-mode mac-address  //Configure the switch to identify voice flows based on the MAC address.

[HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 300

[HUAWEI-GigabitEthernet0/0/1] quit

[HUAWEI] voice-vlan remark 8021p 5

[HUAWEI] voice-vlan mac-address 00e0-bb00-0000 mask ffff-ff00-0000  //You must configure this command when the switch identifies voice flows based on the source MAC address. This MAC address is the MAC address of a voice device.

 

l   If voice VLANs are obtained through LLDP, enable LLDP globally.

[HUAWEI] lldp enable

 

      ★★★Summary★★★ All About Huawei Switch Features and Configurations

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

Created Sep 24, 2015 07:59:14 Helpful(1) Helpful(1)

Thanks, Good.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top