after configure ERPS, the ring is working linear

Created Apr 28, 2018 17:54:52 585 0 0 0

Abstract

1. In normal operation Gig 0/0/2 port is in Forwarding state and Gig 1/0/2 port is in Discarding state BUT whole ring becomes unreachable.

2. When manually shutdown Gig 0/0/2 port, then Gig 1/0/2 port goes in forwarding state and ring becomes reachable.

3. When Gig 1/0/2 port goes in Discarding state then again whole ring becomes unreachable.

Issue Description

1.  In normal operation Gig 0/0/2 port is in Forwarding state and Gig 1/0/2 port is in Discarding state BUT whole ring becomes unreachable.
2.  When manually shutdown Gig 0/0/2 port, then Gig 1/0/2 port goes in forwarding state and ring becomes reachable. 
3.  When Gig 1/0/2 port goes in Discarding state then again whole ring becomes unreachable.

below is the topo:

1d16b726315a4841bf58cb90fd0b6744

Handling Process

from our checking, customer configure ACL 4001 and apply it in system view. the last rule is set "rule permit"

acl name MAC 4001 <?xml:namespace prefix = "o" />

 description for MAC ACL

 rule 5 deny destination-mac 0180-c200-0000

 rule 10 deny destination-mac 0180-c200-0001

 rule 15 deny destination-mac 0180-c200-0002

 rule 20 deny destination-mac 0180-c200-0003

 rule 25 deny destination-mac 0100-0c00-0000

 rule 30 deny destination-mac 0100-0ccc-cccc

 rule 35 deny destination-mac 0100-0ccd-cdd0

 rule 40 deny destination-mac 0100-0ccc-cccd

 rule 45 deny destination-mac 0100-0ccd-cdce

 rule 1000 permit

The device is S5300-LI which using marvel chip, there is some wrong with the implementation mechanism. When match the permit rule, then will not transmit the ERPS message.

And as our checking, customer  just apply the acl 4001 in system view, other acl not apply in system view. so only this ACL will affect the ERPS service.

Root Cause

this issue is due to device named “pune-dig-cha-jaytub-r2-eas04” not transmit the ERPS message, so ring is unreachable when G0/0/2 port is in Forwarding state and G1/0/2 port is in Discarding state.

The device is S5300-LI which use marvel chip, there is some wrong with the implementation mechanism. When match the permit rule, then will not transmit the ERPS message.

Solution

with customer confirmation, the ACL 4001 is useless. so after removing the traffic-filter inbound with acl 4001 in system view. the ERPS works fine

 

 

 

 

 

 

 

  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top