Got it

A mesh network example on eNSP

Latest reply: Jun 7, 2014 21:49:06 7268 4 1 0 0

Hi!


This post is about a mesh network example on eNSP. Please see more details below.


eNSP


ISSUE DESCRIPTION


Can anyone help me with configuring a simple wireless mesh network on eNSP similar to the netowrk diagram I have attached?


POSSIBLE SOLUTION


I have tried using similar configurations to what is described in the manuals, but have not got it to work.


Thanks for assisting me with a mesh network example on eNSP!


Sanjay Reddy

This article contains more resources

You need to log in to download or view. No account? Register

x
  • x
  • convention:

AtlasGentech
Created May 28, 2014 20:23:05

Thanks,


I understand the above small/medium/large scale network and have access to the document.


My question was setting up a wireless mesh network - I have also setup a WDS network but unable to get the mesh working using the example in the manual.

View more
  • x
  • convention:

MauroLatam
Created Jun 7, 2014 21:49:06

AS far as I know, Wireless Mesh is not supported on eNSP. Just ESS and WDS.



View more
  • x
  • convention:

oyshuo
Created May 28, 2014 01:46:50

Example for Configuring WLAN Services on a Small-Scale Network (IPv4 Network)


Networking Requirements

As shown in Figure 1, the AP is directly connected to the AC. An enterprise branch needs to deploy WLAN services for mobile office so that branch users can access the enterprise internal network from anywhere at any time.

The following requirements must be met:
  • A WLAN named test is available.
  • Branch users are assigned IP addresses on 192.168.11.0/24.
Figure 1 WLAN service configuration networking on a small-scale network
A mesh network example on eNSP-1547587-1

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the AP, AC, and upstream device to implement Layer 2 interconnection.
  2. Configure the AC as a DHCP server to assign IP addresses to STAs and the AP from an IP address pool of an interface.
  3. Configure AC system parameters, including the country code, AC ID, carrier ID, and source interface used by the AC to communicate with the AP.
  4. Set the AP authentication mode and add the AP to an AP region.
  5. Configure a VAP and deliver VAP parameters to the AP so that STAs can access the WLAN.
    1. Configure a WMM profile and radio profile on the AP, retain the default settings of the WMM profile and radio profile, bind the WMM profile to the radio profile to enable STAs to communicate with the AP.
    2. Configure a WLAN-ESS interface so that radio packets can be sent to the WLAN service module after reaching the AC.
    3. Configure a security profile and traffic profile on the AP, retain the default settings of the security profile and traffic profile, configure a service set, bind the WLAN-ESS interface, security profile, and traffic profile to apply security policies and QoS policies to STAs.
    4. Configure a VAP and deliver VAP parameters to the AP so that STAs can access the Internet through the WLAN.

Procedure

  1. Configure the AC so that the AP and AC can transmit CAPWAP packets.

    # Configure the AC: add interface GE0/0/1 to management VLAN 100.

    A mesh network example on eNSP-1547587-2 NOTE:

    In this example, tunnel forwarding is used. If direct forwarding is used, configure port isolation on GE0/0/1 that connects the AC to the AP. If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

    In tunnel forwarding mode, management VLAN and service VLAN must be different.

    <AC6605> system-view [AC6605] sysname AC [AC] vlan batch 100 101 [AC] interface gigabitethernet 0/0/1 [AC-GigabitEthernet0/0/1] port link-type trunk [AC-GigabitEthernet0/0/1] port trunk pvid vlan 100 [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 [AC-GigabitEthernet0/0/1] quit 


  2. Configure the AC to communicate with the upstream device.

    A mesh network example on eNSP-1547587-3 NOTE:

    Configure AC uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AC uplink interface GE0/0/2 to service VLAN 101.

    [AC] interface gigabitethernet 0/0/2 [AC-GigabitEthernet0/0/2] port link-type trunk [AC-GigabitEthernet0/0/2] port trunk allow-pass vlan 101 [AC-GigabitEthernet0/0/2] quit 


  3. Configure the AC as a DHCP server to allocate IP addresses to STAs and the AP.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    [AC] dhcp enable [AC] interface vlanif 100 [AC-Vlanif100] ip address 192.168.10.1 24 [AC-Vlanif100] dhcp select interface [AC-Vlanif100] quit [AC] interface vlanif 101 [AC-Vlanif101] ip address 192.168.11.1 24 [AC-Vlanif101] dhcp select interface [AC-Vlanif101] quit 


  4. Configure AC system parameters.

    # Configure the country code.

    [AC] wlan ac-global country-code cn Warning: Modify the country code may delete configuration on those AP which use 
    the global country code and reset them, continue?[Y/N]:y

    # Configure the AC ID and carrier ID.

    [AC] wlan ac-global ac id 1 carrier id other

    # Configure the source interface.

    [AC] wlan [AC-wlan-view] wlan ac source interface vlanif 100


  5. Manage the AP on the AC.

    # Check the AP type ID after obtaining the MAC address of the AP.

    [AC-wlan-view] display ap-type all  All AP types information:     
      ------------------------------------------------------------------------------
      ID     Type                   
      ------------------------------------------------------------------------------
      17     AP6010SN-GN 19 AP6010DN-AGN 21     AP6310SN-GN            
      23     AP6510DN-AGN           
      25     AP6610DN-AGN           
      27     AP7110SN-GN            
      28     AP7110DN-AGN           
      29     AP5010SN-GN            
      30     AP5010DN-AGN           
      31     AP3010DN-AGN           
      33     AP6510DN-AGN-US        
      34     AP6610DN-AGN-US  35     AP5030DN               
      36     AP5130DN               
      38     AP2010DN  ------------------------------------------------------------------------------
      Total number: 15 

    # Add the AP offline based on the AP type ID. Assume that the AP type is AP6010DN-AGN, and the MAC address of the AP is 60de-4476-e360.

    [AC-wlan-view] ap-auth-mode mac-auth [AC-wlan-view] ap id 0 type-id 19 mac 60de-4476-e360 [AC-wlan-ap-0] quit
    A mesh network example on eNSP-1547587-4 NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap-auth-mode mac-auth command.

    # Configure an AP region and add the AP to the AP region.

    [AC-wlan-view] ap-region id 10 [AC-wlan-ap-region-10] quit [AC-wlan-view] ap id 0 [AC-wlan-ap-0] region-id 10 [AC-wlan-ap-0] quit

    # After powering on the AP, run the display ap all command on the AC to check the AP running status. The command output shows that the AP status is normal.

    [AC-wlan-view] display ap all  All AP information:           
      Normal[1],Fault[0],Commit-failed[0],Committing[0],Config[0],Download[0]       
      Config-failed[0],Standby[0],Type-not-match[0],Ver-mismatch[0]  ------------------------------------------------------------------------------
      AP    AP               AP              Profile   AP              AP           
                                             /Region                                
      ID    Type             MAC             ID        State           Sysname      
      ------------------------------------------------------------------------------
      0     AP6010DN-AGN     60de-4476-e360  0/10 normal ap-0         
      ------------------------------------------------------------------------------
      Total number: 1,printed: 1 


  6. Configure WLAN service parameters.

    # Create a WMM profile named wmm.

    [AC-wlan-view] wmm-profile name wmm id 1 [AC-wlan-wmm-prof-wmm] quit 

    # Create a radio profile named radio and bind the WMM profile wmm to the radio profile.

    [AC-wlan-view] radio-profile name radio id 1 [AC-wlan-radio-prof-radio] wmm-profile name wmm [AC-wlan-radio-prof-radio] quit [AC-wlan-view] quit

    # Create WLAN-ESS interface 1.

    [AC] interface wlan-ess 1 [AC-Wlan-Ess1] port hybrid pvid vlan 101 [AC-Wlan-Ess1] port hybrid untagged vlan 101 [AC-Wlan-Ess1] quit

    # Create a security profile named security.

    [AC] wlan [AC-wlan-view] security-profile name security id 1 [AC-wlan-sec-prof-security] quit

    # Create a traffic profile named traffic.

    [AC-wlan-view] traffic-profile name traffic id 1 [AC-wlan-traffic-prof-traffic] quit

    # Create a service set named test and bind the WLAN-ESS interface, security profile, and traffic profile to the service set.

    [AC-wlan-view] service-set name test id 1 [AC-wlan-service-set-test] ssid test [AC-wlan-service-set-test] wlan-ess 1 [AC-wlan-service-set-test] security-profile name security [AC-wlan-service-set-test] traffic-profile name traffic [AC-wlan-service-set-test] service-vlan 101 [AC-wlan-service-set-test] forward-mode tunnel [AC-wlan-service-set-test] quit


  7. Configure a VAP and deliver VAP parameters to the AP.

    # Configure a VAP.

    [AC-wlan-view] ap 0 radio 0 [AC-wlan-radio-0/0] radio-profile name radio [AC-wlan-radio-0/0] service-set name test [AC-wlan-radio-0/0] quit

    # Commit the configuration.

    [AC-wlan-view] commit ap 0 Warning: Committing configuration may cause service interruption,continue?[Y/N
    ]y


  8. Verify the configuration.

    After the configuration is complete, run the display vap ap 0 radio 0 command. The command output shows that the VAP has been created.

    [AC-wlan-view] display vap ap 0 radio 0 All VAP Information(Total-1):                                                 
      SS: Service-set     BP: Bridge-profile     MP: Mesh-profile                   
      ----------------------------------------------------------------------        
      AP ID  Radio ID  SS ID  BP ID  MP ID  WLAN ID  BSSID           Type           
      0      0         1      -      -      1        60DE-4476-E360  service        
      ----------------------------------------------------------------------
      Total: 1 

    STAs discover the WLAN with SSID test and attempt to associate with the WLAN. You can run the display station assoc-info command on the AC. The command output shows that the STAs associate with the WLAN test.

    [AC-wlan-view] display station assoc-info ap 0 radio 0 ------------------------------------------------------------------------------  STA MAC          AP ID   RADIO ID  SS ID    SSID  ------------------------------------------------------------------------------
      9021-55dc-3e17   0       0         1        test
      ------------------------------------------------------------------------------
      Total stations: 1


Configuration Files

  • Configuration file of the AC

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
     wlan ac-global carrier id other ac id 1
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 192.168.10.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 192.168.11.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface Wlan-Ess1
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    wlan
     wlan ac source interface vlanif100
     ap-region id 10
     ap id 0 type-id 19 mac 60de-4476-e360 sn 210235419610CB002287
      region-id 10
     wmm-profile name wmm id 1
     traffic-profile name traffic id 1
     security-profile name security id 1
     service-set name test id 1
      forward-mode tunnel
      wlan-ess 1
      ssid test
      traffic-profile id 1
      security-profile id 1
      service-vlan 101
     radio-profile name radio id 1
      wmm-profile id 1
     ap 0 radio 0
      radio-profile id 1
      service-set id 1 wlan 1
    #
    return     
View more
  • x
  • convention:

oyshuo
Created May 28, 2014 01:48:12

you can access to our website to obtain document.

http://support.huawei.com/ehedex/hdx.do?docid=DOC1000044693&lang=en

 

View more
  • x
  • convention:

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.
Information Protection Guide
Thanks for using Huawei Enterprise Support Community! We will help you learn how we collect, use, store and share your personal information and the rights you have in accordance with Privacy Policy and User Agreement.