Use MUX VLAN to manage a device with only one vlanif from 2 different VLAN's

Created Apr 01, 2017 11:33:59Latest reply Apr 11, 2018 22:31:36 1054 5 0 0

This KB help you to manage a device that can support only one VLANif interface from 2 different vlan's.

This scenario can ocure when for example there are 2 companies and one company (ISP) buy a part of the network infrastructure of another company and during transition period both company need to manage same devices.<?xml:namespace prefix = "o" />

If company A use management VLAN 4093 and company B use management VLAN 400 and company B buy a part of network infrastructure of company A and among the devices some of them don't support multiple VLANif interfaces - for example:
S2750EI/S5700LI/S5700S-LI: earlier versions of V200R005 (support only 1 VLANif interface) - then we can use MUX VLAN to configure VLAN 4093 as the "Principal VLAN" and VLAN 400 as "Subordinate VLAN".

This article contains more resources

You need to log in to download or view. No account?Register

x
  • x
  • convention:

ms.america     Created Apr 01, 2017 14:22:45 Helpful(0) Helpful(0)

vlan 4093                                                                      
mux-vlan                                                                      
subordinate group 400



interface GigabitEthernet0/0/8                                                 
<?xml:namespace prefix = "o" />

port ink-type access                                                         

port default vlan 400                                                         

port mux-vlan enable vlan 400


Remember you have to enable mux-vlan function on each transit interface, for example if you
have one more switch to reach managed device and you have a trunck interface between, then you have to enable on it also.



transparent.gif Solution

Create both VLAN

#

vlan batch 4093 400


Assign first and second ip to VLANif interface:


interface Vlanif4093 

ip address 10.10.2.205 255.255.252.0

ip address 10.2.10.15 255.255.252.0 sub


Configure Principal and subordinate VLAN:

#                                                                              

vlan 4093                                                                      

mux-vlan                                                                      

subordinate group 400


Enable mux-vlan function on subordinate VLAN interface and on transit interfaces if there are any.

#                                                                              
interface GigabitEthernet0/0/8                                                 

port link-type access                                                         

port default vlan 400                                                         

port mux-vlan enable vlan 400


Now you should be able to access the device from both VLAN's.

f696ff8127784b5bb3b3a9fc1e101c32

  • x
  • convention:

Btadeu     Created Apr 11, 2018 00:42:19 Helpful(0) Helpful(0)

When configuring mux-vlan you get error msgm: Error: The number of ports added to the MUX-VLAN has the upper limit.
Software Version: VRP (R) Software, Version 5.160 (V200R009C00SPC500)
can you help me. ?
  • x
  • convention:

StarOfWest  Moderator   Created Apr 11, 2018 13:54:10 Helpful(0) Helpful(0)

  • x
  • convention:

“We only get answers to the questions that we ask.” physicist Werner Heisenberg
Btadeu     Created Apr 11, 2018 22:30:43 Helpful(0) Helpful(0)

Posted by b00745015 at 2018-4-11 13:54 Check the link to find out what are the limitation and dependencies associated with MUX VLAN configu ...
Olá, Obrigado pelo retorno.
O erro relatado diz respeito a interface inseridas na vlan separate da configuração de MUX.
Somente consegui adicionar 32 interfaces. Na 33 recebo a msgm de erro.
  • x
  • convention:

Btadeu     Created Apr 11, 2018 22:31:36 Helpful(0) Helpful(0)

Posted by Btadeu at 2018-4-11 22:30 Olá, Obrigado pelo retorno.O erro relatado diz respeito a interface inseridas na vlan separate da ...
Sorry, now english.
Hello, Thanks for the feedback.
The reported error relates to the interface inserted in the vlan separate of the MUX configuration.
I was only able to add 32 interfaces. At 33 I get the error msgm.
  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top