Trunk problem

Created: Feb 24, 2014 22:09:24Latest reply: Feb 28, 2014 14:18:20 2572 2 0 0
One of my edge Huawei S5700-28C-EI stack switches  is dead, I am going to replace it with a Cisco switch Catalyst 3750 series PoE-48 via a trunk link  with GE fiber port on both ends, please see the diagram below.
                                  trunk                     trunk
   Core switchrouter<----------S5700<--------------->Cisco Catlyst 3750


I haven’t touch Cisco switch for many years, I would like to ask the following questions:

1.)      Do I need to take any precaution before connecting this Cisco switch into my Huawei network? Only one link between S5700 and C3750, so I don't need worry anout STP? Do I need to worry about Default vlan regarding trunking port?

2.)      I need to use different trucking protocol e.g. 802.1Q etc to interconnect these two switches (S5700 and Catalyst 3750), please see the following configuration:


For S5700:

 port link-type trunk
 port trunk permit vlan all


For WS-C3750X-24T-L:


switchport trunk encapsulation dot1q
switchport trunk native vlan (What you want)
switchport trunk allowed vlan (VLANs required)
switchport mode trunk
spanning-tree portfast trunk


Do you think the configurations above are right?

Do I need to manually enter Duplex and speed options ?       

3.)If the configurations are not right, then what are the commands for trucking port/link should I use on the Cisco switch (it uses IOS software) and Huawei switch?  Procedures of the commands would be really helpful !

Any information and help would be much appreciated.

  • x
  • convention:

Sophoni     Created Feb 28, 2014 14:18:20 Helpful(0) Helpful(0)

http://forum.huawei.com/enterprise/thread-300305.html

 

for your reference.

 

hw

[Quidway] interface GigabitEthernet1/0/1

[Quidway-GigabitEthernet1/0/1] port link-type trunk

[Quidway-GigabitEthernet1/0/1] port trunk allow vlan 2 to 10

 

cisco

 

Cisco(config)# interface GigabitEthernet1/0/1

Cisco(config-if)# switchport trunk encapsulation dot1q

Cisco(config-if)# switchport mode trunk

Cisco(config-if)# switchport trunk allowed vlan 2-10

 

  • x
  • convention:

Gabo Created Aug 4, 2018 03:46:02
Nice, The trunk link allow pass the vlans other way will not be possible to reach the vlans.  

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top