[Troubleshooting Series] Case 48 Direct connection devices cannot ping successfully

Created Jan 29, 2019 09:04:55 345 0 0 0


Physical Network Topology

As shown in the figure, two CE12800 directly connected devices, two different IP addresses are configured on device A, and the directly connected IP address is configured on device B.

Figure 1-1 Direct connection devices cannot ping successfully

090046ce97wmpgwrfpg343.png

 

Fault Description

The device A can ping device B as follows:

[~R4U13-CE12800] ping  102.1.1.101
PING 102.1.1.101: 56  data bytes, press CTRL_C to break
Reply from 102.1.1.101: bytes=56 Sequence=1 ttl=254 time=2 ms
Reply from 102.1.1.101: bytes=56 Sequence=2 ttl=254 time=2 ms 

When the source IP address is an interface IP address on the device A, the ping cannot be pinged. The details are as follows:

[~R4U13-CE12800] ping -a 102.1.1.1 102.1.1.101
PING 102.1.1.101: 56  data bytes, press CTRL_C to break
Request time out
Request time out
Request time out
Request time out
Request time out
--- 102.1.1.101 ping statistics ---
5 packet(s) transmitted
0 packet(s) received
100.00% packet loss

Configuration Files

dfs-group 1
 source ip 10.1.1.1 
#
ip vpn-instance huawei-1
 ipv4-family 
#
ip vpn-instance huawei-2
 ipv4-family 
#
ip vpn-instance huawei-3
 ipv4-family 
#
bridge-domain 10
 vxlan vni 5010
#            
interface Vlanif100
 ip binding vpn-instance huawei-1
 ip address 100.1.1.2 255.255.255.0
#
interface Vlanif200
 ip binding vpn-instance huawei-2
 ip address 101.1.1.2 255.255.255.0
#
interface Vlanif300
 ip binding vpn-instance huawei-3
 ip address 102.1.1.101 255.255.255.248
#
interface Vlanif1000
 ipv6 enable
 ip address 100.100.1.102 255.255.255.0
 ipv6 address 1000:1000::102/64
 ipv6 address auto link-local
 vrrp vrid 1 virtual-ip 100.100.1.101
 vrrp6 vrid 2 virtual-ip FE80::1 link-local
 vrrp6 vrid 2 virtual-ip 1000:1000::1000
#           
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#
interface 10GE2/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 200 300
 device transceiver 10GBASE-FIBER
#
interface 10GE2/0/20
 eth-trunk 10
 device transceiver 10GBASE-FIBER
#
interface 10GE2/0/22
 eth-trunk 1
 device transceiver 10GBASE-FIBER
#
interface LoopBack1
 ip address 5.5.5.5 255.255.255.255
#
interface Nve1
 source 5.5.5.5
 vni 5010 head-end peer-list 1.1.1.1
#
bgp 10088
 peer 102.1.1.1 as-number 10086
 #
 ipv4-family unicast
  preference 20 20 255
  import-route direct  
  peer 102.1.1.1 enable
 #
 ipv4-family vpn-instance huawei-1
  peer 100.1.1.1 as-number 10086
 #
 ipv4-family vpn-instance huawei-2
  peer 101.1.1.1 as-number 10086
 #
 ipv4-family vpn-instance huawei-3
  peer 102.1.1.1 as-number 10086
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0
  network 5.5.5.5 0.0.0.0
  network 102.1.1.0 0.0.0.255

Troubleshooting Procedure

                               Step 1      View the routing table and ARP entries in this segment. The data is normal. The details are as follows:

[~R4U13-CE12800] dis ip routing-table 102.1.1.101
Proto: Protocol        Pre: Preference
Route Flags: R - relay, D - download to fib, T - to vpn-instance
------------------------------------------------------------------------------
Routing Table : _public_
Summary Count : 1
Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
102.1.1.96/29  Direct  0    0             D   102.1.1.100     Vlanif300
[~R4U13-CE12800]
[~R4U13-CE12800]dis arp | in 102.1.1.101
ARP Entry Types: D - Dynamic, S - Static, I - Interface
EXP: Expire-time
IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
------------------------------------------------------------------------------
102.1.1.101     200b-c73c-9337   13   D/300     10GE1/0/1
------------------------------------------------------------------------------
Total:52         Dynamic:40       Static:0    Interface:12

                               Step 2      The packet can be sent out normally from the interface, but there is no return packet, as follows:

<R4U13-CE12800> dis int 10g 1/0/1
10GE1/0/1 current state : UP (ifindex: 64)
Line protocol current state : UP
Description:
Switch Port, PVID :    1, TPID : 8100(Hex), The Maximum Frame Length is 9216
Internet protocol processing : disabled
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 200b-c73c-9301
Port Mode:     COMMON FIBER,     Port Split:                   DISABLE
Speed:                10000,     Loopback:                        NONE
Duplex:                FULL,     Negotiation:                  DISABLE
Input Flow-control: DISABLE,     Output Flow-control:          DISABLE
Mdi:                      -#goback
Last physical up time   : 2018-07-02 08:37:22+02:00
Last physical down time : 2018-07-02 08:34:32+02:00
Current system time: 2018-08-20 13:28:48+02:00
Statistics last cleared:2018-08-20 13:28:28+02:00
Last 300 seconds input rate: 148 bits/sec, 0 packets/sec
Last 300 seconds output rate: 367 bits/sec, 0 packets/sec
Input peak rate 148 bits/sec, Record time: 2018-08-20 13:28:48+02:00
Output peak rate 367 bits/sec, Record time: 2018-08-20 13:28:48+02:00
Input :                536 bytes,                  3 packets
Output:               1383 bytes,                 10 packets
Input:
Unicast:                      2,   Multicast:                       1
Broadcast:                    0,   Jumbo:                           0
Discard:                      0,   Frames:                          0
Pause:                        0
 
Total Error:                  0
CRC:                          0,   Giants:                          0
Jabbers:                      0,   Fragments:                       0
Runts:                        0,   DropEvents:                      0
Alignments:                   0,   Symbols:                         0
Ignoreds:                     0
Output:
Unicast:                      7,   Multicast:                       3
Broadcast:                    0,   Jumbo:                           0
Discard:                      0,   Buffers Purged:                  0
Pause:                        0
Input bandwidth utilization threshold : 90.00%
Output bandwidth utilization threshold: 90.00%
Last 300 seconds input utility rate:  0.01%
Last 300 seconds output utility rate: 0.01%

From the current port count, the message has been sent, but the message has not returned.

                               Step 3      Query the routing entries of the peer device, as follows:

[~R4U13-CE12800-SWITCH-A] dis ip routing-table vpn-instance huawei-3 102.1.1.1
[~R4U13-CE12800-SWITCH-A]

The routing entry does not exist. Add the corresponding routing entry:

[~R4U13-CE12800-SWITCH-A] ip route-static vpn-instance huawei-3 102.1.1.1 255.255.255.248 102.1.1.100

After the routing entry is added, you can ping normally.

[~R4U13-CE12800] ping -a 102.1.1.1 102.1.1.101
PING 102.1.1.101: 56  data bytes, press CTRL_C to break
Reply from 102.1.1.101: bytes=56 Sequence=1 ttl=254 time=3 ms
Reply from 102.1.1.101: bytes=56 Sequence=2 ttl=254 time=2 ms
Reply from 102.1.1.101: bytes=56 Sequence=3 ttl=254 time=2 ms
Reply from 102.1.1.101: bytes=56 Sequence=4 ttl=254 time=1 ms
Reply from 102.1.1.101: bytes=56 Sequence=5 ttl=254 time=3 ms
 
--- 102.1.1.101 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 1/2/3 ms

----End

Root Cause

When the device is pinged with the source IP address, the source IP address and the peer device are not in the same network segment. As a result, packets are sent without a routing entry.

 


  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top