[Troubleshooting Series]Case 2 Error Packets Are Transmitted on Switche, or Interfaces on Switche Connect to PC Alternate Between Up and Down Randomly

Created: Nov 30, 2018 18:42:04Latest reply: Dec 27, 2018 15:49:58 164 1 2 1

troubleshooting series comes again, in today troubleshooting case, we will introduce: Error Packets Are Transmitted on Electrical Interfaces of Switches, or Interfaces on Switches Connected to PCs Alternate Between Up and Down Randomly

Physical Network Topology

Figure 1-1 Network where a fauilre occurs

183453f9w3zinapfi3dap5.png

 

Fault Description

1.         Error packets are transmitted on the switch's electrical interface that works in half-duplex mode through negotiation.

2.         The switch's interface connected to the PC alternates between Up and Down randomly.

Configuration Files

# SwitchA(R10U36-S3700)

#
!Software Version V100R006C05
 sysname R10U36-S3700
#
 vlan batch 20 30 103 220
#
lldp enable
#
acl number 3000
 rule 5 permit icmp source 2.1.1.1 0 destination 1.1.1.1 0
 rule 10 permit icmp source 1.1.1.1 0 destination 2.1.1.1 0
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher %@%@^bs5*JFbe4(a,S9*1RbKTA!$%@%@
 local-user admin privilege level 15
 local-user admin service-type telnet terminal ssh http
#
interface Ethernet0/0/23
 port link-type access
 port default vlan 20
 auto speed 10
#
interface Ethernet0/0/25
#
interface NULL0
#
 ip route-static 0.0.0.0 0.0.0.0 10.220.6.1
#
return

#SwitchB(R10U11-S9706)

!Software Version V200R008C00SPC500
#
sysname R10U11-S9706
#
vlan batch 20
#
lldp enable
#
clock timezone UTC add 00:00:00
#
icmp-reply fast
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password irreversible-cipher %^%#rr]KD+}\>0O"Fx#[|gf+^1<\XP#EtT/S_"IueGEYOhlZ;jkzh=F!N2IWP]<Q%^%#
 local-user admin privilege level 15
 local-user admin service-type terminal ssh http
#
interface Vlanif20
 ip address 1.1.1.1 255.255.255.0
#
interface Eth-Trunk100
#
interface Ethernet0/0/0/0
 ip address 10.220.7.128 255.255.254.0
#
interface GigabitEthernet1/1/1/23
 port link-type access
 port default vlan 20
 undo negotiation auto
 speed 10
#                                         
ip route-static 0.0.0.0 0.0.0.0 10.220.6.1
ip route-static 2.1.1.0 255.255.255.0 1.1.1.2
#
return

Troubleshooting Location

Troubleshooting Procedure

                               Step 1      Check the running status of the Ethernet 0/0/23 which conneted to the SwitchB.

Run the display interface XXX command, and it is found that the interface works in half-duplex mode through auto-negotiation, indicating that the peer end must work in forcible mode.

<HUAWEI> display interface gigabitethernet 0/0/23
Ethernet 0/0/23 current state : UP                                       
Line protocol current state : UP                                              
Description:HUAWEI, Quidway Series, Ethernet0/0/23 Interface                                                                  
Switch Port, PVID :   20, TPID : 8100(Hex), The Maximum Frame Length is 1600
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 38bc-01ec-9520
Port Mode: COMMON COPPER
Speed :   10,  Loopback: NONE
puplex: HALFNegotiation: ENABLE
Mdi   : AUTO
...

Solution:  Modify the auto-negotiation mode on both ends to be consistent.

<R10U11-S9706> system-view
[R10U11-S9706] interface gigabitethernet 1/1/1/23
[R10U11-S9706] negotiation auto

And then it is found that the ethernet interface connected to the PC frequently alternates between up and down states.

                               Step 2      Check the configuration on the PC after confirming that the cable, module, negotiation mode, rate, and device hardware at both ends of the switch are intact.

And then it is found that the WOL function was configured on the PC and the PC enters the standby or sleep state.

Figure 1-2 WOL enabled on the PC

 


  • x
  • convention:

dagui  Visitor   Created Dec 27, 2018 15:49:58 Helpful(0) Helpful(0)

Run the display interface XXX command, and it is found that the interface works in half-duplex mode through auto-negotiation, indicating that the peer end must work in forcible mode.How do you understand this sentence?
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top