Selective QinQ and VLAN mapping not working on the same interface

Created Nov 06, 2018 20:45:42Latest reply Dec 26, 2018 15:27:09 202 2 0 0
Device: S1720-10GW-2P

Version: V200R011C10SPC600

Issue Description

The issue appears to be when the VLAN 10 should be mapped to VLAN 210, actually this is not happening on the LSW4 switch.

86ec898e90c34963b8b3cc52ee27174c


Config LSW4:

!Software Version V200R011C10SPC600

#

vlan batch 10 2010

#

traffic classifier test operator and

 if-match vlan-id 10

#

traffic behavior remark

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 2010

#

interface GigabitEthernet0/0/3

 port link-type hybrid

 qinq vlan-translation enable

 undo port hybrid vlan 1

 port hybrid tagged vlan 10

 port hybrid untagged vlan 2010

 port vlan-stacking vlan 210 stack-vlan 2010

 port vlan-mapping vlan 10 map-vlan 210

#

 

Config LSW3:

!Software Version V200R011C10SPC600

#

vlan batch 2010

#

interface GigabitEthernet0/0/1

 port link-type dot1q-tunnel

 port default vlan 2010

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 2010

#




transparent.gif Handling Process

We have issues a ping from 192.168.2.1 towards 192.168.2.2 and vice versa then we captured packets between switches. In both cases we noticed the ARP being broadcasted without a response. Below is the capture

SW5 to SW4:

5893e382bf0f405596ce0c1dc6c72505

SW4 to SW5:

b1f9688584d24c588ae5accd8995214a

SW3 to SW4:

2937ece84cd74a1aa863901b7771e4ad

SW4 to SW3:

a06c497f98cd4a16a8327d6669f46dd1 


transparent.gif Root Cause

During the tests it has been confirmed that we can’t enable both VLAN mapping and VLAN stacking functions in the same interface.

Starting with version V200R011C10SPC600, there is a new command available that can do both operations in the same command.


transparent.gif Solution

Starting with V200R011C10SPC600 we can enable both VLAN mapping and VLAN stacking functions using the same interface and command.

On LSW4 interface Gi 0/0/3 we configure as follows:

#

interface GigabitEthernet0/0/3

port link-type hybrid

qinq vlan-translation enable

undo port hybrid vlan 1

port hybrid tagged vlan 10

port hybrid untagged vlan 2010

port vlan-stacking vlan 10 stack-vlan 2010 map-vlan 210

#

  • x
  • convention:

xiaomumu  Novice   Created Dec 24, 2018 09:37:22 Helpful(0) Helpful(0)

Learn more, great
  • x
  • convention:

dagui  Novice   Created Dec 26, 2018 15:27:09 Helpful(0) Helpful(0)

port vlan-stacking vlan 210 stack-vlan 2010

port vlan-mapping vlan 10 map-vlan 210
Can you provide a more detailed explanation?
  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top