[Q&A] The NAT is not working on NE20E

Created Jul 20, 2018 17:44:12 260 0 0 0

The problem is that customer configure NAT like below, but when he try to ping from internal, it can't ping, check the NAT session, find that the NAT is not working.

#
service-location 1
 location slot 3
#
service-instance-group Mada
 service-location 1
#
nat instance Mada id 1
 service-instance-group Mada
 nat address-group Mada group-id 1 x.x.x.x x.x.x.y
 nat log session enable
#
acl number 3001
 rule 5 permit ip
#
interface GigabitEthernet0/3/6
 negotiation auto
 undo shutdown
 ip address y.y.y.2 255.255.255.252
 dcn
 nat bind acl 3001 instance Mada
#

#
bgp 65100
 peer y.y.y.1 as-number 47442
 peer y.y.y.y.1 password cipher %^%#yuV/;b"e6<7U/D8FMt.B|n+r/B&n8U/Q{=LMKWKF%^%#
 #
 ipv4-family unicast
  undo synchronization
  peer y.y.y.y.1 enable
#

 

Check the NAT configuration, it is correct;

Check the route and found that the NAT group addresses did not network to the bgp peer, there is no backup route to NAT group address, it lead to the NAT is not working .

 

after network the x.x.x.x under bgp, it is working fine.

 

  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top