Memory leak on quidway S5328C-SI

Created Dec 12, 2013 17:27:24Latest reply Aug 25, 2014 16:21:09 2544 4 0 0

Problem. My switch worked correctly during the year without reboot. Uptime over 52 weeks. But one day I saw that the switch rebooted. About 2 weeks ago. And it would not be a big problem if do not reboot today. I began to understand and noticed that during the operation of free memory leaked. Before reboot sysinfo log contained information, that memory used on 95%.

Monitoring data:

https://dl.dropboxusercontent.com/u/15877830/Screen/forum/huawei.JPG

 

In the documentation there is nothing except display memory-usage. How to define where it goes memory?

Firmware V100R006C00SPC800. Help me please!

 

  • x
  • convention:

StarOfWest  Moderator   Created Dec 13, 2013 09:30:54 Helpful(0) Helpful(0)

Yes, looks like a memory, leak.

How about the cpu-usage? Usually memory leak involves high cpu-usage.

 

Try display cpu-usage, find the task that usually consumes resourse more than usual and it might give you a clue.

I recommand to upgrade the version or at least install the latest patch for your V1R6.

 

PS. Release notes of the patch or new software version shows what problems it solves. You can check for memory leaks.

  • x
  • convention:

kkudryavtsev     Created Dec 13, 2013 14:42:18 Helpful(0) Helpful(0)

Quote 2 #

Yes, looks like a memory, leak.

How about the cpu-usage? Usually memory leak involves high cpu-usage.

 

Try display cpu-usage, find the task that usually consumes resourse more than usual and it might give you a clue.

I recommand to upgrade the version or at least install the latest patch for your V1R6.

 

PS. Release notes of the patch or new software version shows what problems it solves. You can check for memory leaks.

b00745015 Post On 2013-12-13 09:30:54

cpu-usage in normal. 80% VIDLE, 1% FTS, 1% frag_Add, 3% linkscan, OS 15%.


 

  • x
  • convention:

StarOfWest  Moderator   Created Dec 17, 2013 14:08:03 Helpful(0) Helpful(0)

yes, cpu usage is normal. 

I recommend to upgrade your version, as far as I know there is no reference association about memory block and feature module. Somebody need to check the code to see which memory block information is leaking. Some memory blocks may be shared between different feature modules so is quite hard to find the leak. But usually the most convenient way to solve this is to upgrade. 


Of course if you want you can contact TAC, they can provide professional support and find out which module information is leaking :)




  • x
  • convention:

kkudryavtsev     Created Aug 25, 2014 16:21:09 Helpful(0) Helpful(0)

Hello! After update, I have a new problem with memory.

 

I install new update in December 2013. I have not rebooted it. Where again a memory leak? I disabled the web server, but memory is not freed.

Software version V200R003C00SPC300.

  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top