L2TPv3

Created Dec 14, 2017 03:10:26Latest reply Mar 22, 2018 22:07:02 2110 4 0 0
  Rewarded E Coins: 0 (problem resolved)
i need to configure L2TPv3 between huawei router and cisco ,Can anyone help on this ?
  • x
  • convention:

Busy_with_lazy_mind  Moderator   Created Dec 14, 2017 09:26:35 Helpful(1) Helpful(1)

Can works with Cisco using static mode.
for example

Huawei devide:
l2tpv3 enable
#
license active accept agreement
license function datae
#
interface GigabitEthernet0/0/0
undo portswitch
link-bridge Tunnel0/0/1 vc-id 1234 tagged
#
interface GigabitEthernet0/0/1
undo portswitch
ip address 10.10.2.1 255.255.255.0
#
interface Tunnel0/0/1
tunnel-protocol svpn
encapsulation l2tpv3
l2tpv3 local session-id 1
l2tpv3 remote session-id 4
tunnel-source 3.3.3.3
tunnel-destination 10.10.2.2
#

Cisco device:

pseudowire-class HW-device
encapsulation l2tpv3
protocol none
ip local interface Loopback0
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
!
interface GigabitEthernet0/1
ip address 10.10.2.2 255.255.255.0
duplex auto
speed auto
no keepalive
!
interface FastEthernet0/0/0
no ip address
duplex auto
speed auto
xconnect 10.10.2.1 1234 encapsulation l2tpv3 manual pw-class HW-device
l2tp id 4 1

  • x
  • convention:

Waeel     Created Dec 14, 2017 16:32:59 Helpful(0) Helpful(0)

i will try it and feedback , Please also confirm if the source tunnel is correct should not be 10.10.2.1 instead
of 3.3.3.3 ?

interface Tunnel0/0/1
tunnel-protocol svpn
encapsulation l2tpv3
l2tpv3 local session-id 1
l2tpv3 remote session-id 4
tunnel-source 3.3.3.3
tunnel-destination 10.10.2.2
  • x
  • convention:

Waeel     Created Dec 16, 2017 18:51:26 Helpful(0) Helpful(0)

Dear,
thanks for your help , xconnect is up . but one more thing i hope you can help me . why the interface binding to tunnel in huawei router goes to protocol down when i am binding it to tunnel
  • x
  • convention:

StarOfWest  Moderator   Created Mar 22, 2018 22:07:02 Helpful(0) Helpful(0)

Hi,

it's normal to go down, since communication at protocol level is performed through tunnel interface. Please check the tunnel interface protocol status.
  • x
  • convention:

Best answer

“We only get answers to the questions that we ask.” physicist Werner Heisenberg

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top