[Knowledge sharing] How to replace a Cisco switch and connect S switch to ESX server

Created: Sep 29, 2018 16:00:22 317 0 3 0

Hello all,

In this post I share with you the steps required when you want to replace a Cisco Switch with a Huawei switch and which commands are required when you connect the switch to an ESX.


Fault symptom: You want to replace a Cisco switch with a S5720 but you have difficulties when configuring more ports of the switch in LACP mode. The ping is not working.

Version information: V200R010C00SPC600

Operation scenario:

The configuration you used on Cisco which was working ok is the following:

 

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

#

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

#

interface GigabitEthernet1/0/3

description pdsesxi01 Port 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

#

 

The configuration you use on Huawei S5720 :

 

interface Eth-Trunk1

port link-type trunk

port trunk pvid vlan 4

port trunk allow-pass vlan 2 to 4094

mode lacp

#

interface GigabitEthernet0/0/5

description vmesxi-viewR7-01 Port 1

eth-trunk 1

#

interface GigabitEthernet0/0/6

description vmesxi-viewR7-01 Port 2

eth-trunk 1


transparent.gif
Solution:

The solution for this issue is to apply the lacp force-forward command in interface eth-trunk view. The explanation is that before the server obtains the configuration file, Interface1 is an independent physical interface and is not configured with LACP. As a result, LACP negotiation on the switch interface fails and the server cannot communicate with the switch. The switch does not forward traffic on the Eth-Trunk, and the server cannot download the configuration file through Interface1.

To address this issue, run the lacp force-forward command on the Eth-Trunk of the switch. The Eth-Trunk member interface in Up state can still forward data packets even though the remote device is not enabled with LACP.

 c63fe745fd2f43818a2210749983ca46    


 NOTE:

  • When this command is used, although Layer 3 forwarding is not supported the member interface in ForceFwd state can still forward Layer 2 traffic. The ForceFwd state is automatically set when LACP negotiation fails, and cannot be changed manually. Use the display eth-trunk command to check the value of the Status field.
  • This command only applies to the scenario where an Eth-Trunk joins a VLAN as an access, hybrid, trunk, and dot1q-tunnel interfaces.
  • When a spanning tree protocol (for example, STP, RSTP, or MSTP) is used, member interfaces that are in ForceFwd state cannot be blocked. Member interfaces in ForceFwd state can continue to forward data packets. When other loop prevention protocols such as ERPS and RRPP are used, member interfaces that are in ForceFwd state can be blocked. The blocked member interfaces in ForceFwd state cannot forward data packets.
  • This command cannot be used with E-Trunk. That is, this command cannot be used on the Eth-Trunk that joins a E-Trunk.
  • This command cannot be used with max active-linknumber or least active-linknumber.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top