Interoperation Between Huawei Switches and an Microsoft NLB Cluster (Using Multi-Interface ARP)

51 0 0 0

Overview

NLB is developed by Microsoft for a cluster set up by multiple Windows servers. When a switch is connected to an NLB cluster, the switch needs to send packets destined for the cluster IP address to every NLB server in the cluster. An NLB server can work in unicast, multicast, or IGMP multicast mode.

Currently, a switch can be connected to the NLB server working in only unicast or multicast mode. After multi-interface ARP is configured on the switch, the switch can be connected to the NLB servers.

On a device model or in a version that does not support multi-interface ARP, the following methods are available to implement the connection:
  • Add a Layer 2 switch between the switch and NLB servers. (When the NLB servers work in multicast mode, enable dynamic learning of ARP entries with multicast MAC addresses or configure static ARP entries on the switch.) This method can be used when there are sufficient device resources.
  • Use physical link loopback. This method results in complex configuration.

Networking Requirements

As shown in Figure 2-63, the Switch connects to three NLB servers respectively through GE1/0/1GE1/0/2, and GE1/0/3 in VLAN 10. The NLB cluster works in multicast mode. Each server in the NLB cluster has an IP address and a MAC address. All servers in the cluster share the cluster IP address (10.128.246.252/24) and cluster MAC address (03bf-0a80-f6fc). There are reachable routes between the Switch and Client.

The customer requires that the Switch can send the Client's packet destined for the cluster IP address to each server in the NLB cluster.

Figure 2-63  Networking diagram for configuring multi-interface ARP 
imgDownload?uuid=94ecf74579c34f3c9ef415f

Configuration Roadmap

  1. Configure IP addresses for interfaces and add the interfaces to VLANs.
  2. Configure a MAC address entry mapping multiple outbound interfaces and configure a static ARP entry so that the Switch can send the packets destined for the cluster IP address to the three servers in the NLB cluster.

Configuration Notes

  • The VLAN to which an interface is added cannot be a MAC VLAN, super VLAN, leased line VLAN, MUX VLAN on the X series cards, and control VLAN of Smart Ethernet Protection (SEP) and Rapid Ring Protection Protocol (RRPP).

  • The SA series cards (except the EH1D2X12SSA0 and ET1D2X12SSA0 cards) do not support multi-interface ARP.

  • On the S5720I-SI, S5720S-SI, S5720SI, S5730S-EI, S5730SI, S6720S-SI, and S6720SIwhen the outbound interfaces are Eth-Trunk interfaces, you must run the load-balance command to configure load balancing based on IP addresses. Otherwise, the configuration does not take effect.

  • On switches except the S5720I-SI, S5720S-SI, S5720SI, S5730S-EI, S5730SI, S6720S-SI, and S6720SI, when the outbound interfaces are Eth-Trunk interfaces, you must run the unknown-unicast load-balance enhanced command to configure the load balancing mode for unknown unicast traffic on the interfaces. Otherwise, the configuration does not take effect.

  • In a VPN scenario, switches that support VPN and run V200R010C00 and later versions can be connected to an NLB cluster. A client and the server that the client accesses must be in the same VPN.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Create a VLAN on the Switch and add the interfaces to the VLAN.
    <HUAWEI> system-view[HUAWEI] sysname Switch[Switch] interface gigabitethernet 1/0/1[Switch-GigabitEthernet1/0/1] port link-type access[Switch-GigabitEthernet1/0/1] quit[Switch] interface gigabitethernet 1/0/2[Switch-GigabitEthernet1/0/2] port link-type access[Switch-GigabitEthernet1/0/2] quit[Switch] interface gigabitethernet 1/0/3[Switch-GigabitEthernet1/0/3] port link-type access[Switch-GigabitEthernet1/0/3] quit[Switch] vlan 10[Switch-vlan10] port gigabitethernet 1/0/1 to 1/0/3[Switch-vlan10] quit

  2. # Create a VLANIF interface on the Switch and assign an IP address to the VLANIF interface.

    [Switch] interface vlanif 10[Switch-Vlanif10] ip address 10.128.246.251 24[Switch-Vlanif10] quit

  3. Configure a MAC address entry mapping multiple outbound interfaces on the Switch.

    [Switch] mac-address multiport 03bf-0a80-f6fc interface gigabitethernet 1/0/1 to gigabitethernet 1/0/3 vlan 10  //Configure a MAC address entry mapping multiple outbound interfaces

  4. Configure static ARP entries on the Switch.

    [Switch] arp static 10.128.246.252 03bf-0a80-f6fc //The short static ARP entries must be configured here.[Switch] quit

  5. Verify the configuration.

    # Run the display mac-address multiport vlan 10 command on the Switch to check the configured MAC address entry mapping multiple outbound interfaces.

    <Switch> display mac-address multiport vlan 10--------------------------------------------------------------------------------
    MAC Address       VLANID    Out-Interface               Status  
    --------------------------------------------------------------------------------
    03bf-0a80-f6fc    10        GigabitEthernet1/0/1        Active                                
                                GigabitEthernet1/0/2        Active                                
                                GigabitEthernet1/0/3        Active                                
                                                3 port(s)                           
    --------------------------------------------------------------------------------
     Total Group(s) : 1 
    

    # Run the display arp static command on the Switch to check static ARP entries.

    <Switch> display arp staticIP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE  
                                              VLAN/CEVLAN                           
    ------------------------------------------------------------------------------
    10.128.246.252  03bf-0a80-f6fc            S--         Multi-port:3            ------------------------------------------------------------------------------  
    Total:1        Dynamic:0      Static:1     Interface:0 
    

Configuration Files

Switch configuration file

#
sysname Switch#
vlan batch 10 
#
interface Vlanif10
 ip address 10.128.246.251 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10 
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
arp static 10.128.246.252 03bf-0a80-f6fc
#
return

Applicable Product Models and Versions

Product

Product Model

Software Version

S5700

S5700HI

V200R003C00, V200R005(C00&C01)

S5710EI

V200R003C00, V200R005(C00&C01)

S5710HI

V200R003C00, V200R005(C00&C01)

S5720SI and S5720S-SI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720I-SI

V200R012C00, V200R013C00

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5730HI

V200R012C00, V200R013C00

S5730SI

V200R011C10, V200R012C00, V200R013C00

S5730S-EI

V200R011C10, V200R012C00, V200R013C00

S6700

S6700EI

V200R003C00, V200R005(C00&C01)

S6720SI and S6720S-SI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720HI

V200R012C00, V200R013C00

S7700

S7703, S7706, and S7712

V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S7703 PoE

V200R013C00

S7706 PoE

V200R013C00

S9700

S9703, S9706, and S9712

V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

See more please click 

https://support.huawei.com/enterprise/en/doc/EDOC1000069520/9aadccc0/comprehensive-configuration-examples


  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top