[Insider Sharing] Cisco&Huawei MSTP scenario disclosed.

Created Jan 29, 2014 17:31:58Latest reply Aug 06, 2014 17:29:25 5720 1 0 0

Hi Guys,


Having a loop-free network in a multi-vendor environment not an easy point to achieve, that's why, I think you will consider this case useful. We will use MSTP to integrate Cisco & Huawei switches in the same loop free domain. 

Topology is simple, there are 2 Cisco S3560 and 4 Huawei S6700 switches as below: 

We have more than one business VLAN in the network (Let's say : vlan10, vlan20, vlan30). It needs to work in load-balancing way, associated to a MSTP instance.

Cisco device: use MST protocol, the interface that connects to Huawei SW using a Trunk port.
Huawei device: use MSTP protocol, the interface that connects to Cisco SW using a Trunk port. 

Key configuration points:
Cisco device: CISCO-1 is configured as ROOT in MSTP instance 0; the entire network is using the same path-cost algorithm, the interface that connects to the user PC is an edge port.
Huawei device: HW-1 is configured as ROOT in MSTP instance 1; the entire network is using the same path-cost algorithm, the interface that connects to CISCO ring should be configured with digest snooping, the interface that connects to user’s PC is an edge port.



Configuration: 

!

spanning-tree pathcost method short              

spanning-tree mode mst

!

spanning-tree mst configuration

name test

revision 0

instance 1 vlan 20, 30             

spanning-tree mst 0 priority 4096           

!

interface GigabitEthernet0/1                   

switchport                                                            

switchport trunk encapsulation dot1q 

switchport mode trunk

switchport trunk allowed vlan 10,20,30

!

interface GigabitEthernet0/11                 

  switchport mode access

  switchport access vlan 10

  spanning-tree portfast          

!

 

Huawei device:

 

#

stp pathcost-standard dot1d-1998                                    \\ adjust patch cost algorithm to be the same as cisco's method short

stp instance 1 priority 4096             

stp enable

stp mode mstp

#          

stp region-configuration

  region-name test

  revision-level 0

  instance 1 vlan 20 30

active region-configuration 

interface GigabitEthernet0/0/1               

  port link-type trunk

  port trunk allow-pass vlan 10 20 30

  stp compliance dot1s                                                     \\ make it compliant with IEEE 802.1s

  stp config-digest-snoop                                                \\ solves BPDU keys inconsistency

  bpdu enable                                                          

#

interface GigabitEthernet0/0/11                      

  port link-type access

  port default vlan 10

  bpdu enable

  stp edged-port enable                                      

#


Notice:

1. the interface on Huawei SW that connects CISCO ring should be configured with digest snooping, command: stp config-digest-snoop.

On an MSTP network where Huawei and non-Huawei devices are interconnected, if the Huawei and non-Huawei devices have the same region name, revision level, and VLAN mapping table but different BPDU keys, the stp config-digest-snoop command can be used to enable the Huawei and non-Huawei devices to exchange BPDUs.

2. CISCO C4500/C3750/3560/ME3400 SW default road-cost algorithm is short, corresponding Huawei is 802.1d-1998. However Huawei device default way is 802.1t, corresponding CISCO long algorithm. 

3. Interfaces that connects to user device, should be configured as edge ports in order to avoid them to participate to STP process and speed up convergence time. We can configure on Huawei SW: stp edged-port enable or stp disable. 

4. For Huawei switches you need to configure bpdu enable  to allow bpdu packet processing;S77, S57, S37 series require this command under interface-view, S27 series under system-view. 

5. The network topology can be improved by adjusting the port path cost, commands:



[HUAWEI-GigabitEthernet0/0/11]stp cost ?

INTEGER<1-65535>  Port path cost  

CISCO(config-if)#spanning-tree cost ?
  <1-200000000>  port path cost


That's all! Post here if you have any questions.

  • x
  • convention:

nileshkahar     Created Aug 06, 2014 17:29:25 Helpful(0) Helpful(0)

This is very good information.
  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top