How Do I Configure Multiple dhcp pools for Multiple VLANs on Switch?

Created: Mar 30, 2019 15:23:32Latest reply: Mar 30, 2019 15:30:09 56 1 0 0
  Rewarded Hi-coins: 0 (problem resolved)

  How Do I Configure Multiple dhcp pools for Multiple VLANs on Switch,The switch is S5720.

 

  • x
  • convention:

Featured Answers
DDSN  Visitor   Created Mar 30, 2019 15:30:09 Helpful(0) Helpful(0)

Hi dear, 

If you only want to allocate different address pools to different VLANs, here is a sample configuration from S5700:

vlan batch 10 20
#
ip pool 10
gateway-list 192.168.1.1
network 192.168.1.0 mask 255.255.255.0
dns-list 10.0.0.1
#
ip pool 20
gateway-list 192.168.2.1
network 192.168.2.0 mask 255.255.255.0
#
interface Vlanif10
ip address 192.168.1.1 255.255.255.0
dhcp select global
#
interface Vlanif20
ip address 192.168.2.1 255.255.255.0
dhcp select global
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 10
port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20

If you want to apply DHCP to a subnet-based VLAN, that’s a bit more complicated. You can check out the below link for configuration details: http://support.huawei.com/hedex/ ... E%2BConfiguration.
  • x
  • convention:

All Answers
DDSN  Visitor   Created Mar 30, 2019 15:30:09 Helpful(0) Helpful(0)

Hi dear, 

If you only want to allocate different address pools to different VLANs, here is a sample configuration from S5700:

vlan batch 10 20
#
ip pool 10
gateway-list 192.168.1.1
network 192.168.1.0 mask 255.255.255.0
dns-list 10.0.0.1
#
ip pool 20
gateway-list 192.168.2.1
network 192.168.2.0 mask 255.255.255.0
#
interface Vlanif10
ip address 192.168.1.1 255.255.255.0
dhcp select global
#
interface Vlanif20
ip address 192.168.2.1 255.255.255.0
dhcp select global
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 10
port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20

If you want to apply DHCP to a subnet-based VLAN, that’s a bit more complicated. You can check out the below link for configuration details: http://support.huawei.com/hedex/ ... E%2BConfiguration.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top